Black screen when booting with nvidia drivers.

I’m a total newbie to SUSE. Everything works fine in nouveau when I install it but when I run:

zypper install x11-video-nvidiaG03

and then reboot I get a black screen. When I boot into recovery mode everything is fine and when I remove these new drivers then I can boot normally again.

Am I just using the wrong driver? My card is a GTX 650 TI. Let me know if there is any more information I can provide that will help.

These are the instructions that I followed:

https://en.opensuse.org/SDB:NVIDIA_drivers

Try G02 flavor

I tried that as well. At first it worked, but then when I opened up the nvidia settings it crashed and would no longer boot without a black screen.

Did you fully remove the G03 Driver before installing the GO2? It could leave bits that are incompatible…

So reinstall GO3 then UNINSTALL it to get rid of all. Then install GO2

Just to be totally clear is this a Optimus based notebook??

Okay. I did it the graphical way by just downloading:

http://opensuse-community.org/nvidia-gf6_gf7.ymp

after a new reinstall and it worked this time I think. Last time I tried using Konsole. My computer started without any problems in desktop mode.

I am using the drivers, but it seems that some settings are being locked.

I can’t set my resolution above 1024x768, and when I try to rotate my second display (which is vertical upright) nothing happens.

I’m not using a notebook I am using a desktop.

Nevermind. Upon restarting I can no longer boot in anything but recovery mode.

Please follow gogalthorpe’s advice, as at quick glance it looks like you probably still have parts of the G03 driver in there, and that just will not work with combined driver parts and versions.

Did you fully remove the G03 Driver before installing the GO2? It could leave bits that are incompatible…

So reinstall GO3 then UNINSTALL it to get rid of all. Then install GO2

Ok Not sure were you are now???

Do you have a working NVIDIA driver and the problem now is resolution of the screen?

Are you using a KVM switch?? In any case this is normally a problem that the monitor is not reporting it’s resolution to the computer. So you have to force it with an edit to xorg.conf

I have to change mine since the monitor is 1600x900 and the computer does not see it because of my KVM switch

So in /etc/X11/xorg.conf file


Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       55.0 - 83.0
    VertRefresh     50.0 - 75.0
    ModeLine        "1600x900_60.00" 119.00 1600 1696 1864 2128 900 901 904 932 -HSync +Vsync

EndSection


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 210"
EndSection

#Section "Screen"
#   Identifier     "Screen[0]"
#    Device         "Device[0]"
#    Monitor        "Monitor[0]"
#    DefaultDepth    24
#    SubSection     "Display"
#        Depth       15
#        Modes      "1920x1080" "1280x1024" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
#    EndSubSection
#    SubSection     "Display"
#        Depth       16
#        Modes      "1920x1080" "1280x1024" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
#    EndSubSection
#    SubSection     "Display"
#        Depth       24
#      Modes      "1920x1080" "1280x1024" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
#    EndSubSection
#    SubSection     "Display"
#        Depth       8
#        Modes      "1920x1080" "1280x1024" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
#    EndSubSection
#EndSection

Section "Screen"

# Removed Option "metamodes" "1600x1200 +0+0; 1280x1024 +0+0; 1280x960 +0+0; 1152x864 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "1600x900 +0+0;1280x1024 +0+0; 1280x960 +0+0; 1152x864 +0+0; nvidia-auto-select +0+0; 800x600 +0+0; 640x480 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    Modes      "1920x1080" "1280x1024" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
EndSection



You have to create a modline

example here


gtf 1024 768 85

1024×768@85Hz.

Once that is added you can then choice it in the normal desktop setup functions

I did a clean reinstall and installed the GO2 drivers.

The computer booted after a restart to desktop, but once again I was unable to change any graphical settings in the Nvidia settings.

Then, after doing a full shut down and boot I once again only boot to a black screen and can only boot in recovery mode.

I am not using a KVM switch. My monitor has a DVI connection straight to the computer and the resolution is picked up perfectly fine in Nouveau.

I have also a Nvidia GTX 650 TI, the card is working with the G02, G03 and G04 driver.

But I have not installed it from Repository, I have installed it in RunLevel 3 with the Driver from Nvidia.

lspci -nnk | grep -iA2 vga
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106 [GeForce GTX 650 Ti] [10de:11c6] (rev a1)
        Subsystem: eVga.com. Corp. Device [3842:3653]
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia
nvidia-settings -v

nvidia-settings:  version 346.35  (buildmeister@swio-display-x86-rhel47-09) 
Sat Jan 10 21:57:03 PST 2015
  The NVIDIA X Server Settings tool.

  This program is used to configure the NVIDIA Linux graphics driver.
  For more detail, please see the nvidia-settings(1) man page.

  Copyright (C) 2004 - 2010 NVIDIA Corporation.

I have no /etc/X11/xorg.conf, nomodeset as Kernel Parameter in the Grub-Commandline and a blacklist-File.

grep "blacklist nouveau" /etc/modprobe.d/*
/etc/modprobe.d/nvidia-installer-disable-nouveau.conf:blacklist nouveau

Okay, so you’re basically telling me to just install the drivers from Nvidia’s website and ignore what’s in repos?

https://en.opensuse.org/SDB:Switch_runlevel

The same way I would in this guide? Then when I’m finished I switch it back to 5?

What about updates? If the nvidia drivers don’t add anything to repos do I just have to do this manually?

Also what is the best way to blacklist nouveau? Keep in mind I’m used to Mint where it holds my hand on everything.

When I install nvidia drivers “the hard way”, I find it easiest to simply add “nomodeset” to the kernel boot command.

In “/etc/default/grub” find the default line and add " nomodeset" to the end. Then run


# grub2-mkconfig -o /boot/grub2/grub.cfg

The “nouveau” driver will not be loaded because of the “nomodeset”.

Okay, so you’re basically telling me to just install the drivers from Nvidia’s website and ignore what’s in repos?

No, I only say, this Graphics Card is working with Linux.

The above is my way to install the Driver, I also do not do the nvidia-xconfig because it will build a /etc/X11/xorg.conf wich is unnecessary and may cause errors.

Install the Driver from Repo, after Installation see if there is no /etc/X11/xorg.conf, add nomodeset to the Grub2 by Yast2, and see if there is a blacklist-File for Nouveau in /etc/modprobe.d.

grep "blacklist nouveau" /etc/modprobe.d/*

Then restart your Computer.

As strange as it may sound, the Nvidia drivers have to have a properly working VNC and RDP in order to work.
Which means that Xorg will stall out unless your loopback on your localhost is clearly defined (127.0.0.1)

So it may actually be an issue with your network settings and not just your video card drivers.

A quick work around is to use [ALT] + [F3] to get a command line in text mode and login as root.
Then type in ‘yast2’ and use your arrow keys to navigate to network settings to make sure
that your primary and secondary DNS servers are set to what your ISP uses and that
your localhost is (127.0.0.1).

Okay, I tried blacklisting nouveau in grub first.

Tried to install the driver from nvidia’s website directly, got the same issue.

Tried to install G02, G03 and G04 after completely removing the one that came before it.

For some reason 03 and 04 worked after a restart but then this problem continued after a full shut down. Could no longer boot in anything but recovery mode.

I tried installing the nvidia drivers in another PC to see if I could recreate this problem, but the drivers worked fine. No issues at all. this PC is using a GT 210.
As pwchapman92 suggested I checked my network settings. Everything was normal.

I also tried everything listed here:

https://en.opensuse.org/SDB:NVIDIA_the_hard_way

Something about doing a full shut down seems to cause this. I can uninstall and reinstall the drivers in safe mode and it will boot once but when I do a full shut down it happens again.

I can uninstall and reinstall the drivers in safe mode

Install it in Runlever3, thats without any X.

And you have no other Graphics-Card inside:

/sbin/lspci -nnk | grep -iA2 vga

I’ve tried installing the drivers in runlevel 3 as well.

When I type [init 5] the computer loads up that initial green loading graphic but then freezes.

Do you have an Intel CPU? if so does it have a built in GPU?? if so have you disabled that GPU in the BIOS ???

Is this a notebook does it have Optimus tech?

I am not using a laptop.

I have an i7-4790K, it does have Intel graphics but I’d rather not disable them unless I absolutely have to. I think the problem has something to do with my configuration. I’ve noticed that as long as I never open the nvidia settings my PC will continue to boot and reboot with the drivers and it DOES let me change display options using the default KDE software.

However, when I install Steam I get this message:

“OpenGL GLX extension not supported by display”.

Is this some kind of clue? I have read online that this error has to do with nouveau clashing with the nvidia drivers but I can’t find anything specific to OpenSUSE about how to fix it. I think the nouveau drivers just aren’t completely disabled. I have added nomodeset to grub and then ran

/usr/sbin/grub2-mkconfig --output=/boot/grub2/grub.cfg

and then

sudo echo "blacklist nouveau" > /etc/modprobe.d/50-blacklist-nouveau.conf

Is there something I am missing? Is there a way to check which driver is actually in-use?