Black screen sfter installing openSUSE 11.2

After entrring the command sax2 -r -m 0=vesa nothing happens. I wait for 2 minutes but nothing happens, so I have pressed CTRL-C… :frowning:

Very strange… entering the command sax2 (without options) should start the video configuration, or I remember wrong?
But here nothing happens… nothing starts… mmmh…

maybe you’re right, but I don’t know how many users have the same kind of problem.
Googling for a while, I have found that a problem like mine is common for openSUSE users. 99% of times this is caused by the video configuration after installing openSUSE form CD/DVD.

It does appear I had a random check that is not accurate, further checking does not support my previous post. oops!

sax2 is definitively a death-command… I have opened the PC cabinet, cleaned it with an hoover and I have checked all cables. All seems ok…

I have closed the cabinet and turned on the PC again. Nothing to do… always black screen…

sax2 is in essence a wizard for creating an /etc/X11/xorg.conf file. Worst comes to worst and one simply delets the /etc/X11/xorg.conf file.

But again, sax2 has MANY input arguments.

Also, with (and without) an /etc/X11/xorg.conf in place, the command ‘startx’ also has many input arguments possible.

In my case, I never have much patience to deal with X boot problems, and if a boot does not work properly, and if I have made (give my average experience level) what I believe to be a good effort to get X to work , then I will stop and write a bug report (and then support the packagers in trying to resolve the bug report).

Are you suggesting yo delete the xorg.conf file? So a new one will be created at boot?

Yes, but they don’t works… (for example the ‘-a’ options) sax2 only print:

initializating please wait...
your current congiguration will not be read in

but after nothing happens.

Do you thing that I should write a bug report? To who? Where?

No xorg.conf file is not required normally for 11.2. You may have one to deal with problem hardware though. So if you delete or rename it it will NOT be recreated on a reboot. Only if you run a sax2 command.

Most sax2 options only change the xorg.conf file and do nothing else.

For more information type

man sax2
info sax2

Hi oldcpu, while typing to you… openSUSE has started normally on the other PC!
Again I see the desktop screen and all is working normally. I think that ghosts are living in that PC! :slight_smile:

I have immediately copied the xorg.conf file to my usb key. Here are the contents, as you can see, is a very basic configuration file using only two resolutions and the standard fbdev driver:

# /.../
# SaX generated X11 config file
# Created on: 2010-04-07T17:06:34+0200.
# Version: 8.1
# Contact: Marcus Schaefer <>, 2005
# Contact: SaX-User list <>
# Automatically generated by [ISaX] (8.1)
Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"

Section "Module"
  Load         "dbe"
  Load         "glx"
  Load         "dri"
  Load         "extmod"

Section "InputDevice"
  # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section. 
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "it"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"

Section "InputDevice"
  # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section. 
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "9"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImExPS/2 Logitech Explorer Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"

Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  376 301
  HorizSync    30-80
  Identifier   "Monitor[0]"
  ModelName    "HANNS.G HX191"
  Option       "DPMS"
  Option       "PreferredMode" "1280x720"
  VendorName   "HSD"
  VertRefresh  43-75
  UseModes     "Modes[0]"

Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1280x1024" 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +HSync +VSync
  Modeline 	"1024x768" 78.65 1024 1056 1184 1312 768 772 776 792

Section "Screen"
  SubSection "Display"
    Depth      15
    Modes      "default" 
  SubSection "Display"
    Depth      16
    Modes      "default" 
  SubSection "Display"
    Depth      24
    Modes      "default" 
  SubSection "Display"
    Depth      8
    Modes      "default" 
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"

Section "Device"
  BoardName    "Framebuffer Graphics"
  Driver       "fbdev"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "VESA"

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"

Section "DRI"
    Group      "video"
    Mode       0660

Section "Extensions"

Now I’m scared to turn-off PC… now is working, maybe the right solution is to never turn-off it! rotfl!

I have opened a terminal on the desktop and started the sax2 command. All works fine, sax2 show me settings and configurations.
When I have started the same command from the text terminal it doesnt started… why?
Now I try a low screen resolution

The file is setting

Driver “fbdev”

frame buffer devices
this is a very very basic driver with very few options. You are probably stuck with a single resolution.

Yes, I know that. But it should work with any resolution! Now I have lowered the resolution to 800x600 (using sax2) and it works.

After I have reboted the system…

one time… (it works)
two times… (it works)
three times… black screen again! :open_mouth:

I’m really stuffed… :disapointed:

I’m convinced myself that must be two only explainations:

  1. openSUSE 11.2 DVD include some software bug;
  2. my integrated video card is damaged and I must buy a new PC.

Now I have found my old openSUSE 11.1 DVD and I reinstall again openSUSE 11.1 (I don’t know how many times I have reinstalled linux in this days…)
If 11.1 works, the explaination (1) is the most probable.

I would be suspect of an xorg.conf created by sax2 from a terminal.

wrt the xorg.conf that you posted:

Section "Device"
  BoardName    "Framebuffer Graphics"
  Driver       "fbdev"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "VESA"

as noted by gogalthorp this xorg is using the most basic of video drivers. The fbdev has even slower performance than the vesa driver.

You mentioned you have 2 identical PCs … both running openSUSE and one has the problem and one does not. I have in idea if the hardware is 100% identical. Can you please type type on both PCs:

rpm -qa '*Mesa*'
rpm -qa '*driver*'

and post here the output of both, noting which output corresponds to which PC. If the outputs are the same, try copying the xorg.conf from the functional PC to the semi-functional PC and then reboot.

And as noted by gogalthorp, in many cases for many types of hardware, one does not need an xorg.conf file on openSUSE. My guess is your problematic PC may need such a file, but you can remove the file and try booting.

Hi oldcpu,

sorry but I’m tired of this situation… after more than 3 days I cannot use the second PC.

A) Working PC was an openSUSE 11.1 system upgraded to 11.2 via internet connection.

B) Not-Working PC is an openSUSE 11.2 installed by the downloaded DVD iso image.

So I have decide to repeat the same steps that I have done for the PC A:

  1. I have installed the old openSUSE 11.1 version from my old DVD;
  2. I have executed standard installation without touching nothing;
  3. I have turned off PC 5 times;
  4. I have restarted PC 5 times;
  5. and… IT WORKS!

Really, no problem at all, all works like it must be.

Answer is only one: the downloaded openSUSE 11.2 DVD contains a big big bug! I’m sure of this. I have trowed it in my trash bin and I suggest to not waste time with that stuff…>:(

Now I’m gone to install internet connection to:

  1. upgrade to 11.2 version through internet;
  2. downloading and installing openchrome drivers for my AGP videocard.

Its also possible your 11.2 download was bad or your burn was bad, and the trash may be where this DVD belongs.

Glad to read you are making some progress.

It could be… I was thinking to that yesterday; I have not checked the MD5 signature of the iso file before burning it on the DVD… and I have deleted that file…:frowning:

Now I don’t know how to be sure that the DVD was not damaged in some way…:\

Well since you trashed it, … sort of bribing the garbage men with a bottle of scotch :stuck_out_tongue: … there is not much else … :slight_smile:

Well, thats not quite true :slight_smile: Assuming you can still lay your hands on the dvd, you could try this: how to check a burned dvd with opensuse . It was written for 11.1 but it applies to 11.2 also.

the dvd is in trash bin near the desk… ok I have picked it! Now I check…:wink:

Wow! DVD is running running running… it’s normal that the process takes so long time?

Below results of the checksum:

295d713314a30ad017948f0d542c6d92 (after excuting the **md5sum image11.iso**)
295d713314a30ad017948f0d542c6d92 (from the opensuse web page)

They are identical…:expressionless:
So the DVD fly again to the trash-bin! et voilà! lol!

I’m little confused… I have applied all of upgrades to openSUSE 11.1 version as recommended before upgrading to the 11.2 version. I have used Yast to perform the updating process

(please note that using the openSUSE 11.1 the black screen phenomena has completely disappeared :))

Now I want upgrade to 11.2 using the live upgrade (without burning a DVD/CD). I have done this task many weeks ago, but now I don’t remember how I have excuted this task.
As I remember, I have used only Yast… no Wagon and no Zypper… but I really don’t remember the process… can you point me to the right web page containing the istructions? :\


After spending all night on the PC I have definitively solved the problem. Here follows the facts:

  1. I have two identical PC mounting the ASUS M2V-TVM board with integrated video board with 256 MB and the Fritz!wlan stick plugged in the USB port.

  2. PC-A is working normally under openSUSE 11.1 upgraded to 11.2 directly through internet connection.

  3. PC-B was mounting WindowsXP and my intention was to erase it and replicate configuration of PC-A on PC-B.

  4. After installing openSUSE 11.2 from the downloaded DVD on the PC-B, I’ve got a lot of black screen after booting/turning-on the PC.

  5. Downloaded DVD was checked against the md5sum. Installation steps was absolutely standard, no strange option was set during the installation process.

  6. Black screen was appearing 80% of times after a reboot or after turning on the PC. So behaviour of the PC-B was not stable and the PC itself was unuseful. :frowning:

  7. I have repeated the installation process 5 or 6 times, without solving the problem of the black screen.

  8. After, I have installed the openSUSE 11.1 from my old downloaded DVD. PC-B has started to work normally, no more black screen. All was perfect.

  9. After downloading all of the patches for the 11.1 (using a cable to connect directly to my wifi-router), all was still working perfectly, but I still cannot install my AVM Fritz!lan stick under 11.1 (it prompts for some kind of firmware to be updated).

  10. Using the published istructions, I have updated the PC-B from 11.1 to 11.2 (big time for downloading all packages!). After this, 11.2 was working normally, no blackscreen.

  11. After this, I was coming back on my steps again. I have erased the working openSUSE 11.1 -> 11.2 from PC-B :open_mouth: and I have reinstalled openSUSE 11.2 from DVD. :open_mouth:

  12. Without turning off the PC I have executed the “Online update” using Yast and I have downloaded all of the patch/update for the 11.2 version (big download/installation time!). I was lucky 'cause I had a cable to establish an internet connection.

  13. After a complete update of the 11.2 I have turned-off/rebooted the PC-B many times. No more black screen! All was working perfectly.

  14. Problem in installing my Fritz!wlan has disappeared on the 11.2 version. By following published istructions (ndiswrapper) I have excuted the task in 5 minutes.

  15. Now PC-B is perfect.

What are the conclusion of all above? My conclusion is only one: if you install openSUSE 11.2 from the DVD and you have no internet connection then you’re going to get a mountain of problems. The basic installation obtained from the DVD is largely unstable (in my opinion), while the 11.1 was robust and stable.

To resume:

  • if you install openSUSE 11.2 from DVD you MUST have an internet connection through cable. Wifi sticks are useless.

  • After 11.2 installation is completed, don’t turn-off your PC (important!) but apply immediately all of the patch/update available for the 11.2 version using Yast -> Online update.

I repeat, I was lucky 'cause I have found an old internet cable in the cellar to get a stable internet connection. If not, Bill Gates was acquiring a new client… :slight_smile:

I hope that this helps.

Congratulations on solving this.

That is interesting to read. It suggests to me that there was an update in the 11.2 updates that fixed the problem. Given this was a basic problem in booting, I suspect this may have been fixed by the change of the kernel from to Those sorts of fixes are rare, but they do happen on occasion.

This is very true. The time when this was MOST important was when openSUSE-10.1 was unfortunately released with a buggy software package manager. It was so buggy, it would NOT update software via the YaST Software Package Manager. Hence even if one had a fix, one could not install it via YaST. One was left with an openSUSE install that could only update software via the basic rpm command. Some of us were not impacted because we used the Smart Software Package manager, but that was not the case for 95% of openSUSE users and the uproar of upset users was massive. There was a mass exodus of openSUSE users to other Linux distributions with that release. I lost two close friends from openSUSE to Ubuntu on that release (one has subsequently come back to openSUSE, and the other subsequently left Ubuntu for Windoze - but I diverge).

Eventually Novell released a partial fix for the openSUSE-10.1 package manager problem (although it was never completely fixed - the problem went far too deep) and users who could install with an online Internet connection managed to get the fix and did not have the problem as bad as those who did the install with no internet connection.

I always try hard to get a wired connection when ever I do an openSUSE install.