Black screen sfter installing openSUSE 11.2

Hello, I have registered a problem similar to the one reported in this thread: Solution to black screen problem in opensuse11.2 - openSUSE Forums
after installing openSUSE 11.2 from DVD, and rebooting the system a blank screen appears after booting process is completed.

Initially, I was thinking that was 'cause of the installation of ndiswrapper drivers (see command “modprobe ndiswrapper” not working - openSUSE Forums) but after the 4th (!) installation of openSUSE I really don’t know what to think… :\

Sometimes openSuse boots regularly, and sometimes not… seems that there is no difference if I restart the PC or I turn it off and then off. Result is the same: sometimes I get the user desktop and sometimes not… :open_mouth:

As explained in my previous post, I have checked the disk but all seems ok.
Now I cannot use the PC even in failsafe mode… I get always a black screen.
But what is more surprising is that I have 2 identical (identical!) PC with the identical hardware, and identical bios configuration. Only the monitor is different. Well, said that, one is working the the other one not…:frowning:
To be honest, the working PC was an openSUSE 11.1 systems updated to openSUSE 11.2.

I think that must be something wrong on the distributed openSUSE DVD…

Any idea? In the meanwhile, I go to the bad PC and turned it repeatively to see if it starts correctly… :sarcastic:

Could it be the bad PC is indeed bad ? ie the bad PC hardware is starting to fail ?

What graphic driver are you using? EXACTLY what graphic hardware is in use here?

When you are having the “refuse” to boot problem, are you able to boot to run level 3 direct from the grub/boot/splash menu by pressing 3 so that 3 appears in the options line, followed by selecting a regular boot.

Again, ensure your hardware is good.

hi oldcpu, hardware bad? It could be, obviously… but I think this is not the problem.
Before yesterday, after last virus, I have removed WindowsXP-Professional and installed WindowsXP-Home without any problem, all was working perfectly.
After this, I have decided to erase completely windows and install openSUSE from the scratch.

Do you remember our long thread about my VIA VT3336: K8M890 01:00:0 0x1106 0x3230 AGP via problems? (see Via Chrome9 resolution problem - openSUSE Forums). Well, the hardware is the same, 'cause I bought two identical PC in the same shop.

Yes, in thread above you teached me how to use the init 3 option when booting. But, after that I have got the linix prompt what can I do?
I have started the sax2 video configuration, but the standard video settings seems ok to me: 1280x1024 with 65000 colors. Even the LCD monitor is detected correctly: Hanns-G 19’’.
So, seems all ok to me. :\

Problem is not concerning the poor performances of my video card (as in the thread reported above), is different: linux boot normally, then I see the “automatic login” window for, maybe, half second. After that, screen becomes black with the mouse in the center (mouse is not freezed).

I have tried to decrease resolution to 1024x768 using sax2, but it has solved nothing.
Another mistery: now I have restored resolution to the original size and… wow! desktop has appeared and working normally after restarting.
mmmmhhhh… I have done nothing! :\

Now I try again to turn off/on PC many times to see if problem is still here…

Ahhh … chrome9. … I think that was the time that user “consused” bailed me out of difficulty.

It it ain’t broke, don’t fix it !! rotfl!

Did you ever read the guide that user user “consused” contributed? It is here: openSUSE Forums - View Single Post - openSUSE Graphic Card Practical Theory Guide for Users - via/chrome hardware/drivers

Problem is still here :frowning:

I have turned off PC and turned on again, and the problem… is returned!
Was working ok few minutes ago! I became crazy… sometimes works, sometimes not… :disapointed:

And I touch nothing… even the Failsafe mode is not working…
The sax2 -p command writes

VESA Framebuffer graphics ..[omissis]... AGP fbdev

I could try to install Chrome9 drivers as I have done for the other PC, anyway I think that the default driver should work even with poor performances.
Anyway, after that openSUSE installation is completed, the system run normally. You can install drivers, printers, anything. But if you turn off and try to turn on again… black screen…

When it doesnot work, take a copy of the /var/log/Xorg.0.log file, and mark it according (date/time of occurrence) as a separate file. Do the same for the dmesg. Then maybe you can see what was happening.

To enable you to do this, try <ctrl><alt><f2> to get a full screen text console so you can do those activities. And if that does not work, then boot to a live CD (so you do not change the files) and then from the liveCd make a copy of those files on to a memory stick.

You need to start creating a record as to what is happening when this occurs.

Yes, I read that guide while solving problem with the graphic chipset, but now the problem is not concerning performances… even the poor and basic VESA driver should work, or not?

I see that graphics card works,

I see the test screen of the sax2;
I see the background screen when linux is loading;
I see, for a fraction of second, the automatic login window appearing;

after… I see a black screen with the (no freezed) mouse in the middle…:frowning:

Uh! while writing I have turned on the PC again and… it works!:open_mouth: If I turn left my chair of 180 degree I can see the gnome desktop! All icons loaded as well as the bar at the bottom of the screen.

Really, I’m not joking… now the system has started normally. I really don’t know what to think…:\

where is located the dmesg file? Uh! maybe I must pipe the command to a file? I don’t remember how to do this… :frowning: too many years using windows!

I have restarted the PC and black screen has returned.

<ctrl><alt><f2> combination works, I have produced two txt files, but now how I can copy them to the usb key in the text-mode? :stuck_out_tongue:

I’m bad ! … apologies …

I tend to get lazy in my descriptions. My understanding is by typing “dmesg” one’s terminal will display the contents of the /var/log/boot.msg file. Now dmesg will scroll by the screen too fast and so one can type “dmesg > dmesg.txt” and look at dmesg.txt in a text editor.

Or, rather than scurry around in the mystery of this bizarre dmesg command, one could simply open up /var/log/boot.msg (or copy it some where) with a text editor.

On 04/07/2010 12:06 PM, giulio buccini wrote:
> oldcpu;2149175 Wrote:
>> When it doesnot work, take a copy of the /var/log/Xorg.0.log file, and
>> mark it according (date/time of occurrence) as a separate file. Do the
>> same for the dmesg. Then maybe you can see what was happening.
> where is located the dmesg file? Uh! maybe I must pipe the command to a
> file? I don’t remember how to do this… :frowning: too many years using
> windows!

The operation you want is “redirect”. You “pipe” information from one
program to another. Some examples:

dmesg > dmesg.out Redirect the output of dmesg to a file.
dmesg >> dmesg.out Append the dmesg output to the file.
dmesg | grep error Pipe the output of dmesg to program grep

I have done exactly what you wrote, now I have two txt files: xlog.txt and dmesg.txt and I want to examine them on the working PC, but how I can copy them to the USB key? Using the text mode I don’t know which mounted device I must use…

I have turned on/off/restarted my PC many times, but now I get only black screens a go-go (like french says).

Last time I’ve got a singular behaviour: the “automatic login” dialog window (that usually stays on the screen for a fraction of second) was… freezed!:open_mouth:
The system was completely blocked… below, a strange bottom bar was displayed, with strange icons.
In the dialog windows there was two buttons: “cancel” and “login” but was both disabled, so I cannot do anything else than turning off the PC.

This kind of things was not happening with openSUSE 11.1… I’m not so sure that 11.2 version is so stable…:sarcastic:

This takes average knowledge (to do in text mode). Start the following with USB stick not plugged in.

Create a directory /home/username/disk

mkdir /home/username/disk

Then run fdisk to identify the nominal setup without usb stick:

su -c 'fdisk -l'

and enter root password when prompted. Take a look at the drives (maybe only sda with a bunch of sdax where x is 1 to some number).

Then plug in the usb stick and run again:

su -c 'fdisk -l'

and enter root password when prompted. Take a look at the drives and you should see an extra one that was not there when you ran fdisk with no usb stick plugged in. That extra drive is your usb stick. Perhaps it will be sdc or sdb. Lets say its sdb. And there should be a partition on it, likely called sdb1.

So to mount that partition:

su -c 'mount -t vfat -o rw,users,uid=username /dev/sdb1 /home/username/disk'

and enter root password where prompted. Note that “username” is your username in all the above.

The usb stick will be mounted under /home/username/disk

Once everything is copied to /home/username/disk, then you can unmount with:

umount /home/username/disk

note it is “umount” and not “unmount”

Hi oldcpu,

thanks for the super-fast course on linux commands, expecially for the difference between unmount and umount that made me crazy every time when I was at university. By the way, somebody knows why the command is called “umount” and not “unmount”?? :slight_smile:

Said that, I have copied log files that I have produced by pressing <crtl><alt><F2> keys during the “black-screen” situation.
Honestly speaking, I see nothing going wrong… both log files seems ok to my eyes.

here the link to the xlog.txt file: xlog.txt

and here the link to the dmesg.txt file: dmesg.txt

I still think that the default VESA driver should work without problems. I could try to play with the xorg.conf for a while, but I don’t know what I must try to modify… resolution? Colors? :\

Is it my imagination, or do these recent posts on random black screens tend to have gnome in common? Recent updates perhaps?

maybe you’re right, but I don’t know how many users have the same kind of problem.
Googling for a while, I have found that a problem like mine is common for openSUSE users. 99% of times this is caused by the video configuration after installing openSUSE form CD/DVD.

My problem is more complicated: after installing openSUSE all is ok, but if you reboot or turn off/on PC there is 80% of chanches to get the black screen.
Usually, PC are deterministic machine: they work or not. But my PC seems to be a non-deterministic machine! lol!
Today, after 6 times, it has started normally in Failsafe mode normally… but I have touched anything…:open_mouth:

Thanks lwfinger, I have solved the problem with Google. Thanks in any case!

I agree Vesa should work, but as user “consused” noted, some of the via/chrome implementations are not very good, and I think this (not so good implementation) could also impact the Vesa driver.

My familiarity with configuring for the vesa driver is only by using the sax2 wizard. Note there are many more options that can be used besides the basic “sax2 -r -m 0=vesa” and with root permissions you could type “man sax2” to learn about the others.

I will try to play with the vesa configuration, but seems to me that there is a different problem…