Black screen on installing OpenSUSE 11.1 on Studio XPS 13

I got a Dell Studio XPS 13 and I am trying to install OpenSUSE 11.1.

I downloaded the RELOADED remastered .iso from here which has worked great on my desktop computer.

However, when I boot up the CD on my Studio XPS 13 and select the install option, a green loading screen comes up and completes, then I just get a black screen with a frozen text entry marker.

I checked the HCL for Dell Laptops but the Studio XPS series isnt listed.

I really need some help on this one.

My guess is that your graphics were not configured properly for some reason.

Can you tell us what graphic hardware your Dell Studio XPS 13 has ?

You could load a generic vesa driver as an interim, or you could use the installation xorg.conf file as an interim.

I recommend you reboot the PC. When the grub boot menu comes up (that is where you can choose, openSUSE-11.1, or safe settings, or windows, … ) choose openSUSE-11.1 (probably the default) and type “3” (no quotes). The “3” should appear in the options line in that menu. That will boot to run level 3 (which is an ASCII text screen).

Log in there as a regular user. Enter regular user password.

Once logged in, type “su” (no quotes - enter root password when prompted) to get root permissions.

You can determine your graphics by typing:
sax2 -p
which will say what graphics you have. What does that say?

Then 1st try the installation xorg.conf file (where xorg.conf is the configuration file for your graphics). Do that by typing:
cp /etc/X11/Xorg.conf.install /etc/X11/xorg.confNote the directory is X-one-one, not X-L-L.

Then reboot by typing:
shutdown -r now

and see if that works? [this time do NOT type “3” ]

If that does not work, then reboot again, type “3” in the grub boot menu, and login as a regular user at the ASCII prompt. Again, after having logged in, type “su” (no quotes - enter root password) to get root permissions. And then try to load the vesa driver by typing:
sax2 -r -m 0=vesaNote that is “zero equals vesa”.

choose a very conservative resolution for now.

Exit sax2. Again type:
shutdown -r now
to reboot. Do not type “3” in grub menu, and see if that works.

Thanks for the quick and good reply!

I will try it out now but thought I would just mention that the Dell Studio XPS 13 comes with a hybrid SLI graphics solution consisting of an nvidia GeForce 9200M GS + nvidia GeForce 9400M G card…

Tried your suggestion but I still get a black screen with a frozen text marker.

The important thing to note here is that I havent gotten OpenSUSE Installed yet either. I just put in the cd, boot up and select the default suggestion (OpenSUSE 11.1…). I get a green loading screen and then I get the black screen.

I tried booting with “3” but same thing happened…

OK, I don’t know what a hybrid is, nor how that relates to Linux.

For nvidia graphics, typically there are 3 graphic drivers one can choose from:

  • vesa - this is a generic driver. It works for most graphic hardware indepenant of supplier (nvidia/ati/intel … ). It will typically survive a kernel or X11 software update. It also has the worst performance. It is provided typically with openSUSE.
  • nv - this is the openGL (opensource) graphic driver. It has moderatate performance. It will typically survive a kernel or X11 software update. It is provided typically with openSUSE.
  • nvidia - this is the proprietary driver (made by nVidia). It is NOT provided by Novell/SuSE-GmbH, but one must go to the nVidia site and download it (or setup a nVidia repository). It has the best performance. It is almost always broken when ever there is a kernel or X11 software update, requiring a rebuild and reinstallation of the driver specific for the new kernel/new X11. It drivers new users crazy, as they both love its performance and hate it being broken on occasion. In truth, its easy to re-build, ONCE one knows how.

When installing the driver, for openSUSE with one graphic device, one will typically type (from run level 3):

  • for vesa driver: sax2 -r -m 0=vesa
  • for openGL driver: sax2 -r -m 0=nv
  • for proprietary driver (after the driver has been downloaded and installed): sax2 -r -m 0=nvidia

Sometimes neither of those will work, and one has to type “man sax2” to learn the sax2 options. For example, I think: sax2 -r -l -m 0=vesa (with the -L (lower case)) option will force the vesa driver to a lower resolution.

Good luck. I hope that explains a few things.

Are you trying to simply boot to the live CD ? Or install from the Live CD?

If the live CD boots, then what you could do instead, is choose a text install. You can do that, by rebooting, and when the boot menu comes up, is change the graphics to “text” (note you can also change the graphics to “vesa” , and rather than “text” you can try that instead ). Look at the bottom line of the boot menu on the liveCD, and you will see you can choose your graphics. Select a lower graphics, or select “vesa” or select “text”. Then boot the live CD. When you then click on the install icon on the desktop with will do a text (or vesa) install.

Its possible the default (openGL) is not working for you.

Apologies for the above posts, I had thought that you got further in the install.

A hybrid SLI graphics solution means that you actually have two graphic cards (kinda) where the operating system can enable or disable the second one when needed. I managed to install Ubuntu perfectly on this laptop but it woulndt let me switch between the cards (which is due to that feature not being implemented yet in Nvidia Linux Drivers)

Again, I cant really see how I can install a driver when OpenSUSE blacks out before even starting the installation proccess…?

We are cross typing here … :slight_smile:

You can always do a text install.

The risk here, of course, is the liveCD has limited options for installation, and choosing the text install may still not work when using the liveCD (one has more options and a better chance with the DVD).

I tried the F3 → Video Mode: Text option which loaded up lots of stuff and ended with:

Starting auditd: done

and then I got the black screen (this time without the text entry pointer though)

How long did you give it? Had it indeed frozen at that point?

Again, one has more options here with the DVD. They had to cut out some installation options with the liveCDs.

I did give it 2-3 minutes at the black screen at which point the HD-activity LED was dark for the same amount of time…

I cant seem to find a RELOADED remastered OpenSUSE 11.1 DVD…

Guess I am out of luck :frowning:

What is wrong with the regular 11.1 DVD ?

Well, I first installed the stock OpenSUSE 11.1 DVD on my desktop computer but for some reason, all the repositories were wrong or too old so I had to manually change alll the KDE repositories along with packman and all the others (might be a problem with my install, I dont know… got help from some users at the irc channel)…

I reinstalled using the RELOADED .iso and everything worked fine!

I also enjoy the fact that with the RELOADED .iso I have all the updates, all the right repositories and the latest stable version of KDE…?

There are many liveCDs, but no RELOADED DVD that I know about. I note the “official” CD/DVDs are here: Index of /distribution/11.1/iso
… there is no “official” reloaded CD nor DVD.

But there are many openSUSE live CDs. Take a look at this page:
Live CD - openSUSE

The KDE-4.3 live CD that I prefer to use is this one here:
“KDE Four Live” CD](

… which leads to a different link (its a different liveCD) than the one you attempted to use. Whether it will make a difference, I do not know.

Are you certain your liveCD was burned ok? Did it pass the md5sum check with the web site? Did you burn it at a slow speed (slowest your burner allows) to a high quality media ? (NOT to an RW , but preferably to -R or +R).

Did it pass the media check?

Exactly, there are no RELOADED DVD, just a LiveCD which means that in order to use the extra installation options the DVD provides I have to use the stock DVD image… Right?

I am not aware of any openSUSE liveCD that has as much flexibility in the installation as the stock DVD.

You may be forced to do a Fail Safe installation, if the other installation modes (such as vesa or text) do not work.

Just downloaded and burned the Live CD you linked to, the “KDE Four Live” CD… and I suddenly got to the text based login…


What now?

EDIT: I typed “startx” and got a fatal error, “No screens found”

If you have the text based logins, then try the vesa driver. Or try the openGL driver.

I gave the sax2 commands above for those.

sax2 -r -m 0=vesa
then type

Got same error…

“No screens found”… :confused:

Found this link… Its for Ubuntu though but its the same laptop and same problem.