Black screen on 11.2 DVD Installation

So every 11.2 installation disc Ive downloaded so far has shown me a black screen right after clicking on the Installation option from the main DVD menu. I have a x1250 ATI onboard graphics and Im assuming the new xorg changes are whats causing the problem. Can anyone help me get it to show the installation setup? Do you need any more information? Thanks

This was the case with 11.1 so try it

If the graphical boot menu doesn’t show or freezes, try press and hold Shift on the keyboard when booting the installation media. This starts the text-mode boot menu instead.
I believe you can select text mode from pressing F3 at the boot menu too

Typically there is a VESA installation option (I think one presses F3 or someother Fx key when the very first green boot selection menu appears). There is also a text option which gives you text menu during the install.

There is also a safesettings install.

How did those fair?

Using the Vesa and every resolution option still gave me the black screen. Setting the Driver to Yes just loaded a black screen with some white font on it. Finally, setting the kernel to Safe Mode allowed me to start up the installation.

After Installing though Ive ran into a ton of errors. When rebooting it gave me a grub 17 error about partition not found or something, so I ran the repair system from the DVD and it popped up alot of things missing or needed to be fixed. After repairing and rebooting it then just said “missing operating system” and failed to load. I ran the repair system several times, and one thing it always says is the Package database is missing “/var/lib/rpm/Filemd5s”.

I managed to load the operating system by clicking the boot from hard disc in text mode after repairing. Also, I set the default boot to the failsafe instead of the default. Im wondering if the problem is the grub setup. How is it supposed to look b/c it says only “/boot/vmlinuz” for path to kernel and I was thinking it should be “/boot/vmlinuz” or something more specific.

Please let me know if you know of any way to fix my problems. Thanks

11.2 RC1 x64 bit DVD. x1250 Radeon video

HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

All About Grub - openSUSE