Black Screen For All Applications on OpenSuse on Thinkpad T40

Hi,

After years away from Linux I decided to jump back in. I burned an Open Suse iso and used it to install on an old Thinkpad T40, selecting Gnome as the desktop. The installation completed without any issues and I am able to log in and see the desktop and associated menus. However when I launch an application, I’m just presented with a blank, black screen where the application graphic should be. This seems to be true for all applications, be they games, network settings etc. On the desktop I see the outlines of where the applications should be and the windows have the correct labels so obviously they are running, but there is no graphics at all.

I have no idea how to troubleshoot this. Can anyone point me in the right direction?

Thanks.

-ts1971

Logout
At the login screen (this assumes you have autologin disabled)
Try selecting IceWM as your session.

Does the problem happen in IceWM
*(Right click on the desktop space should give you a menu)

Hi and thanks for taking the time to reply. No, no issues using IceWM. Having now selected IceWM, the applications and their associated graphics are running fine. Obviously, I’d still like to get Gnome working …

Thanks again.

-ts1971

On Sat, 03 Mar 2012 15:06:02 -0500, ts1971
<ts1971@no-mx.forums.opensuse.org> wrote:

>
> Hi,
>
> After years away from Linux I decided to jump back in. I burned an Open
> Suse iso and used it to install on an old Thinkpad T40, selecting Gnome
> as the desktop. The installation completed without any issues and I am
> able to log in and see the desktop and associated menus. However when I
> launch an application, I’m just presented with a blank, black screen
> where the application graphic should be. This seems to be true for all
> applications, be they games, network settings etc. On the desktop I see
> the outlines of where the applications should be and the windows have
> the correct labels so obviously they are running, but there is no
> graphics at all.
>
> I have no idea how to troubleshoot this. Can anyone point me in the
> right direction?
>
> Thanks.
>
> -ts1971
>
>
I have the same issue with my a31 thinkpad kde xfce and lxde work. Will be
watching this thread closely.


max

I’m not much use, because I use kde.

Well, you’ve already been some use :slight_smile: Maybe I’ll just switch to KDE as I essentially chose Gnome arbitrarily.

-ts1971 (who is off to figure out how to install KDE)

You can install the patter from IceWM
http://dl.dropbox.com/u/10573557/Add%20Patterns/add-patters-fromQT.png
or it might look like this
http://dl.dropbox.com/u/10573557/Add%20Patterns/add-patterns-fromGTK.png

Or if you want kde pure- you need to re-install only kde