Black screen after sleep(suspend to ram) on my desktop

Hello openSUSE community

I do not know if this is the right forum section so if I am in the wrong forum section please move it to the right section.

I have this problem from the beginning of openSUSE 12.3 a fresh install on an 30 GB partition,some times if I wake up my Pc it will not wake up how it should the screen stays black and I can not do anything.

First I have an AMD Radeon HD 4870 running with the opensource drivers all works fine but too hot so I am controlling the clock speed with this plasma widget Radeon Power Management to lover the temps.

I thought maybe that is the problem so I tried leaving it as default but no use the same problem some times(this has perfect worked under Chakra Linux with systemd 204 and Kernel 3.7.6 and 3.9.2) so I tried another Kernel from the Stable repo first the 3.9 and now the latest 3.10.1 from the OBS stable kernel repo but the same this this time.

I say some times,it do not happen always so I do not know what the problem is so I will post a system log from yast.(pastebin makes big problems so via google drive an system plain text file below)

Start of sleep at this line:
2013-07-18T19:20:35.569950+02:00 Dragon-openSUSE systemd[1]: Starting Sleep.
Seep end:
2013-07-18T22:50:53.275022+02:00 Dragon-openSUSE kernel: [16288.837713] Freezing user space processes … (elapsed 0.01 seconds) done.

So look at the log and if you need more information ask me.

I am thankful for any help.

New day same problem xD

It seems using the 3.10.1 Kernel makes this problem appear every time after sleep.

So her a small system log,why small-if I post the big one above it would say I am spammer xD and the open ID **** gives me an error,maybe I have done something wrong.
From the beginning of the sleep and to the restart after the black screen:
SUSE Paste

So please can someone say something?

Just an idea:
In my BIOS I have an option “Repost Video on S3 Resume” in the “Power” submenu.
For some kernel versions I had to set that to “Yes” to have the gfxcard (Radeon 9600) working after suspend, on other versions I had to set this to “No” (which was the default anyway).

So take a look in your BIOS settings if you have a similar option (maybe called something like “reinitialize graphics card after suspend”?) and try toggling it on and off.
Maybe that helps?

First thank you very much for your answer :smiley:

I have Asus M4A78T-E motherboard with an AMD Phennom 2 x4 955 BE and I do not remember seeing such option but I will look at it and see.

This could explain why is it so terrible working with the 3.10.1 Kernel but not why is it sometimes working and sometimes not working with the 3.7.10 kernel.

OK now I made some testing:

I do not have the same settings as you wolfi323 but I tried what I could.

On the Power menu I have:
Suspend [Auto]
ACPI 2.0 support [disabled]
ACPI APIC support [enabled]

So I tried setting ACPI 2.0 enabled and Suspend to S3 only(second option is S1 pos) with both kernels 3.7.10 and 3.10.1 but the same problem after the first sleep or the second(one time the sleep works the other time not).

I sad it maybe wrong,after it wakes up from the sleep I see on the screen the normal wake up process but It ends up in a black screen with my LCD monitor going to power save mode and on my usb keyboard I can not enable caps lock or disable num lock so maybe it is a full system crash?

I upgraded Systemd and Udev to version 204 via OBS System:Base repo.

Systemd 204 is fast like hell, KDM can not catch up xD but unfortunately this was no help after the second sleep the same problem black screen or system crash?

Ok a few days have passed and no really help from the community and it is still the same problem.
I am waiting for an update to fix this issue until then I will be booting in to Chakra Linux too avoid too many reboots afters sleep.

Still I have no clue why is it not working how it should with all open source drivers,all other distros do not have this problem with only open source drivers.

Well, you could try to install the package “pm-utils”.
This contains workarounds for certain hardware.

If it is installed systemd uses it for suspending instead of just asking the kernel to do it, IIUC.

Maybe that could help you?

Ohh nice idea thank you very much.
I thought pm-utils is installed by default in all distros,any way I will check it out now.

Ok pm-utils are installed by default in openSUSE as I can see now.
Later I will check the options of pm-ultis,maybe this helps.

Ok I downgraded systemd and udev to 195 and deleted the 3.10.1 kernel and there was an xorg update so I tested.

her is the pm-suspend.log with systemd and udev 204 and 3.10.1 kernel a few days ago with the problem after sleep.
SUSE Paste

and her the log of today with downgrade systemd and udev and kernel and with no problem after sleep strange?
SUSE Paste

So maybe the xorg update solved the problem but I will see.

Ok it seems the problem got solved so the wake up after every sleep now is ok.

Now I know the problem if I under-lock my gpu from 750 MHz to 500 MHz to save energy and temps the problem appears very often but in Chakra Linux it works without a problem.
So no gpu under-locking for openSUSE :frowning:

Another time I was wrong it happens also with the default clock speed of the gpu so I do not have any clue what is is causing this problem after sleep.

Please can someone help me?

Maybe uninstalling pm-utils helps, then?
Otherwise I’m out of ideas, sorry.

But you could open a bug at (same username/password as here).
(especially as it works ok on Chakra)

Thanks for answering.
I think I will post a bug report.

Ok found a bug report same as my problem.

It seems it is a problem of the free xorg radeon driver I will try to update it maybe this helps.

Ok I tried to update the xf86-video-ati driver to the version of the X11:XOrg repository and also libdrm2 made vendor change.

After 4 short sleeps no problem it seems to work.
I will report back after a longer sleep.

Ok updating the free Radeon driver helped and yet for real I hope xD