Black screen after reboot-openSUSE 12.1

Dear All
I recently (fresh) installed openSUSE 12.1 on my desktop

Processor =Intel (R) Core 2 CPU 6420 @ 2.13 GHz
Graphics Card= GeForce 7300 GT

It installed perfectly and I could use it without any problem immediately after installation. But soon after installation if I do a reboot, it goes upto green screen where one has to choose openSUSE 12.1 or its failsafe version. If I click any of it a black screen appears without any sign of login screen etc.
I would be grateful if someone could help me to figure out potential problems and how I can fix them. All other versions of openSUSE (11.4, 11.3 etc) do not pose such problem.
Many thanks in advance,
PS: There is only one operating system i.e., openSUSE 12.1 on my machine and it is installed on the first partition of the hard disk.

Are you saying it doesn’t get you to a desktop in Failsafe?

Have you tried typing: nomodeset
in to the kernel argument of the default boot
File:Nomodeset-example.jpg - openSUSE

Yes, it does not get me to desktop (login screen etc) with Failsafe.
I didn’t try nomodeset.

I didn’t try nomodeset.
Then I suggest you do

If that doesn’t work
Try a level 3 boot
Clear any arguments and just type: 3
As shown here

I did as you suggested. Here is the outcome
1> If I enter nomodeset in Boot Options while booting openSUSE 12.1 it does not help. I again get a blank screen.
2> If I enter 3 in Boot Options, I get following text in next screen,

[0.406292] …[end trace 4eaa 2a86a86e2da23]…
[0.406292] note: swapper[1]exited with preempt_count 1
[0.411720] kernel panic-not syncing : Attempted to kill init !
[0.411807] Pid:1, comm:swapper tainted:G DW 3.1.0-1.2-desktop #1
[0.411893] Call trace:
[0.411979] <co205433>] try_stack_unwind+0x163/0x180


Any help will be highly appreciated.

I don’t know.

How many times have you tried the install? Might be worth trying again.
Does the install media pass the media check:

It’s a shame.
Actually I tried to install several times and also media check was ok.
Thanks anyway.

Any other suggestion???

If trying from a DVD, then try from the liveCD.

Or if trying from the liveCD, then try from the DVD.

Hi try this on boot options put:

vga=0x314 nomodeset

It worked for me i think its a problem with the graphics drivers. :slight_smile:

My problem is solved. Thanks to “Oldcpu”, I used Gnome LiveCD for the installation and everything was fine. However, I still don’t have a clue what is wrong doing installation with DVD on my desktop machine? I used same DVD for successful installation on my laptop. Obviously hardware is different, but somehow DVD installation does not work for my desktop.
Thanks all who tried to help.

Strange isn’t it.
I have come across this before. Well done to @oldcpu for having his thinking cap on.