Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

The Title says it all… I just did a software update of the “KDE Frameworks 5 & Plasma 5” Repository which apparently was updating from Plasma 5.5.2 to 5.5.3 and I am now getting a black screen following login. The repo that I am using is:

http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/

When I arrive at the black screen, I cannot access a shell with <ctlr><alt>-F1 either. I thought that it may have to do with a Plasma 5 user setting in my directory so I rebooted to run level 2 where I renamed ~/.kde4, however, I continued to get the blackscreen after login then as well. Everything acts normally after login including the display of the green gecko, the progress bar and the login sound. Then immediately after the login sound the screen goes black and I cannot do anything to recover except do a forced shutdown by holding my power button down.

Fortunately, I did an rsync backup immediately prior to the update so I have now recovered to my previous state prior to the update. I have tried updating several times both with YaST and “zypper up” and I get the same crummy result each time.

I added this repo on Monday of this week with YaST and switched system packages immediately thereafter so I do not believe that I have a conflict between repos.

Does anybody have any recommendations for me to successfully do the update? Has anybody else running this repo had this problem?

Thanks,

Gordon

What is level 2? Somebody says you can’t properly remove .kde with KDE running.

When you boot into run level 2 then X-Windows and the Desktop GUI are not loaded. See:

http://www.tldp.org/LDP/sag/html/run-levels-intro.html

I use that repository and had some headaches (which I fixed) did you do a **dup **with KDE:/Frameworks5 because it sounds you have mixed incompatible packages from both repositories.
How to fix it, it depends do you have another desktop, Icewm should be there and should work, if you can logon to Icewm and do a full vendor change with KDE:/Frameworks5, execute

zypper lr -d
zyppre dup --from <put KDE:/Frameworks5 alias or number here> --from <put packman alias or number here>

(use packman too as to keep your multimedia from braking)
or post your repo list and we can try to help.
If Linux goes straught to plasma 5, hit ctrl+alt+backspace 2 times to kill X and return to the logon screen,
If sddm does not work then
at grub before booting hit the ‘e’ key and add the number 3 at the end of the boot command, that will boot you in run level 3 ie text mode, from there you can do zypper lr -d and zypper dup --from

Hello I_A,

Thanks very much for your reply. I am confident that I do not have a problem with mixed up packages from conflicting repos. Nevertheless, I did the zypper dup again but the problem remained with a black screen after login. Also, I had previously created a guest user account which I am able to login to. So, I suspect that the problem may have something to do with some incompatibility with my user settings and Plasma 5.5.3 that was OK with Plasma 5.5.2.

I looked at “journalctl -b” and posted an abbreviated version of the log here:

http://dickens.com/download/journalctl.txt

My login is successful on line 24 of the abbreviated log as follows:

Jan 10 14:04:46 hippo sddm-greeter[1405]: Message received from daemon: LoginSucceeded

I am confident that the black screen then occurred by the time stamp of Jan 10 14:03:49.

I am not very familiar with systemd and I don’t see anything suspicious about the log.
Do you see anything in the log that may give us a clue as to what the problem is? Please
let me know if you have any other suggestions.

Thanks,

Gordon

unless you have some important data (emails/passwords) you could simply delete the old plasma config files from the 2nd account, hunting down a bad setting might take forever.
My problem was that I installed newer kde5 apps from KDE:Extra and they wore killing dolphin so I did a dup to the OSS and Update repo’s to get everything back and then a 2nd dup to kde:frameworks5 repo to get plasma 5.5

Yes, I had already renamed ~/.config and I am now able to log on to my user account which, of course, is now a clean slate without any of my previous configurations, panels, icons, etc. So, I guess that I will have to then rebuild my desktop. What a bummer… KDE Plasma 5 has been causing me all kinds of headaches and this is just the icing on the cake. I wish that I had never upgraded from 13.2 to Leap 42.1. 13.2 ran fine and did not have all of these bugs that are present in Plasma 5. IMHO, the current versions of Plasma 5 are all a POS.

I_A, thanks for your help. Please let me know if you or anybody else has any ideas on how to recover my desktop user settings so that I don’t have to build every thing all over again. Otherwise, I guess that is what I’m gonna have to do.

Thanks,

Gordon

well if you switch from kde:frameworks5 to wolfi’s Frameworks5 repo you can install kde4 and have both plasma 5.5 and kde4 running under leap, I’m thinking about doing just that.
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.1/

How does wolfi’s repo work with respect to the home directory? That is, are both KDE4 and Plasma5 settings saved in the same home directory and then the user chooses to either run KDE4 or Plasma5 when they log in?

Thanks,

Gordon

KDE4 in in the ~./kde4 directory and Plasma 5 is now in ~/.config

the main difference between wolfi’s plasma5 and kde:plasma5 (or oss plasma5) is that wolfi’s packages go in
/opt/kf5 so it can coexist with kde4 while the regular plasma5 goes in /usr and can not coexist with most of kde4 it has nothing to do with a user’s /home profile

What is the best way to revert back to the OpenSUSE repos for Plasma 5? That is, if I want to drop the “KDE Frameworks 5 & Plasma 5” repo and go back to the stock OpenSUSE repos for Plasma 5. Would I do a zypper dup to the Main OpenSUSE Update repository or the OpenSUSE-Leap-42.1-Update Repo or both?

by doing a zypper dup with the OSS and the update repo’s (packman too or you’ll brake multimedia)
of not sure post zypper lr -d and people will help.

Hi I_A,

Looking at the packages and their repos, it looks like the stock Leap 42.1 Plasma 5 software is coming from the Main OpenSUSE Update repo and the OpenSUSE-Leap-42.1-Update repo. However, I may be wrong and I would like advice and input from the experts. So, please let me know the recommended way to revert all of the Plasma 5 software back to the stock OpenSUSE Leap 42.1 repos.

Here is the output from “zypper lr -d”:

#  | Alias                            | Name                             | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                            | Service
---+----------------------------------+----------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------------+--------
 1 | GLD - Bumblebee                  | GLD - Bumblebee                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_Leap_42.1/   |        
 2 | GLD_-_Packman_multimedia         | GLD - Packman multimedia         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/                  |        
 3 | GLD_-_Plasma_5                   | GLD - Plasma 5                   | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/ |        
 4 | GLD_-_Printing                   | GLD - Printing                   | No      | ----      | No      |   98     | rpm-md | http://download.opensuse.org/repositories/Printing/openSUSE_Leap_42.1/         |        
 5 | GLD_-_Ubuntu_fonts_by_gldickens3 | GLD - Ubuntu fonts by gldickens3 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/gldickens3/openSUSE_42.1/      |        
 6 | GLD_-_libdvdcss_1                | GLD - libdvdcss                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/                             |        
 7 | GLD_-_nVidia                     | GLD - nVidia                     | No      | ----      | No      |   99     | rpm-md | ftp://download.nvidia.com/opensuse/42.1/                                       |        
 8 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)        | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/              |        
 9 | download.opensuse.org-non-oss_1  | Update Repository (Non-Oss)      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                         |        
10 | download.opensuse.org-oss        | Main Repository (OSS)            | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                  |        
11 | download.opensuse.org-oss_1      | Main Update Repository           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss                              |        
12 | repo-update                      | openSUSE-Leap-42.1-Update        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                             |

Thanks,

Gordon

you have the plasma 5 repo disabled maybe that’s your issue
the OSS and the Update repo carry plasma 5.4 the KDE:/Frameworks5 repo has plasma 5.5 (you have this repo disabled)
to get back to the regular 5.4 plasma you’d need to do

zypper dup --from 10 --from 11 --from 2

edit you seam to have 2 copies of the update repo, repo’s #11 and #12 seam to be the same, the only difference being a missing / at repo 11

Thanks for your assistance I_A! I downgraded the Plasma 5 packages successfully back to the stock OpenSUSE repos (Plasma 5.4) while preserving the packman repo as you recommended.

I had disabled the Plasma 5 repo on purpose after I had reverted the Plasma 5 repo’s packages from 5.5.3 back to 5.5.2. For me, Plasma 5.5.3 was a total bust. That is, after I finally was able to login to a real desktop (instead of a black screen) by removing ~/.config then I started rebuilding my desktop… But I then ran into even more problems. First, my autohide panel kept disappearing whereby it would only be accessible after I restarted Plasma 5. That is, the panel became inaccessible following the first time that it was autohidden after each restart. So, I started over several times trying to rebuild that panel and make it work, but to no avail, it became inaccessible after a while each time that I tried… Then, while adding widgets to the panel, I got the black screen of death again… And when I restarted Plasma 5 or rebooted then I was immediately stuck at that black screen of death immediately after login just like before. In other words, my experience with Plasma 5.5.3 was a complete and total failure. For me, Plasma 5.5.3 is the most unstable piece of desktop software that I have ever tried to use. Maybe there is something peculiar about my installation… I will admit that my desktop is probably more complicated than most with alot of plasmoid widgets and launcher icons, however, IMHO, that should not matter…

As an FYI, I also had to do a “zypper dup” for the Bumblebee repo and my Ubuntu freetype font repo as well in order to get them back to the prior state as well.

Yes, that was a goof on my part, thankfully harmless, and I deleted repo #12. Thanks for pointing that out!

Gordon