Black Screen after installing NVIDIA Drivers

I guess this is how I will get better at using Suse but I was hoping for a smoother start. After installing 11.2 and keeping my Home partition from 11.0, I tried to install the Nvidia drivers from the one click, it seemed to go ok. Then when I rebooted I got a black screen. So upon reboot again I found I could get into failsafe but was unsure what to do then. I did check as listed in the one click directions that the driver was for the same kernel, it was (desktop instead of default, I had not seen that before). Searched the forum but did not really see this problem for a desktop pc, looked like a lot of similar problems for laptops. I have reinstalled 11.2 and am at square 1 without adding the drivers, could someone guide me in getting my GeForce GTX9800 card to work so I may move on to the other 3 or 4 other things that are not working properly?
Thank you very much for any help.

I forgot to add that I installed the 64 bit version.

There are likely many solutions.

First a question. After installing the nVidia graphic driver, did you boot to run level 3 (ie a text login, you get there by pressing “3” when the grub boot menu appears) - a “3” will appear in the options log.
Carry on and login to the text loggin. And then try a few things.

First, remove any /etc/X11/xorg.conf file (if there is such a beast). If there was try rebooting now (with no file) with root permissions with “shutdown -r now”. Likely that will fail. So restart your PC again (either via <CTRL><ALT><Backspace> twice in a row very fast, or <CTRL><ALT><Delete> twice in a row very fast (my memory has left me and I can not recall which) or <CTRL><ALT><F2> and login to the terminal and withroot permissions type “shutdown -r now” or do a hard reset.

Again, log in to run level 3 (see above).

This time, try to create a custom /etc/X11/xorg.conf file for your proprietary driver with a nvidia tool. Try by typing:
nvida-xconfig

and then restart as above with “shutdown -r now”, and again try. If that fails, again restart as above, and log in again into run level 3.

This time, try to create a custom /etc/X11/xorg.conf file for your proprietary driver with an openSUSE tool. Try by typing:
sax2 -r -m 0=nvidianote that is zero equals nivida.

and then restart as above with “shutdown -r now”, and again try. If that fails, again restart as above, and log in again into run level 3.

Other commands you can try to configure your PC for different drivers are:

  • for open source driver
    sax2 -r -m 0=nv

  • for vesa driver
    sax2 -r -m 0=vesa

Let us know where you end up, so we can then give further guidance as needed.

Thank you for your help. I did not boot into run level 3. I am not very good with the command line so I am not sure how to remove the file w/out the gui. It does not appear that I have that file now, prior to install of the driver. I will now try to reinstall, my printer is not printing right so I will go between here and another computer to trouble shoot. Thanks again.

OK, first I did not have a xorg.conf file, I couldnt figure out how to get there through the terminal but through failsafe it showed I had no such file. Next I booted to RL 3 and tried nvidia-xconfig, got 2 messages, both saying unable to open xconfig file. Next I tried the sax2 -r -m 0=nvidia command using su. Just like reboot, flash at the top, no start, black screen, no commands you recemmended would reboot. Did a hard restart, RL 3, su, same command except 0=nv and suprise it is now booting. Is there anything else I should check now to make sure it is operating properly? Thank you for your help.

Yes, ok so what you have running now is a graphic driver called “nv” , where “nv” is the free open source graphic driver for nvidia hardware. It is a reasonably stable driver, it has significantly superior performance over the vesa and over the fbdev drivers, but it has significantly poor performance in compared to the “nvidia” driver that you tried to use the first time. One nice thing about the “nv” driver, is when there is a kernel or an xorg software update, the “nv” driver will still work. However the higher performance “nvidia” proprietary driver is often broken when there is a “kernel” update or an “xorg software” update.

I recommend you identify the nvidia rpm that you installed previous, and you remove it. If in doubt as to what you installed, leave it for now.

Then I recommend you spend some time and get comfortable with X windows. I recommend you make a copy of your /etc/X11/xorg.conf file that was created by “sax2 -r -m 0=nv”. You can do that by typing with root (administrator) permissions:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.my.nv.backup

Note Linux is case sensitive.

So now you know the rpm for the proprietary “nvidia” driver failed to work. You can either:
a. try again the rpm/repository solution some time, or
b. wait until people tell you there is an update to the driver, or
c. build the driver yourself “the hardway” (which is not hard, but it requires some basic Linux knowledge).

There is guidance here for approach-a: NVIDIA - openSUSE

There is guidance here for approach-b: NVIDIA/The hard way - openSUSE

Your sig confused me for a while. Do you also have an openSUSE-11 system?

Thank you for your help, I would like to be able to use all the bells & whistles of the KDE 4 system so I will work to get the driver to work. Sorry about the sig, I had opensuse 11 & KDE 3.5 for some time and am now trying to upgrade.I hope I made the right choice, everything was working I just figured it was time to start using the better OS & KDE 4.I guess since I already messed it up and got back to here I will try the repo way next. I was in the configuration from the launcher and it said to configure the nvidea just type in nvidea-xconfig in the terminal, I did and then I was back to a black screen.

OK, … So where are you now? Do you have X running with the ‘nv’ (free open source “openGL” nVidia ) driver?

I typically install the nVidia driver “the hardway” so if it gets to that point, where you want to give that a try, post here, and we can try help. It WILL be a learning experience, as you will need to type a very small number of terminal commands. :slight_smile:

That should say:

There is guidance here for approach-c: NVIDIA/The hard way - openSUSE

Well I think I am going to need to do it the hard way, I was looking at the repo way and it says that driver is already installed. Can I (should I) remove it through Yast and try again?

Thats worth a try.

Be careful you remove the correct rpm. Then install it again.

I have followed all the directions in the Hard Way but I am unable to see the directory I downloaded the file to. I will try the repo way first but I dont understand what I am doing wrong in the comand line. The file is in /home/Downloads/nvidia, in the terminal when I type cd /home/Downloads/nvidia it says no file found. Doesnt matter if I am in root or not. What am I missing? Thank you for your help.

First of all, you should not be downloading a file with root permissions. I’m serious.

I understand, the temptation for a new user, who does not understand when root permissions are needed, and do not understand in which directories where root permissions are needed, want to be root all the time.

I understand. Truly I do.

But , its really a very very VERY bad idea. The odds are you will very quickly irrepairably mess up your system if you follow that. So stick with regular user permissions. DO not download to /home/Downloads/nvidia. Download as a regular user to /home/yourusername/nvidia as a regular user. Then when you open a terminal, as a regular user, you just need to type " cd nvidia" and you will be in the right directory. Type ‘dir’ or ‘ls’ and you will see the file.

Now when you run that script file, then (since you are installing software ) and only then should you type ‘su’ (no quotes) to switch to root permissions. You will see your cursor change from " > " to " # ". To get back to a regular user, just type ‘exit’ .

Two basic navigation commands …

  • cd directory

moves you to that directory (which I called “directory” ) .*]**… ** # two dots, moves you back out of that directory to the next higher level

Thank you, I think I either mis-wrote or am really lost. I downloaded the file as a regular user w/Firefox to a folder that I made in my Home directory Downloads. In that folder I make other folders, in this case I made one called nvidia where I stored the file called “NVIDIA-Linux-x86_64-190.42-pkg2.run”. Then, as I tried to figure how things work in the terminal I tried to find the file, first as a regular user, then as root using su. I was unsuccessful either way, I got no farther than “home”. I now did what you said (not in root) and what I had not done is put myusername after home. Now I can see the folder so I think I learned something, maybe there is still hope for me.

I just tried the repo route with no luck, same black screen, reverted back to 0=nv. Is it possible that the Hard way will not work either?

Yes, its possible, … but IMHO it has a good chance of working. To do the hardway, remove the nvidia driver rpm you installed. Thats important.

Go to YaST > Software > Software management and change the “filter” to “pattern” and select the “base development” pattern. That will take a LONG time to install. Then change the “filter” to search, and select “kernel-source”, “kernel-syms” and “linux-kernel-headers” and install those if not already installed.

Then reboot to run level 3, and navigate to /etc/X11/xorg.conf and move that file to /etc/X11/xorg.conf.mybackupfile or something like that, so that you have NO xorg.conf. You can do that by first typing ‘su’ (no quotes - enter root password when prompted) to get root permissions and then type :

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackupfile

navigate to the directory where the NVIDIA-Linux-x86_64-190.42-pkg2.run is located. You do have a 64-bit openSUSE install, right ? then type:

sh NVIDIA-Linux-x86_64-190.42-pkg2.run -q

select YES as appropriate to the questions.

then create the /etc/X11/xorg.conf with the nvidia program

nvidia-xconfig

it should do a better job than sax2 for creating the /etc/X11/xorg.conf file. It will complain it could not find an /etc/X11/xorg.conf, but it will create its own then.

Then restart with : shutdown -r now

Hopefully that will succeed.

Thank you for all your help. I got impatient this afternoon and I am using all this as a learning experience so…before I got your last post, I removed the installed drivers, I followed the instructions on the Hard Way and completely borked the system, just a black screen even after sax2 -r -m 0=nv. It said it installed properly, it all was good till I did nvidia-xconfig. So I figured (since I couldn’t log in anyway) to do a clean install and remove the old home folder (which is all backed up on another drive) and allowed it to partition ext4.Did the one click install and…no luck, just like before. So, I am going to wait a bit, follow your instructions to the letter and hope for a better outcome.:expressionless:

Sorry you’re having trouble M13. Oldcpu is a wizard and has helped me out of a couple jams with my Nvidia drivers.

Just curious, do you have more than one output on your video card?

I had a problem very similar to yours a short time ago, and it turned out that Sax was switching to the vga port when my monitor was hooked up to the DVI. It would only choose the “wrong” output when the “nvidia” driver was used (for some reason) so I thought I had driver trouble. To test it, you could try plugging your monitor into the 2nd output (if you have one) when you get to the black screen.

If that is indeed what is happening, there is one line you can add to your xorg.conf file to tell it which port to use permanently.

Good luck.

Hello queequeg, I only have the one Samsung monitor. I think I read your posts when I was researching my problems. What seems really weird (to me anyway) is that the one click install worked fine for me with 11.0. So I am thinking that either the driver or the new OS is missing something in my particular PC. I hope oldcpu can help me as well as he has others.