Black screen after installing Nvidia driver (Geforce GT710)

Hi All,
first time with opensuse (42.3), i tried to install nvidia drivers (Geforce GT 710 using zypper following the help guide in:
but now during the startup I have a black screen with the mouse cursor and the boot process stops (with Ctrl+Alt+F1 a tty1 terminal is available)
How can I fix this problem?
Thanks in advance for Your help

Assuming that you are using a desktop (and NOT an Optimus laptop for which a different guide is needed), maybe the command:

zypper install-new-recommends

didn’t work and you are left with no driver installed.
Try installing manually via YaST Software (available also on the console login) all the “G04” packages available in the Nvidia repository that you should have added to your system according to the guide you referenced.

Sorry, i’m new in Opensuse-Yast, where do I find the commands to retrieve the packages in the Nvidia Repository from the console and install them?

I cannot test myself at the moment, but assuming that you correctly added the repository according to the guide, the following should work:

su -
<enter password for root>
zypper install nvidia-gfxG04-kmp-default-384.98_k4.4.76 nvidia-glG04-384.98 x11-video-nvidiaG04-384.98 nvidia-computeG04-384.98

If it doesn’t work try the following to see the exact name of the packages as seen by your system:

zypper search nvidia

Did you first try either of the applicable FOSS drivers and find neither acceptable? To get rid of black screen, did you try disabling plymouth (plymouth.enable=0 on kernel cmdline in grub menu), or removing plymouth altogether (zypper rm plymouth)?

I have this packages marked as “i” (installed?):


After the first update of Opensuse I had problems freezing and browsing web pages I thought to solve by installing nvidia drivers (as in other distributions with the same problem).
However, your suggestion (plymouth.enable = 0 on cmdline kernel in grub menu) worked :slight_smile: and i could now make it permanent editing the /etc/default/grub file (adding in the “GRUB_CMDLINE_LINUX_DEFAULT=” entry) and updating the /boot/grub/grub.cfg file or it would be better to definitely remove plymouth (is this an unresolved conflict of plymouth with nvidia drivers for now or it may be fix)?


I never let Plymouth get installed on openSUSE in the first place, and never install proprietary drivers, so I don’t know if one is better. Some distros don’t permit Plymouth removal, so for those I use plymouth.enable=0 on cmdline.

NVidia drivers I think only partially support kernel modesetting, which I think Plymouth requires. Likely there is a conflict, but it’s avoided via either method.

Plymouth removal means trivially less time and bandwidth at updates times and trivially reduced disk space consumption. Plymouth AFAIK was originally created to eliminate “flicker” at mode switch times, something that never bothered me, if I ever even noticed it.