Black Screen After Install

I install Leap 42.1 - KDE- using default options on a seperate SSD. I have two other SSDs - my primary has Linux Mint 17.2 Cinnamon installed and my second has Windows 7.
The install is issue free and I can boot into the Opensuse desktop, which looks great. I can open Dolphin, Firefox and install the advised updates, again without issue.
The problem comes when I try to open YAST. I can enter the password and click on open(or whatever the button says). Immediately the screen goes completely black. No mouse cursor, no response to any keyboard input.
The only way I have found to get out of it is to press the Reset button on my PC case.
I have experienced the same black screen crash(?) with Plasma 5 after installing other distros. But it can appear at a different point with some. Usually immediately after the desktop loading screen.
I assume this is some kind of graphics issue but the problem appears so fast I don’t have time to access any settings before it happens.
Anyone got any ideas?

Desktop PC
Asus P9X79 Deluxe motherboard
Intel i7 3930K cpu
nVidia GeForce GTX780 graphics card
32GB ram
Creative SoundBlaster X-Fi 5.1 Pro USB sound card
Razer Taipan USB mouse
Corsair K65 RGB USB keyboard

I had similar problems but on Gnome, and the reason was nouveau. As my card is similar to yours (gtx 750), try to install nvidia drivers and see if that fixes the issue.

Thanks for the reply. I’ve never had any issues with Gnome (other than insane cpu usage with Fedora 23). Anyway I’ll try and figure a way to install the relevant software repository and nvidia drivers from a terminal. I could do that easily on a Debian based system but have no idea how to do it with OpenSuse. Ah well, back to searching the web.
Thanks again.

Eazypizi There is a command line version of yast as root in a terminal just type yast

Thanks. I’ll give that a try.

OK, I’ve got it fixed.

Once booted to the desktop I opened a terminal and installed the nVidia driver:

Added repository:

zypper addrepo -f nvidia

Installed driver:

zypper install-new-recommends

Rebooted and now no black screens!