Black screen after install of 11.3 on 2009 Mac Pro

My title just about says it all. I tried both installing 11.3 on top of 11.2 and a new install with the same result on a couple of different mac pros (with 2009 ATI Radeon HD 4870 with 512MB of GDDR5 memory, 2.66 GHz 2x4 core Xeon 3500, 24 GB of memory). The install was done via the downloadable dvd from The graphics of the install process looked fine as well as the configuration. When it came time to boot, however, the suse splash screen showed up and then the monitor went dark. The graphics seems to be frotzed. Now attempting to boot from the DVD does not cause the display to do anything. Even putting a mac DVD restore disk (and using C during boot) does not result in anything on the display). Any ideas of what the installation could have done – seems like a no-brainer that something is screwed up with the graphics card, but I have no real proof and even less idea of what to try next. Any ideas out there?

A complete power down does not restore the graphics?

As to the Linux specific stuff

openSUSE Graphic Card Practical Theory Guide for Users

No, actually when I use the usual (e.g. as in what got the machine to start up from the DVD in the first place) holding down the “C” key on the keyboard at startup to start from the CD/DVD drive, the screen remains black. The usual hardware “everything is fine” chime occurs and presumably the drive spins up just fine (it is in a machine room with a lot of ambient noise so it is not possible to hear the drive) and then nothing. As everything with the install seemed to be going fine, I made a few DVDs and attempted to install the update on several machines in parallel. On another machine, I noted that the machine did respond to ssh and seem to be operating normally (except for the black screen). Another machine has a black screen and does not respond. Power cycling does not affect the black screen. My guess is that a bug in the graphics driver has put the card in a strange mode. My experience with 11.3 has been frustrating to say the least (11.1 and 11.2 were a breeze in comparison). Did I mention I have ten of these machines (in a computational cluster to update?). I am just really surprised as to how unstable/buggy 11.3 is compared with my earlier experience. Any suggestions on what to try would be appreciated (I will look at the reference above for a start, but it at least on the surface doesn’t sound like it will have a “what to do when your screen is black” troubleshooting section). Thanks in advance.