Black Screen after GRUB Screen on openSUSE 11.4 KDE RC 2

I try to install openSUSE 11.4 KDE RC 2, unfortunately I show black screen after GRUB screen. I must press Power button to turn off my computer.
I hope it won’t on openSUSE 11.4 stable.
PS: I’m waiting for downloading openSUSE 11.4. I fell it very long :smiley:

Welcome to openSUSE Linux and to openSUSE forums.

First, after the welcome, an administrative note. Sorry, but we do try to keep our forum organized. You posted in Install-boot-login, but you are using openSUSE-11.4 RC2 which is NOT a nominal release. Hence the post belongs in Pre-Release-Beta subforum area and not here. When you obtain openSUSE-11.4 GM version, only then does the post belong here.

Reference your problem, try this:

  • boot with the boot code ‘nomodeset’ (just type that the in the options line of the very first ‘grub’ boot menu that appears when you boot from the CD or DVD)
  • try a Safe Setting boot

Note there is a description in the release notes for 11.4 about this.

Did you read the new users stickie in the FAQ area ? You can find it here:

On 03/09/2011 04:36 PM, i363 wrote:
> I hope it won’t on openSUSE 11.4 stable.

probably will be, it was in 11.3 for some graphics sets, see how to
fix it here:
openSUSE Graphic Card Practical Theory Guide for Users

[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

I’m sorry. I forgot. Thanks!

I have the same problem with the openSUSE 11.4 GM x86_64.
Which video card/chipset do you have ?

I did not have the time yet but I will try the KMS trick ( SDB:NVIDIA the hard way - openSUSE )
I have tried to boot with nomodeset and I get a black screen too.
Booting in failsafe mode works… maybe it’s just some grub parameters to apply

My laptop uses NVIDIA Optimus technology. It contains Intel HD and NVIDIA GeForce 310M. I have the same problem with the openSUSE 11.4 GM KDE 32 bit version. In RC 2 this problem happen in many time but in GM it’s always.
Will openSUSE developers fix it?
PS: I must say that I love openSUSE and its community!

If the functionality is not working the way you believe it should, and if you want this looked at by the SuSE-GmbH packagers/developers, then you should consider writing a bug report on the openSUSE version you are using. There is guidance here for bug reports: openSUSE:Submitting bug reports - openSUSE You can use your openSUSE forum username and password when logging on to bugzilla.

Please see my comment about a bug report.

Thank you! I’ll do.

Purportedly there is some unofficial support for Optimus, known as bumblebee.

Reference bumblebee, I think originally it was referred to as ‘prime-ng’ and then later renamed to bumblebee. There is a Phoronix article about it here: [Phoronix] NVIDIA Optimus Unofficially Comes To Linux](

which references the developers blog here:
Optimus on Linux Problem Solved | Martin Juhl’s Blog

I also note someone has posted a guide re: bumblebee here: Getting maximum battery time from an ASUS eeePC 1015pn

There is also an rpm approach here where in turn for openSUSE-11.4 someone has packaged this: Search Results and I quote:

Bumblebee is Optimus support for Linux, with real offloading, and not
switchable graphics… More important… it works on Optimus Laptops without a
graphical multiplexer…

But my recommendation is to go for this guide noted earlier in my post (as opposed to the rpm): Getting maximum battery time from an ASUS eeePC 1015pn