Black screen after boot


I have problem with UI for a few days, after boot it ends with black screen with mouse cursor only (it moves normally).
I can’t switch to text console, it imediatelly switches back to that blackscreen.
I have AMD GC RX 560 with kernel drivers + OpenCL part from PRO drivers, mesa-dri is installed.

Thanx for advices:)


If your system has existed for awhile, you probably have old kernels still installed.
Have you tried booting to a previous kernel or repair mode in GRUB? That could narrow down possible causes of your problem to a kernel or graphics driver.

Have you also tried booting directly to a command prompt?

And BTW…
It might be informative to know which Desktop you have installed, and whether you’ve modified the Display Manager or Window Manager.



it seems Kernel was not the problem, I have upgraded it separatelly via Yast and everything is OK.
After subsequent zypper dup problem is there again. Repair mode does not help.

I have default KDE installed without modifications, only extra thing I have is those opencl driver.


I have narrowed it to two groups of packages - Mesa (17.2.6 -> 17.3.3) and Plasma (5.11.5 -> 5.11.95).
Upgrade of any of them is enough to make problems.