Black screen after boot menu.

Hi all i’ve just tried to install openSUSE on to a spare hdd, i’ve also got windows 7 on another. After installing everything and the computer went to reboot the screen just went black and didn’t restart. After restarting it myself, i turned the computer on and got to a menu that says:
openSUSE
failsafe
windows
When i tried to go to openSUSE it seemed to work and a long list of text came up but after a few seconds it went to a blank screen. The same thing happens when i go to failsafe. so i’m not really sure what to do, i would have tried a few things i’ve found from searching but can’t get to the command prompt on failesafe.

I’ve got an ati readon hd 4750 video card.

I suspect your ATI radeon hd 4750 is causing the difficulty with openSUSE, but I am a bit surprised it did not boot to fail safe.

Still, there could be other factors. Which openSUSE version are you trying ?? That makes a BIG difference, and could mean any recommendation I give is meaningless dependent on the openSUSE version.

You will likely get various suggestions and so that you may understand them, I recommend you go to this thread openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums and read

With your PC’s hardware not being legacy hardware (as designated by ATI) I think your best “bet” would be to learn enough about openSUSE so that you can install the proprietary ATI graphic driver (referred to as “fglrx” ).

To get to the command prompt you should NOT have to use failsafe. When the boot/splash screen appears giving you a choice of openSUSE, failsafe, windows, with openSUSE selected just press 3 and you will see a 3 appear in the options line. Then press < enter > for openSUSE to boot and that will take you to a full screen text mode. Login as the regular user with regular user password.

Note once in the full screen text mode, the command to restart is (when run as a regular user):

su -c 'shutdown -r now'

and to halt/stop

su -c 'shutdown -h now'

and in either case type the root password when prompted for a password

Hi, thanks for helping.
I’ve installed openSUSE 11.2 -2.6.31.5-0.1 aparently.

I’ve read the posts you mentioned, and i tried going into text mode by pressing 3 on the options line. pressing 3 didnt work but i had something in there as well which said “vga = 0x317”, i tried with and without the vga thing and what came up looked like it was something(it wasnt clear enoough to see anything) but it was all scrunched up to the top of the screen and was green. i tried mothing my mouse about and typing but nothing seemed to happen.

Having “vga = 0x317” in the options line is quite common. Try replacing that with just a “3” (no quotes). How does that boot? Do you get a full screen text log in there?

Out of curiousity, before installing openSUSE did you first

  • compare the md5sum of the downloaded iso file against the md5sum listed for that file on the web site , BEFORE you burned the CD/DVD ?
  • burn to high quality CD +R or -R (or DVD +R or -R) media and NOT to a RW for CD or DVD ?
  • burn at the slowest speed your burner allows ?
    *]run the mediacheck prior to installing as an additional confidence check for the quality of the media ?

i tried just having 3 in the options menu but the screen just went strange like before.
No i didnt compare the md5sum.
i did burn it at slowest speed and burned it to a dvd-r. i just did “check installation media” and it said “error reading sector 2196116”, im downloading the dvd iso file from the opensuse front page. I havent got any DVDs so im going to try install from a USB pen drive.

There you go. A bad CD.

I recommend you follow the advice here in BOTH our stickie:

Hi again, i re-downloaded openSUSE and checked the md5sum which was the same as from the download page, and burned it on the slowest setting i could. Before i tried reinstalling, i did the check installation media which came up with no errors, and reinstalled after that.

When i try booting i’m still having the same problem (blank screen), so i tried going though what you’ve advised me to do before

openSUSE:

with the default options line(vga = 0x317) options the screen goes blank.

With default and “3” (no quotes) it goes to a blank screen aswell

With just “3” (no quotes) it goes to this screen http://i.imgur.com/dwt6Q.jpg

i tried booting to failsafe but that just brings up a blank screen, and with adding “3” too the options line i get the image above.

I think it’s a graphics problem but i can’t get into text mode to try fix it. Not sure what else could be the problem though.
Current PC specs: I made a mistake earlier about my graphics card.
Dell inspiron 531
CPU: AMD Athlon 64 X2 6000+
Video card: Sapphire ATi HD 4730

Is there any chance of you being able to burn the CD from the same PC in which you intend to install it ?

I’ve been burning the cd’s from the computer im trying to install it on.

One last idea, after which I have no more. Are you burning to an RW or a +R or -R ? If burning to an RW, please do not. Instead burn to a +R or -R at slowest speed of burner.

Both times i’ve burned disks they were to DVD-r. If there’s nothing else that can be done, i’ll just have to try some other OS. Though i was looking forward to trying openSUSE :frowning:
Thanks for all your help though, i’l re-read the posts you pointed me to incase i’ve missed something.

I have been having the same type of problems with SuSE 11.1/2.

You may need to edit GRUB so that the Failsafe logon specifies acpi=off.

During boot with your CD, you will need to set the kernel options before allowing an install or boot from hard drive. You are telling the system to not use ACPI at all.

You may find that this now works.

I have hit this with 4 different MOBOs (2 Gigabyte, one ASUS and one MSI).

If I do not kill ACPI, then I get to a certain point and the screen goes black. And there is NO recovery without rebooting and setting ACPI OFF.

I hope that this addresses your issue.