Black screen after aborting update process.

I installed Catalyst driver on my HP ProBook 4530s (intel + ati hd 6490m) and everything was fine (even switching between two cards from Catalyst control center) but after a while I saw there was some updates available and I was started updating process, when I saw that it whould take too long I decided to abort this. I really dont know which updates I was aborted. :frowning:
Later I turned off system.
Now when I trying to boot system first appears green log screen but after it there is just black screen.
I’m now logged into recovery mode and opened YaST, checked all available updates and waiting to YaST finish it.
What if after this still not be able to boot the system?

If the updates finish properly, things should be back to normal. To answer the “what if” question: I suggest a “wait-and-see” policy.

There was a bug with the intel driver, and I think it’s still there.
The package is


If your version is greater than 2.20.0-1.5.1, try rolling back to 2.20.0-1.5.1 with

zypper in -f xf86-video-intel-2.20.0-1.5.1

If it does work, then you can add a lock to prevent updates for that package until the bug is solved.

zypper la xf86-video-intel

Hope it helps

I don’t think that’s the issue. OP interrupted a running update session, which one should never do (not on linux, not on windows).