Black screen after 1/2 of installation

Ok, I have been using OpenSuse at work for years. My Windows 7 machine crashed on me. Instead of spending the time to fix it, I decided to take the plunge and install 11.2 on my home system. I have 4 one TB drives. My RAID card has a 2x2 1/0 RAID array defined (sdb, sdc, sdc, and sde). A fifth hard drive, outside of the arrary, which is a 250GB drive (sda). It is a software RAID. Here are the partitions I set up in the installer.

On the raid:
1.75 TB on /home
2.01 GB on swap
48.55 GB on /tmp

Off of the raid:
sda1 115 GB /
sda2 115 GB /boot
(I know these are really big but I did not want to put any data outside of the RAID)

In the final Installation Settings screen, I chose Booting and change from booting from the MBR to the /boot partition. The boot loader type is Grub and the status location is at /dev/sda2. I select Install and it installs without any error message.

After it installs, it restarts and I press ESC to see what is happening. It skips boot.cycle and continues to load to “starting HAL daemon … done” and then the cursed black screen. I cannot SSH into it. It just sits there and I have to do a hard resest.

Once I restart it, it boots into the non-RAD drive I get the follwing error message:

GRUB …(it went to fast for me to get the rest of it)
(hd1/1) message: file not found

and I get the option the change the boot options of the Desktop – openSUSE 11.2 and Failsage – openSUSE 11.2 . I select e to edit the boot section of desktop and see

root (hd1,1)
kernal /vmlinz- root=/dev/disk/by-id/ata-ST32508…
intrd /initrd-

I tried changing the root (hd1,1) to 0,1 1,0 2,0, etc with no luck.

HELP!!! What do I do? I need to boot into OpenSUSE and finish the cursed installation.


PS: You can tell I work IT with the uber amount of details I put into this :wink:

You missed one important detail. What is your video card?

Also why such a complex disk setup for a desktop? Or are you building a server?

First look into your BIOS to find out the first harddisk.Try to install the bootloader into the / or boot partition.This you can do via yast.I would set a pure linux raid during means don’t use the raid settings of your motherboard.(if youre motherb.have to be changed you still can use data).
I would put your single hdd as sda with /boot and swap and the rest as a folder in your /home/… .After create to or more equal partitions on each hdd than use the raid option in yast to bring them together.

But what ever you try look first your hdd conection and the bios.

Hope it helps a bit.
Greetings and luck Erich

Thanks for the help and the quick responses. First off, does this seem like an OK partition setup:

On the raid:
1.75 TB on /home
2.01 GB on swap
48.55 GB on /tmp

Off of the raid:
sda1 115 GB /
sda2 115 GB /boot

My video card is a Nvidia GE force 9500. I know this is a little intense but it is because my home business, program writing and website design, lives on that machine. I would rather keep everything solid then run the risk of losing my work. I have had people from two years ago email for a copy of a program I wrote for them.


The BIOS and the hard drive connections are fine. I can see the four TB drive array and the single HD in the BIOS boot menu.

I am sorry but, I do not understand. I thought that I installed the boot loader into the /boot partition during setup when I changed the booting preference from MBR to /boot. Did I miss something?

To make sure I understand, I should try to wipe everything and turn of the raid array within the RAID card. Once that is done, I need to reinstall and use only the SUSE options for RAID.

I think I tried this by selecting the RAID option during the installer. It errored out saying there was not enough free drive available to setup a RAID array. Do I need to delete the suggested partitions first?

Thanks to both of you for the help!

I think you need to select raid before you set up the partitions. Don’t go with the suggested partitioning use the expert mode and set things as you would like. You are setting up a complex partitioning scheme the installer can not guess right for you.

So, I installed it a thousand different ways. I kept getting to starting hal daemon … done and then got a black screen.

It did not matter if it was RAID in the BIOS, the RAID card, or in Suse. I figured out the problem. You can not have two monitors attached when you are setting it up.

I rebooted with one monitor and it finished installing. Thanks everyone for the help.

Right that needs setup after you install