Black Card face in W98 Bicycle Cribbage

Hello list, moderators,
I have openSuse 11.3, Kde 4.4.4.2 and wine 1.2. With an old set of Winodws 98 Bicycle executable files that ran fine on 11.2, the card faces are now black.
My invocation has been wine /path/bc.exe or wineconsole /path/bc.exe in several earlier versons of openSuse and all have worked.
Now the game loads, the dealt cards click, but the face-up cards are black and unreadable.
My problem is light duty for this forum, but I would appreciate some guidance or a suggestion of a better place to try my question.
Thanks Heboland

Hello heboland,

In most cases changing the Windows version wine is pretending can solve a lot of problems.
To changes this run winecfg and select the tab “Applications”.
Now at the bottom of the window, above Ok, Cancel and Apply, you’ll see “Windows Version:”.
Try changing it to an older Windows, not older than 98 of course.

Then try to run the game again.
If that doesn’t work uninstall the game and reinstall it with the older Windows version still configured.

Best of luck!:wink:

Thank you Edward_Iii for the response.
I think I tried all the combinations of the application tab for wineconifg, all with the same results.

There isn’t anything left of the game, but the EXE and help files, so I don’t have an install program.

Last night I tried to upgrade Wine on my dial-up connection. Using Zypper that was unsuccessful. I’m getting a bunch of this:

Digest verification failed for wine-debugsource-1.3.9-1.1.i586.rpm. Expected 81f2317de2fa4723079af92c0ba7e4ff2d67eac5d4349998ff0595231fac7725, found 658967accd42767750429f129bc302ccdfca9623f5ba2f37d4838d7a90de5355. Continue? [yes/no] (no):

One other thought I had is that xorg has changed with 11.3. Is it possible that my display (an LCD) is configured differently than before?

Another question would be, what’s the magic to install wine-1.3.9-1.1.i586 from repro openSUSE BuildService - Wine CVS Builds? Is this where I should get the latest Wind from?
Heboland

Replying to myself, two other observations I made might shed some more light on this problem.

1.) If I run wineconsole /path/bc.exe the console window is also black like the faces of the face-up cards. Everything else in the game display (face down cards, and cribbage board) look normal.

2.) Invoking wine /path/bc.exe from a terminal produces several of these errors:
err:alsa:wine_snd_pcm_recover underrun occurred. To me this is an audio error, not a display error.

In the w98 game package of exe and help files, there is bc, bp, bb, bs for cribbage, poker, bridge, and solitaire. bb invoked from a terminal does not get the alsa error, but it’s face-up cards are black also. Executed from wineconsole bb also produces a black terminal.

Besides the W98 bicycle games, I also have XP executables of MsHearts and Spider. With the necessary DLL for hearts, both games execute with normal looking cards face up or face down.

Since I suspect the 11.3 xorg change, I changed display resolution, but that had no affect on the black card faces. Heboland

Hello heboland,

One setting that also does wonders to graphic problems is enabling the option “Emulate a virtual desktop”.
To do this start winecfg and select the tab Graphics.
There you’ll see the checkbox “Emulate a virtual desktop” , make sure that it’s checked.

I’ve never seen such an error.
But after some searching I found this thread: Wrong Digest error
Although the problem of the OP isn’t really solved I recommend you try out some of the suggestions in this thread.
Especially the first one, deleting all your current ones and re-add them.

One more tip, try to keep your repo count as low as possible.
You only should have the standerd, OSS, update and packman(optional).
And when you need to have some software of a different repo, add the repo, install the software and disable/delete the repo again.

But as far as I can see this has nothing to do with your problem.
Unless your running a fresh install, then the problem could be with your installation CD and or iso.

Xorg can cause a lot of errors/problems with graphics.
Did you install drivers for your graphics card?
Do you encounter other strange problems with graphical applications?

That’s quite simple, you can install it in two ways.
Or you choose the OneClick way, then you can simply search for wine and click on OneClick install. (here)
A lot of users don’t recommend to use OneClick because you’ll can easily get a lot of repos breaking your system.
But if you make sure you’ve disabled the option “Remain subscribed to these Repositories after installation” and check your repos after install than there’s IMO no problem.

Or you could manually add the repo through YaST and install/update wine and then disable the repo again.

The only thing I could conclude out of this observation is that it may not be a problem with wine but with your graphic card driver.

I don’t think this really matters, but you could try to run these games with audio disabled.

It’s very hard to make a conclusion out of that.
The games could use complete different techniques.

I think instead of resolution you should look at the driver.
A few tips that may work:

  • Disable desktop effects if enabled.
  • Check if you’ve got glx support by running this:
glxinfo | grep "direct rendering"

It should return “Direct Rendering: Yes”.

Best of luck!:wink:

Thanks again for your response, Edward_Iii.
I had previously tried the virtual desktop setting, but there could still be an operator error problem on my part.
It wouldn’t surprise me to find the wineconfig wasn’t paying attention to my configuration changes.
In particular the drive tab seems to be unresponsive. If I just type in a terminal “wine bc”, I get something back like c:\windows\system32\bc.exe not found. Instead if in a terminal I type wine /w98/windows/system32/bc.exe, the game executes, but with the black face-up cards.

I will go thru the repository removal and replacement as recommended by your link. Besides the “stock” repros that come with the install DVD, I have added Packman and the openSuse wine-build. For some reason zypper thinks the openSuse wine-build are from a different vendor.

Building wine from a source is something I can handle if I can download all the pieces over my dial-up link. So far I haven’t found a tar.bz2 for the latest stable wine. From what I see of wineHq forum, it’s necessary to join, just to view the posts. That seems heavy to me!

Regarding the media, I did copy the DVD and install from the copy, but I ran the media verification from the install DVD prior and it passed. What more could I do here?

Yast HW Info tells me my display HW is i845. The driver is shown as i915 and it was furnished by the install. This is a place I could use some guidance, and I welcome the chance to dive into it.

From a fresh install there is a place to check for third party drivers, and maybe Intel has a newer openSuse driver that I can install. Sysconfig may also have some driver options I can change.

My desktop affects aren’t enabled and the glxinfo | grep “direct rendering” does return Direct Rendering: Yes. My monitor is probably not relevant either, but it is an HP pavilion vf52 LCD.

For now I would like to explore the driver before attempting a new wine install. Can you give me more guidance on how to further probe into my video driver? Heboland

Hello heboland,

Not sure why zypper thinks that the openSUSE wine-build repo is from a different vendor.
What message does zypper give you?

Strange, AFAIK you can just view the post on the wineHQ forums.
I can just read the posts in this thread: WineHQ Forums View topic - Editing is disabled

There’s nothing more you can do here.
If the verification succeeds then you’re almost 100% sure you haven’t got a defect iso and/or cd.

All seems right, from what I can see you have Intel drivers installed and the are working.
But maybe a bug in the driver you use is causing the black faces?

The best thing you can do is gather information.
I recommend you read this: openSUSE Graphic Card Practical Theory Guide for Users

You could also search for problems regarding your graphics card/driver.
Which graphics card do you have?

Best of luck!:wink:

Thanks again for your reply Edward_Iii!

I did read the link and several embedded links.

One ususual result was that I got a seg-fault running Xorg - configure as root from runlevel 3. At runlevel 3, I did login as root and ran the command directly rather than login as myself and use the su -c Xorg … To me there’s no difference.

It was a relief to see the display come back up in runlevel 5. No xorg.conf.new was created at runlevel 3 when the command crashed.

On my hardware the video connector is on the MB riser, so I believe the “video card” is part of the mother board.

The greps of /var/… logfile came up as Intel for the (II) and (==).

A customization I have that again I think should be of no consequence is both root and myself are zshell logins rather than bash. This customization has never caused me a complication in the past.

I have tried unsuccessfully to google for other instances of my problem. It may be that it takes to many words in the search to limit the scope. When I do search, I get some hits from the winehq site.

It surprises me that google can display a thread from a winehq hit, but that site won’t let me look at past posts without registering!

As the holiday season approaches here, I have left my computer behind for a couple of weeks, so I will be out of touch.

When I get back to my box, I may resurrect this thread. Heboland

Hello heboland,

Strange, you could also try renaming your xorg.conf.
Then openSUSE will generate the configurations by itself without saving it to xorg.conf.

AFAIK Intel graphics cards are well supported under Linux.

Very strange, I couldn’t find any thread that I couldn’t view without registration.
Could you give an example link?

Actually it doesn’t surprise me that Google can view the thread and a normal visitor can’t.
Sometimes a site let’s bots index there site so that they show up in search engines.

Have a nice holiday!:wink:

Hello Edward, List,
Can I resurrect this thread, or should I start a new one?

I’m back again a year later, now with openSuse 11.4 and LXDE, a CRT monitor, but the same HP P4 tower.

The new wine is displaying everything correctly on two of three applications - one W98 and one XP game.

I do have a W98 boot on this system and it displays the Bicycle Cribbage correctly, but wine still displays the card faces only as total black.

Also I have other 11.4 boxes here with the same wine, but the cribbage cards are displayed correctly.

Most likely this is a graphics adapter issue with this tower.

If so, can I get graphic adapter driver upgrade information here? HW info has this to say about the HP tower graphics:

Device i845
Driver i915

Framebuffer Device Intel 845 Graphics Controller

Let me leave things here!! I’m on dial-up, so this isn’t easy! Heboland.

Hello heboland,

There’s no need for starting a new thread, AFAIK it’s still the same problem.

Could you tell which version of wine your running now?

Most likely this is a graphics adapter issue with this tower.

If so, can I get graphic adapter driver upgrade information here? HW info has this to say about the HP tower graphics:

Device i845
Driver i915

Framebuffer Device Intel 845 Graphics Controller

I’m afraid I don’t know much about Intel graphic drivers.
Could you post the output of this command:

rpm -qi xorg-x11-driver-video

And the output of this command:

cat /etc/X11/xorg.conf.d/50-device.conf


The first command is to get information about the package containing the intel driver
and the second command is to get a xorg configuration file.

Best of luck!:wink:

Thank you Edward!

I have the command results for you.

wine –version
wine-1.3.12

rpm -qi xorg-x11-driver-video
Name : xorg-x11-driver-video Relocations: (not relocatable)
Version : 7.6 Vendor: openSUSE
Release : 52.4 Build Date: Tue 22 Feb 2011 05:43:22 PM CST
Install Date: Wed 02 Mar 2011 05:49:57 AM CST Build Host: build31
Group : System/X11/Servers/XF86_4 Source RPM: xorg-x11-driver-video-7.6-52.4.src.rpm
Size : 7124283 License: MIT License (or similar)
Signature : RSA/8, Tue 22 Feb 2011 05:45:59 PM CST, Key ID b88b2fd43dbdc284
Packager : openSUSE:Submitting bug reports - openSUSE
URL : X.Org Wiki - Home
Summary : X.Org video drivers
Description :
This package contains X.Org video drivers.
Distribution: openSUSE 11.4

cat /etc/X11/xorg.conf.d/50-device.conf
Section “Device”
Identifier “Default Device”
#Driver “radeon”

Required magic for radeon/radeonhd drivers; output name

(here: “DVI-0”) can be figured out via ‘xrandr -q’

#Option “monitor-DVI-0” “Default Monitor”
EndSection

Heboland

Hello heboland,

There is a newer version of wine in the Emulators:/Wine repository.
Index of /repositories/Emulators:/Wine/openSUSE_11.4
I’m afraid it won’t solve the problem, but perhaps it’s worth a try.

It isn’t worth updating, the changelog only states bugfixes for recent intel graphics cards.

I’ve got no idea what the source of the problem could be.
Searching for more information I found that Intel graphics cards don’t work well with wine:
General Wine Troubleshooting - Wine-Wiki

Maybe it has something to do with font rendering, since it only affects faced-up cards?
Try changing the registry key HKEY_CURRENT_USER\Software\Wine\X11 Driver*ClientSideWithRender* to N.
If it doesn’t exist you’ll have to create it.

To add a folder right click New->Key… and to add a value right click->New->String Value.

Best of luck!:wink:

Thanks again Edward!

I tried the addition of the registry key, but like you suspected, there wasn’t any change.

On this registry topic, could I gain anything by examining the actual W98 registry, as my system can boot W98-SE?

Also I have the other 11.4 boxes here that will correctly emulate the cribbage game. If it made sense, I could duplicate a successful registry.

Later tonight I’ll try to update to the newer wine. Since I’ve already updated my wine with Yast SW manager, I will have to do more to get a newer version.

It may be that I don’t have the repository enabled that holds the newer version. I would like to do this upgrade with zypper, but I don’t know all the necessary steps.

I can keep poking at this problem and if I do make some progress, report back. Heboland

Hello heboland,

I’m afraid not, the registry key was part of wine.
You wouldn’t find it in a normal Windows registry.

This won’t work since on your other 11.4 boxes the game runs with the default wine registry keys/values.
Copying them to the troublesome 11.4 installation wouldn’t change a thing.

It’s quite easy, first you’ll have to add the Emulators:/Wine repository using this command:

zypper ar http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.4/ wine

This will add a repository with the name wine.
Now you’ll have to update/install wine:

zypper up wine

Best of luck!:wink:

Edward, thanks for the zypper command lines!

I tried them with this result. This machine should be HW capable of handling a cache even tho it is dial-up connected.

Apparently I didn’t give the proper answer to the KEY question. As you can see, I took the default.

root[502] zypper ar Index of /repositories/Emulators:/Wine/openSUSE_11.4 wine
Adding repository ‘wine’ [done]
Repository ‘wine’ successfully added
Enabled: Yes
Autorefresh: No
URI: Index of /repositories/Emulators:/Wine/openSUSE_11.4

root[503] zypper up wine
Download (curl) error for ‘http://download.opensuse.org/distribution/11.4/repo/oss/suse/setup/descr/packages.en.gz’:
Error code: User abort
Error message: transfer closed with 169063 bytes remaining to read

Abort, retry, ignore? [a/r/i/?] (a):
Error building the cache:
Can’t provide /suse/setup/descr/packages.en.gz
Warning: Disabling repository ‘openSUSE-11.4-Oss’ because of the above error.

New repository or package signing key received:
Key ID: 8E5578B7233AB63D
Key Name: Emulators OBS Project <Emulators@build.opensuse.org>
Key Fingerprint: 09E258099B678BCA07F848C58E5578B7233AB63D
Key Created: Tue 03 Aug 2010 06:35:25 AM CDT
Key Expires: Thu 11 Oct 2012 06:35:25 AM CDT
Repository: wine

Do you want to reject the key, trust temporarily, or trust always? [r/t/a/?] (r):
Error building the cache:
Signature verification failed for repomd.xml
Warning: Disabling repository ‘wine’ because of the above error.
Loading repository data…
Reading installed packages…
No update candidate for ‘wine-1.3.12-3.4.i586’. The highest available version is already installed.
Resolving package dependencies…

Nothing to do.
root[504] wine --version
wine-1.3.12
root[505]

Do you have any advice for getting the upgrade to happen? Heboland

Hello heboland,

Reading the output I see that the Wine repository has been disabled.
First you’ll have to enable it again:

zypper mr -e wine

Then you can try installing/updating wine:

zypper up wine

It should ask to accept the key again, you’ll have to answer t or a.
I recommend you accept the key always, otherwise you’ll have to accept it every time the wine repository gets refreshed.

Perhaps we can find the problem if we run it with winedebug.
Just run the same command as always but replace wine with winedbg.

Good luck!:wink:

Edward, I did make some progress!

Your winedbg idea sounded good, but the impression I got from zypper is that winedbg was on a different repository.

I think zypper added a winedbg repository, but this is how it went:

root[503] zypper up winedbg
Download (curl) error for ‘http://download.opensuse.org/distribution/11.4/repo/oss/suse/setup/descr/packages.DU.gz’:
Error code: User abort
Error message: transfer closed with 157487 bytes remaining to read

Abort, retry, ignore? [a/r/i/?] (a):
Error building the cache:
Can’t provide /suse/setup/descr/packages.DU.gz
Warning: Disabling repository ‘openSUSE-11.4-Oss’ because of the above error.
Building repository ‘winedbg’ cache [done]
Loading repository data…
Reading installed packages…
‘winedbg’ not found in package names. Trying capabilities.
No provider of ‘winedbg’ found.
Resolving package dependencies…

Nothing to do.
root[504] zypper mr -e winedbg
Nothing to change for repository ‘winedbg’.
root[505] zypper up wine
Download (curl) error for ‘http://download.opensuse.org/distribution/11.4/repo/oss/suse/setup/descr/packages.gz’:
Error code: User abort
Error message: transfer closed with 4990957 bytes remaining to read

Abort, retry, ignore? [a/r/i/?] (a):
Error building the cache:
Can’t provide /suse/setup/descr/packages.gz
Warning: Disabling repository ‘openSUSE-11.4-Oss’ because of the above error.
Loading repository data…
Reading installed packages…
There is an update candidate for ‘wine’, but it is from different vendor. Use ‘zypper install wine-1.3.32-1.1.i586’ to install this candidate.
Resolving package dependencies…

Nothing to do.
root[506] zypper install wine-1.3.32-1.1.i586
Download (curl) error for ‘http://download.opensuse.org/distribution/11.4/repo/oss/suse/setup/descr/packages.en.gz’:
Error code: User abort
Error message: transfer closed with 497759 bytes remaining to read

Abort, retry, ignore? [a/r/i/?] (a):
Error building the cache:
Can’t provide /suse/setup/descr/packages.en.gz
Warning: Disabling repository ‘openSUSE-11.4-Oss’ because of the above error.
Loading repository data…
Reading installed packages…
Resolving package dependencies…

Problem: wine-32bit-1.3.12-3.4.i586 requires wine = 1.3.12, but this requirement cannot be provided
Solution 1: install wine-32bit-1.3.32-1.1.i586 (with vendor change)
openSUSE → obs://build.opensuse.org/Emulators
Solution 2: do not install wine-1.3.32-1.1.i586
Solution 3: break wine-32bit by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): 1
Resolving dependencies…
Resolving package dependencies…

The following packages are going to be upgraded:
wine wine-32bit

The following packages are going to change vendor:
wine openSUSE -> obs://build.opensuse.org/Emulators
wine-32bit openSUSE -> obs://build.opensuse.org/Emulators

2 packages to upgrade, 2 to change vendor.
Overall download size: 12.5 MiB. After the operation, additional 7.5 MiB will
be used.
Continue? [y/n/?] (y): y
Retrieving package wine-32bit-1.3.32-1.1.i586 (1/2), 12.0 MiB (96.9 MiB unpacked)
Retrieving: wine-32bit-1.3.32-1.1.i586.rpm [done (4.6 KiB/s)]
Retrieving package wine-1.3.32-1.1.i586 (2/2), 532.0 KiB (2.3 MiB unpacked)
Retrieving: wine-1.3.32-1.1.i586.rpm [done (4.6 KiB/s)]
Installing: wine-32bit-1.3.32-1.1 [done]
Installing: wine-1.3.32-1.1 [done]
root[507] which wine
/usr/bin/wine
root[508] wine --version
wine-1.3.32
root[509] which winedbg
/usr/bin/winedbg
root[510] winedbg --version
wine: created the configuration directory ‘/root/.wine’
err:process:__wine_kernel_init boot event wait timed out
Usage:
winedbg --gdb ] prog-name prog-args ] | <num> | file.mdmp | --help ]
root[511]
A menu comes up to install Gecko, but recommended to use the distro version, so I cancelled that install.

This is what winedbg wrote into a user console:
frank[4557] which wine
/usr/bin/wine
frank[4558] which winedbg
/usr/bin/winedbg
frank[4559] winedbg cribbage.exe
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in ‘/home/frank/.wine’ has been updated.
WineDbg starting on pid 002a
err:wineconsole:WCUSER_SetFont wrong font
err:wineconsole:WCUSER_SetFont wrong font
0x7b85d614: movl %edi,0x4(%esp)
Wine-dbg>

I’m going to send this before it gets any longer! Heboland

Hello heboland,

I’m sorry, winedbg isn’t a separate package.
It comes with the wine packages, by replacing wine with winedbg I meant the command for running the game, not the zypper commands.

Anyway, reading the output I see that wine is updated now.

It’s indeed better to install it from the repositories, that way it updates along with the wine version.
The command for that would be:

zypper in wine-gecko

Now I think of it, perhaps it’s easier to run it like this:

WINEDEBUG=all wine <file>.exe 2>tmp.log

This will create a file named tmp.log.
It will probably be to big to put in a post, but you can upload it to SUSE Paste

Best of luck!:wink:

Hello again Edward, List,
Sorry for the lag in my response! Let me start with zypper in wine-gecko. zypper comes back with another change vendor option message similar to the wine update.

I chose to change vendor like I did with the wine update. I think my wine-gecko came from the same vendor as the wine did.

With the new wine and the new wine-gecko the Cribbage.exe hangs at the card shuffle and never gets to deal. To make sure the working system would work with the new SW, I updated the wine and installed wine-gecko from the same vendor.

Now on the “working” system also, the Cribbage.exe hangs at the card shuffle, identical to the “broken” system.

One more piece to the puzzle is that I ran the “file” command on Cribbage.exe. It came up with a file type of Win 3.x, so I changed the wine config on both systems for Cribbage.exe to 3.1. That change didn’t affect the game behavior. The logfile was collected with this new wine config for this game.

So on to the debug, I use zshell, but attempted to invoke your command line exactly. I don’t think the environment variable DEBUG got set to “all”, but I collected a huge log file.

frank[4591] WINEDEBUG=all wine Cribbage.exe 2>Criblog.txt
[1] 4849 terminated WINEDEBUG=all wine Cribbage.exe 2> Criblog.txt
WINEDEBUG=all: command not found
frank[4592] print $WINEDEBUG

The termination stuff is the result of having to kill the game process after it “hangs” at the shuffle. Note that “hang” may be a misnomer as the log file continues to grow during the hang.

This log is from the “broken” system, about 30MB in size. The bz2 archive is about 3MB. I’ll try to upload the Criblog.txt.bz2 file to the link you gave me.

Thanks again for your help and advice with this problem. I’m going to send this now and experiment with the upload. heboland.