"Black box,' no video/flash in Firefox; Google chrome shows no flash installed

After doing a fresh install of Opensuse 12.2 32 bit KDE and after going through all the upgrades, and installing flash from yast, Firefox and Google Chrome wouldn’t play any video. Firefox had a black box where the video plays, that would flash a few times as it tried to load, and Google Chrome just gave a message at the top of the page saying that no flash player was installed.

After some sleuthing, and breaking down and reading the f’ing guide at Arch Linux’s flash wiki: https://wiki.archlinux.org/index.php/Browser_Plugins#Flash_Player:_Videos_not_working_on_older_systems

it said that on an older computer (I have a Compaq from 2003, apparently, with an AMD processor) the way to determine if the CPU will work with newer versions of flash is to open a terminal and run

# cat /proc/cpuinfo | grep sse2

If something is returned in the terminal, newer versions of flash will work. In my case, all that was returned was the hash indicating that I was root. The guide gives a link to Adobe’s site where older versions of flash are available. Yast had originally installed flash 12.1, and I removed that by searching for “flash” in yast, and removing three programs, and downloading and un-tarring Adobe’s flash installer, and copying libflashplayer to /usr/lib/browser-plugins. Now I can play video in both Firefox and Chrome. Google says that the flash player is out of date, and I have to select “run this time” when I want to play a video, and the video is slower and “jerkier” than it is on other computers I have, but it works. I noticed that after going to Adobe’s download page, that later versions of flash are separated into 32 and 64 bit versions, and the older version I used (10.3, if I remember correctly) wasn’t offered with any ‘bit’ option, just a name(flash) and a version number.

BTW, after all of this, I’m impressed with Opensuse! I have Mint and Fedora installed on a newer computer with a better CPU, and Opensuse is faster (and probably more light weight) than either of them! Congrats to the guys who make it.

One consequence of doing all this was that I was told that, on Youtube, if you scroll all the way to the bottom of the page and select “Try something new,” Youtube gives you the option to watch videos in html5. There aren’t a lot of html5 videos out yet, and it only works in Youtube, so sites like ted.com and others still won’t play anything without having flash installed, but you can watch something without flash that way, too.

You may optionally try out totem-browser-plugin-vegas(flash alternative for videos).
It works with youtube and metacafe and i have tried it out on mozilla and opera and it does play flash content very well on these sites.
I don’t know if totem works on KDE :frowning: