Black and white squares during KDE login

After installing the Nvidia driver I get black and white boxes displayed during KDE login. After logging in the graphics are normal. I tried installing the nvidia driver from the opensuse repository and manual installation of the latest stable driver. I do not have this problem when I use Kubuntu so I don’t think it’s a hardware problem.
Any suggestions?

I think I have a kind of similar problem. Instead of black and white squares I get graphical glitches like this:

http://www.myslug.de/fahnen/strange.jpg

This is not at the first login, almost when I relogin or shut down. You can see that instead of the normal nvidia logo.

It starts with the 180x drivers and openSUSE 11.1 KDE4.

Maybe something with the buffers? Card works normal under Linux (ioquake3 and so on) just that strang glitches while login / logout.

Any idea how to fix that?

cu
Gargi

Yes, it’s a problem with package kde4-kdm-branding-openSUSE.

Select it for removal, and the upstream branding package will be automatically selected for you.

Accept that, and you should find that all is ok.

I see there is a new package in there called kde4-kdm-branding-respin, maybe that is a fixed version, no idea.

Good luck :slight_smile:

That helped! Thank you!

cu
Gargi

It did not solve my problem. Indeed I get graphical corruptions as in the picture shown above. I removed the kde4-kdm-branding-opensuse package which automatically activated the upstream package. However, this package did not contain the opensuse theme. I use kde4.2.2. Any other suggestions.

I think this may be unique to the nVidia proprietary driver.

I typically use old hardware with the openGL or VESA driver, and I have NEVER encountered anything like this with the openGL or VESA driver.

Then on the weekend I put a new BFG nVidia 8400GS (512MB) PCI graphic card in my old athlon-1100+ PC. I want to try out the new card to checkout vdpau capabilities for High Definition video.

KDE4 worked with this nVida card (albeit very slow as it is a PCI card) under the VESA driver. BUT KDE4 did not function under the nVidia 180.44 proprietary driver, giving the sort of screen that HRGargi posted.

I had KDE3 login problems, and after a few hours on IRC #openuse-kde (with various suggestions not working) I re-installed 11.1, with no KDE4 and only KDE-3.5.10. I note KDE3 has similar problems with the nVidia 180.44 proprietary driver, in KDE3 as it has in KDE4 albeit KDE3 lasts a bit longer than KDE4 before they occur. But they still do occur in KDE3 ie. KDE3 also after some minutes gives the same screen that HRGargi posted.

I had thought this might be a PCI timing or old PC power problem. I don’t think its overheating, as I have the case open and the PC appears to be running fairly cool.

I had also thought this might be infant mortality in the new graphic card, but if the VESA driver works, then that sort of rules out infant mortality, … although maybe the proprietary driver is more “timing critical”. … With my reading now of others also experiencing this, I am now leaning toward it also possibly being a driver problem.

I’m going to put the nVidia 8400GS card on a slightly newer PC (athlon-2800) over the weekend, where that 2nd PC also has MS-Windows in addition to Linux. I’ll try the card with proprietary nVidia drivers under both OS, and see if I can rule out hardware problems.

It is unpleasnt, but I think you will find there is a good chance the openGL and Vesa drivers work.

Could eveyone else please also list:
a. your graphic hardware, and
b. your graphic driver/version
Without that it is very difficult to pin down any commonality between what we are all observing.

I had both problems mentioned. Instead of black-white squares mine were
purple and white. Following instuctions in the post, my problem is gone. I
noticed yesterday there is an update to the SUSE branding RPM, does
anyone know if this fixes the problem or is updating to KDE4.2.2 required?
I am not ready to go to 4.2.2 based on problems people are reporting, my
4.2.1 is mostly stable.

growbag wrote:

>
> Yes, it’s a problem with package -kde4-kdm-branding-openSUSE-.
>
> Select it for removal, and the upstream branding package will be
> automatically selected for you.
>
> Accept that, and you should find that all is ok.
>
> I see there is a new package in there called
> -kde4-kdm-branding-respin-, maybe that is a fixed version, no idea.
>
>
> Good luck :slight_smile:
>
>

Russ
openSUSE 11.1 (2.6.27.19-3.2-default x86_64) KDE 4.2 release 106, Intel
DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc
(2)

Following which instructions? Just updating kde4-kdm-branding-openSUSE or also kde4-kdm-branding-respin ? Also, what nVidia driver were you using for this to work? Which nVidia hardware do you have? [Is this the GeForce 8400 GS in your sig ? ].

Given a similar effect can be observed on KDE3, and that a fix may be available for KDE4, makes me suspect a systemic mistake by the same person(s) or organization in generically developing or packaging for KDE (either the driver, or an openSUSE desktop support package).

I’m currently puzzling over how safe it is to apply a similar philosophy/workaround to KDE3.

I note KDE-3.5.10 on openSUSE-11.1 comes with kdebase3-SuSE-branding-openSUSE installed by default.

If one selects (in zypper) for installation kdebase3-SuSE-branding-upstream, then zypper marks that for install, and also flags for removal

  • kdebase3-SuSE-branding-openSUSE
  • kdebase3-SuSE
  • kdebase3-SuSE-lang
  • kio-sysinfo
    It appears to me that more is being removed than being installed. Hence with my not knowing the specifics, this does not look too safe for KDE-3.5.10 (at least not until I understand more). The descriptions of “standard SuSE desktop and menu extensions for the KPanel” does not look to me like something that one would want to remove.

I may log on to IRC #opensuse-kde and see if anyone there has any ideas about this wrt KDE3.

My setup is -

openSUSE 11.1 64bit
KDE 4.2.2, release 111
Kernel - 2.6.27.21-0.1-default
GeForce 8400M
Driver: 3.0.0 NVIDIA 180.29 (from the repo)

I simply deselected the branding package, which automatically selected the upstream one.

I get an ugly, non-suse login screen, but no other artifacts on the screen…

Turns out I was correct. I installed kdebase3-SuSE-branding-upstream, which resulted in removal of the 4 above packages (from run level 3) . When I then went to runlevel5, the kde panel was devasated, with KMenu, Desktop access, Quickbrowse menu and window list all gone from the KPanel. Desktop was stable but without the KPanel populated, its not a KDE that I like.

I restored the 4 removed apps, and removed the upstream kdebase3 and went back to KDE3 but the panel was still borked from the upstream test. So I went back to run level 3, changed .kde to .kde-back, and restarted kde3. Of course while I got kpanel back properly, the desktop corruption started again. Uck !

So I restarted KDE3 (to get rid of corruption), and then immediately after starting KDE3, before corruption re-appeared, I changed:

  • Configure Desktop > Appearance and Themes > splash screen > to default
  • Configure Desktop > Appearance and Themes > Theme Manager and change to KDE_Classic

Desktop appears stable now.

It looks to me like there is an incompatibility between the openSUSE selection under Theme Manager and the proprietary nVidia driver. The KDE_Classic works ok.

I need to let this run for a few hours to see how stable.

But IMHO selecting the kdebase3-SuSE-branding-upstream in KDE3 (which NO one suggested - I simply tested on m own) is not the best approach. Rather its better to go to the KDE_Classic theme.

I use opensuse 11.1 x86_64, KDE4.2.2 from factory and the latest NVidia driver. I tried installing the upstream kdm package but this package appears to lack the SUSE theme. It resulted in an ancient looking KDM login screen. So far no solution. At least it’s good to see that I’m not the only one having this problem. Did anyone report this bug?

gielhendriks is it possible that it is the SUSE theme that is incompatible with the nVidia driver on kde4? That is my experience thus far on KDE3. The ancient looking KDE screen appears more stable on KDE3 with the proprietary nVidia driver.

When I asked the view of some IRC channel freenode #opensuse-kde guru’s on this, they thought the bug report should be raised on nVidia’s driver for not being compatible with openSUSE’s theme . … puzzles me … As I had thought perhaps its the other way around (and the bug report should be on openSUSE) ? … Maybe it has to be raised on both ? < not sure >

I found using the KDE_classic theme, that if I changed the desktop icon size from the default 32 to 48 (which I like to do) the instability came back. So the desktop icon size appears to cause the nVidia driver problems. There may also be other aspects that cause this nVidia driver problems.

An update on this. KDE_Classic is more stable than the SUSE_default theme, but after a few hours with the KDE_Classic theme the same corruption occurs. So its no long term solution.

I installed the new kde4-kdm-branding-respin package (which removed the upstream one) and the corruption came back.

I’ll try the compiled nvidia driver a bit later to see what happens.

Delete - mistaken post (I needed to read the thread better).

With your having a GeForce 8400GM, and user “upscope” having a GeForce 8400GS, and myself also a GeForce8400GS, … I am now wondering if this problem is specific to the GeForce 8400 series …

Can anyone else chime in on this?

I have a 8600GS. It could be a Geforce8 series problem. I also installed the respin package but that did not solve the problem. It’s a really strange bug. It is openSuSE specific because I did not have this problem using Kubuntu.