Blac screen during install - FirePro 7750

I’m trying to install OpenSUSE 42.3 and I hit a roadblock. During install, just after first screen and when kernel gets loaded I get a completely black screen and my monitor behaves like a device has been disconnected / powered off.
I’ve narrowed it down to FirePro 7750 card. When I add “nomodeset” to the boot parameters the installer launches. But I have no clue what to do so I could have proper graphics in the end :frowning: .
How should I deal with it? I’d love to revive this Precision t7500 workstation.

The Firepro line always seems a little flaky. It is a AMD chip so thus should work with either the radeon or amdgpu driver both are built in but you may need to force one or the other. I leave that to people more experienced with the AMD graphics stuff . In the mean time you can use the nomodeset to get going but at lower res then you probably would like

How would I do that?
I really don’t know how to get this card working - ****, how I wish the workstation had Nvidia card (while the proprietary driver is… well proprietary it works out of the box).
But I’m still committed to get this 7750 running so all pointers are more than welcome :slight_smile: .

First get the PC to install and then boot to X using the nomodeset.

Then you can edit the /etc/X11/xorg.conf.d/50-device.conf file. Dependent on the driver, you want, I speculate it could be something like

Section "Device"
  Identifier "Default Device"
     Driver "amdgpu"


Section "Device"
  Identifier "Default Device"
     Driver "radeon"

At some point in time, after a successful install, and good indications that your chosen graphics works, you will need to remove the nomodeset option.

I don’t have your hardware nor any radeon devices any more - so someone else will need to chime in with more specifics.

got the system installed with “nomodeset” parameter added to boot.
But still I can’t get the card working as it should - without nomodeset.
Is there some sort of boot parameter I can pass to try using specific driver (radeon or amdgpu) - or disable one? I know how to do similar thing when using Nvidia (disabling nouveau when using proprietary driver) but I don’t know the procedure for ATI/AMD cards.

Lets just check your card, can you show the output from;

/sbin/lspci -nnk |grep -A3 VGA

04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV730 GL [FirePro V7750] [1002:949c]
    Subsystem: Lenovo Device [17aa:0002]
    Kernel modules: radeon
04:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series] [1002:aa38]
  • let me know if I need to provide any more info.

Are the packages drm-kmp-default and/or xf86-video-amdgpu installed? If so look at removing those two and reboot and see how it goes.

Not directly related to this problem, but - I keep seeing this command suggested to check graphical devices. This command results in incomplete and hence misleading output. “VGA” here comes from device class/subclass 0x0300 which stands for “VGA compatible controller”; but e.g. nVidia here has class/subclass 0x0302 which stands for “3D controller” and so is omitted by suggested command.

03:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 830M] [10de:1340] (rev a2)
    Subsystem: Dell GM108M [GeForce 830M] [1028:062b]
    Kernel driver in use: nouveau
    Kernel modules: nvidiafb, nouveau

I suppose, using something "grep ‘[03…]’ could be better.

Unfortunately lspci does not allow filtering by class ID (contrary to manual page) - it requires class+subclass and offers no way to wildcard subclass.

@malcolmlewis : sadly removing those packages didn’t make a difference.
From the things I’ve tried - I blacklisted radeon driver (and removed nomodeset) then tried loading it after system booted. Resulted in immediate black screen and fans on gpu started spinning like crazy.

Ahh, no you need radeon, so remove the blacklist and rebuild initrd (mkinitrd) and reboot, no modeset either…

oh, sorry - my answer was confusing a bit. That was another try, separate from removing amdgpu driver and drm-kmp (which also resulted in black screen when there was no nomodeset).

OK, so radeon is not blacklisted, and when you did all this you ran the mkinitrd command? If not sure, run it again :wink:

Is the system set to autologin? What desktop environment? It might be age of your card…

I’m pretty sure nomodeset has been removed (checked by hitting ‘e’ in the initial panel and looking at the boot parameters).
GNOME as a desktop environment (tried with Xfce and lightdm as well), no autologin - but that shouldn’t matter as I’m not getting anywhere near X. As soon as radeon driver is invoked the screen goes black.

The card works perfectly in Windows, so I don’t think it is a damaged card.

If you look at the lspci output, it wants to use the radeon module but can’t…it’s still blacklisted somewhere…

If you run the command;

lsmod |grep radeon

I have a feeling it won’t show anything?

If it doesn’t, look down in /etc/modprobe.d for a radeon file or entry;

fgrep radeon /etc/modprobe.d/

You need to rebuild initrd as root user run;


The lspci output should show a line Kernel driver in use: radeon

This is the output from SLED 12 SP3 which is what Leap 42.3 is built on and is running with GNOME fine;

/sbin/lspci -nnk |grep -A3 VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4330/4350/4550] [1002:9552]
    Subsystem: Dell Device [1028:02aa]
    Kernel driver in use: radeon
    Kernel modules: radeon

but isn’t it because of nomodeset? When I boot with nomodeset I get a pretty clear warning that radeon won’t work with this setting.
And mind when I get rid of nomodeset I get a black screen - so I had to boot with nomodest to give you lspci output.

Boot without nomodeset, if you get a blackscreen wait a bit… do you get a mouse cursor or blinking _ in the top left? Press ctrl+alt+F1 do you get to a console session?

If you try a boot with the radeon driver and it fails, and then you boot again with ‘nomodeset’ and it works, I would be most curious to see the content of the /var/log/Xorg.0.log.old file to learn if it yields any hints why the radeon boot failed. The Xorg.0.log.old file should contain graphic boot information on the failed graphical boot before the current boot.

There could be many causes of a failed boot – for example I have read of cases where users with old radeon hardware needed the boot code


because the plymouth effort to create a flicker free boot process was interfering with their radeon boot. I’m NOT saying that has anything to do with your problem. Rather I am saying that without more information (such as ‘might be’ in an Xorg.0.log.old file) I fear we could be reduced to iterative speculation, which can be a very frustrating way to troubleshoot.

nope- system gets completely dead and unresponsive. I can’t log to console. Monitor behaves like the cable has been plugged out.

OK, so you have not created/edited any of the config files in /etc/X11/xorg.conf.d/?

So, need to see the old Xorg.N.log.old (should be previous boot, check the file date with ls -la)), post up to somewhere like SUSE Paste and set to never expire please.

Can you boot with nomodset, upload the log file then lets set the console login, rather than graphical as a test;

systemctl set-default
systemctl reboot

Without nomodeset does the system boot to a console login?