bizarre sound issue -- this makes no sense to me

I’m on tumbleweed, but not sure that matters.

YaST->Hardware->Sound->Play Test Sound plays sound

As a user with /etc/group permissions for audio, pulse, and pulse-access,

$ speaker-test -Dplug:surround51 -c6 -l5 -twav plays sound

$ pianobar plays with no sound

any browser apps or amarok, no sound

Does this combination of behaviors ring a bell with anyone?

post your repo list

zypper lr -d

could be a missing package or a misconfigured sound card, the sound could be send to the hdmi device instead of the sound card.
What desktop are you using as plasma5 and gnome use different audio config apps, personally I think it’s a repo issue as I think you don’t have the patented codecs so tell the output of zypper lr -d

I had also taken the steps in, and then rebooted. I should have mentioned that. My desktop is plasma5.

[size=1]# | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
1 | Packman_Tumbleweed | Packman Tumbleweed | Yes | (r ) Yes | Yes | 99 | rpm-md | |
2 | rexecd’s_RPMs | rexecd’s RPMs | Yes | ( p) Yes | Yes | 99 | plaindir | dir:///home/rexecd/rpms |
3 | google-earth | google-earth | Yes | ( p) Yes | Yes | 99 | rpm-md | |
4 | openSUSE-20160408-0 | openSUSE-20160408-0 | No | ---- | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-ATAPI_DVD_A_DH16A1S |
5 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | Yes | 99 | NONE | |
6 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | |
7 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | |
8 | repo-source | openSUSE-Tumbleweed-Source | Yes | (r ) Yes | Yes | 99 | yast2 | |
9 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | |


Now switch vendor to packman

zypper dup --from 1

All mutimedia will then be from packman

Also may want to install pavucontrol this often will allow corrections to sound problems

The behaviour can be explained by not having the correct codecs installed. It can also be explained by pavucontrol redirecting the sound to the wrong sound device.

Hopefully gogalthorp’s suggestion wrt installing apps from Packman will sort the issue if the issue is codec based. If not, take note of his recommendation to install pavucontrol. The logic there is pulse audio provides the functionality to redirect sound (and control sound volume) on a per application basis, directing the sound to different sound devices.

For example, on a test PC I have, with two sound devices, I can have application-a send sound to sound-card-0 and at the same time have application-b send sound to sound-card-1, with sound from two different applications playing sound at the same time, through two different speaker/sound-card combinations. If thou, I had no speakers connected to sound-card-1 (in my example) and if I directed pulse to send the sound from application-b to that sound card-1 with no speakers connected, then I would hear not sound from application-b, even thou application-a works with sound-card-0 and its speakers.

Something is still … off.

Appropriate packages were reset to packman (I’d never seen that command-line option before – neat!) and pavucontrol installed.

There still a problem with sound working for some things and not working for others:
Now I have sound via command-line pianobar (but not in the browser, at the Pandora site and elsewhere).

**And sound quality, when it’s working, is a bit **y depending again on which application:
I have 2 built-in audio sources turned OFF in configuration.
Creative EMU20k2 (X-Fi Titanium) is ON. Set up physically for 5.1 sound, which plays just fine using the speaker-test line up above. But 5.1 is completely garbled for pianobar; setting to Analog Stereo Output in pavucontrol plays, well, stereo through two speakers.

try deleting the pulse config files

rm -r ~/.config/pulse


After doing that and a reboot, but nothing else …

speaker-test works.
pianobar now isn’t.

Can you sense the level of my cluelessness with sound stuff? ;^)

do you have pulse audio installed?
do you have pavucontrol installed?
what does

zypper se -si pavucontrol 

The audio control is desktop dependent, plasma 5 and gnome (and the others) have their own audio widget,
if you don’t have pulseaudio install it,

you can use yast fur troubleshooting
did you hear a sound, if not check your volume level.
in yast check and see what card is selected for audio source it could be your graphic cards hdmi audio, check that the proper sound device is selected.

Status is:

pulse audio and pavucontrol are installed.

$ zypper se -si pavucontrol
Loading repository data…
Reading installed packages…

S | Name | Type | Version | Arch | Repository
i | pavucontrol | package | 3.0-1.3 | x86_64 | (System Packages)
i | pavucontrol-lang | package | 3.0-1.3 | noarch | (System Packages)

YAST -> HARDWARE -> SOUND -> OTHER -> TEST plays a sound.
$ speaker-test -Dplug:surround51 -c6 -l5 -twav plays a sound.
command-line pianobar does not play a sound

YaST sound configuration shows 3 options:

The EMU20k2 is configured as sound card 0
The other 2 options are not configured.

I should check in System Settings for Plasma > Multimedia > Audio and Video
Toggle through the sections there and make sure the devices used match what you have set in Yast > Hardware > Sound

The above makes perfect sense to me. The speaker-test was fixed by deleting the pulse config files. But the pulse audio configuration for pianobar which was likely inside those configuration files and was also deleted at the same time. Likely pianobar app needs a simple reconfiguring, which can be done with pavucontrol.

Today’s update.

Plasma and YaST controls were out of sync. So that’s fixed; rebooted.

I have only 1 sound device configured; the other 2 device profiles are Off on both plasma and pavucontrol and unconfigured in YaST. The one device is set to Analog Surround 5.1 output.

The sound test in YaST seems fine. speaker-test is fine.

I’m using Pandora music as my test, because the music stream is the same, only the app is changing.

pianobar is garbled.
Playing Pandora via the browser is clear.

I am tempted to reconfigure to a different device and try that, but the red part above makes it seem the problem isn’t the sound card.

Actually, that first line should have read that plasma and pavucontrol settings were out of sync.

what backend are you using in plasma’s phonon phonon-backend-vlc or phonon-backend-gstreamer
in my experience gstreamer works “nicer” but I’m not on TW so if you don’t like gstreamer try vlc’s backend

I was and still am using the gstreamer backend.

The problem appears to be fixed. Good quality sound all around.

But I haven’t changed anything since the 3 May post. I have rebooted a couple times (nightly shutdown).

Thanks, sincerely. I am happy to have my tunes. For anyone who wanders here looking for answers, I think the key for me was

Understanding that YaST (system) , plasma (desktop), and pavucontrol sound configuration are all separate and need to be looked at.