Bitmap fonts in GTK applications are invisible - Have worked previously

Hello! As my first post on these forums, I am not sure if it is in the right category, please excuse my ignorance.

I will start with a summary: Switched from i3 to Trinity Desktop Environment, and now my bitmap fonts are invisible in GTK applications.

Longer story:

I use the font Cozette for basically everything. I have it installed in $HOME/.fonts/cozette.otb, and it works really well with everything in Trinity, as well as other applications, except GTK applications.

Now, before we say that it does not work, I used it in i3, with GTK applications for about a year before switching over.

If I switch back to i3, GTK applications still do not recognize the font.

An fc-list | grep cozette, displays the font there, as it always has been.

I have attempted several ‘fixes’ that I have found around the net, but none of them have been specific to openSuse, so I am not sure if there is something I am missing. Where would you all start your search?

Thank you in advance,

I suppose this could be related to ~/.fonts/ deprecation many moons ago finally being reclassed as unsupported by the recognized leader in removing features and support. Try renaming (or for testing purposes, copying) ~/.fonts/ to ~/.local/share/fonts/. Or move (or copy) your ~/.fonts/ content to /usr/local/share/fonts/.

Do you have both of these installed?:

# rpm -qa | grep y-gtk

Since you prefer Cozette globally, you could try making it more global via /etc/fonts/conf.d/. There is contained 60-family-prefer.conf that contains lists of fonts in the order preferred. I override that with my own preference first listed in each category. The result is fc-match for any generic will result in my first choice being returned.

I attempted to move the fonts as you said and update the cache. It sees the font, both in ~/.fonts/ and in ~/.local/share/fonts/, though the same issue persists.

I uploaded a screenshot of what it looks like in, for example, lxappearance. If I select the font to use, or use the two packages that you asked if I had installed, which I do, to force my TDE font onto GTK applications, all text is gone.

So it would seem that the font is ‘found’ but not able to display - except Emacs, which just completely refuses to load the font at all saying it does not exist (but I have a suspicion that will solve itself if the rest is solved).


I read somewhere that hinting should be enabled to display bitmap fonts, and other places that antialiasing should be disabled for that font - though these settings have never been in place, and therefore I am confused as to why it suddenly became an issue after I started using TDE.

Thank you for your help so far - at least I tried something.

I found the solution!

So the disabling of antialiasing seemed to be the right solution, but it is very finicky about where you change this setting. I tried in the fonts.conf but that didn’t do anything.

In the Trinity Control Center, first to go fonts:

Then open the antialiasing window, and diable antialiasing for the range where your bitmap font size is. Mine is 10, so I kept the default low of 8, to 10.
Then I made sure hinting was enabled.


Doing this completely solved the issue.

Thank you for your patience, and hopefully this will help somebody else in the future.