Bison webcam uvcvideo not working anymore

I have been able to make my webcam work some time ago, but it does not work anymore. (I installed xen kernel recently, but I don’t know whether it’s related or not).

I am using Opensuse 11.2.

My webcam is a Bison uvc compatible webcam. It should work with the uvcvideo driver which is intalled by default with the kernel. My kernel is

Linux linux-61le #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 x86_64 x86_64 x86_64 GNU/Linux

lsusb gives:

Bus 002 Device 004: ID 5986:0241 Acer, Inc

dmesg gives:

  203.235792] uvcvideo: Found UVC 1.00 device BisonCam, NB Pro (5986:0241)
  203.235814] uvcvideo: No valid video chain found.

uvcdynctrl -l gives:

Listing available devices:
No devices found.

luvcview gives

luvcview version 0.2.1
Video driver: x11
A window manager is available
video /dev/video0
ERROR opening V4L interface
: No such file or directory

v4l-info gives:

open /dev/video0: No such file or directory

and indeed, there is no such file /dev/video0.

Has someone an idea? I searched through several forums and did not find a solution yet.

That’s an interesting topic.
I have bison webcams on two of my laptops from clevo.
I thought that it was not supported because it never worked with opensuse 10.3 nor with 11.1 .
Some research on the internet gave no correct guideline.

Some stupid questions :
Is there some option to give to uvcvideo module at loading ?
Is the camera activated via bios ?

I would be very suspicous of your xen or default kernel (which is it ?? ) . Still, you could try malcolmlewis’ uvcvideo-kmp-xen or default rpm for your kernel (assuming it is kernel-xen- or kernel-default- Do a search here for uvc :

my current kernel is
I don’t remember if I upgraded it between the time my webcam has worked and now. But I always had a “desktop” kernel.

Since I’m trying to make my webcam work again, I reinstalled the kernel (by removing it and resinstalling it while using the xen kernel) but it was in vain.

I also tried and installed uvcvideo-kmp-desktop but it did not work neither.

My computer is a clevo too. The uvcvideo module is loaded automatically when you hit Fn+F10 which activates the webcam. But there is this error “No valid video chain found.”

When typing

modinfo uvcvideo

it appears that there is a parameter that allows quirks. There might be a parameter that allows the cam to be cosniedered by the module. Example :

modprobe uvcvideo quirks=2

However, i tried this parameter with many different values without success.
Also, what is strange is that it doesn’t create any /dev/video device…

indeed, I tried to set this parameter in /etc/modprobe.d/99-local.conf too, but it did not work.