BIOS Complication (Sources Referenced) - Linux Only

As a reference point, the title is stating Linux only because this worked perfect when this pre-made was Windows. I wanted it to be Linux, so I wiped off Windows. Sorry for the stupid confusion here

Hey OpenSUSE Community,

I have been searching around the forums, and so far it seems that the reason for a strange experience I am having with my Linux OS Distro installation on a pre-made PC is being centralized to the Motherboard manufacture (ASRock).

#dmicode output:
Manufacturer: ASRock
Product Name: A320M-HDV R4.0
Version: AMD Ryzen 5 1600 Six-Core Processor

Some have also stated it could be the CPU of AMD.

From my own testing, what I have found is that it is not distro specific so I am comfortable thinking this is a Linux Kernel situation with either this board, CPU, or the combination of the two. How I have come to my understanding is because I have tried installing and (successfully) working with: Ubuntu, Mint (same), Fedora, and OpenSUSE.

Where the issue comes up is at the beginning of the BIOS splash screen. Upon first attempt, this will not come up. The work-around fo this, which I don’t understand very much on why, yet, is flipping the PSU’s I/O switch. By doing it very quick, the system moves to BIOS and in a few minutes - we are at Grub2 no issue.

Being a pretty good noob, I figured I would reach out to the community here and ask if anyone has ever run across a similar scenario with a similar set up or separate and could offer some advice. I am very interested in solving this but not experienced enough to know how best to go about this. Also, I am not afraid to play around to make it work. The process of learning is more fun. :slight_smile:

Also, since this was a pre-made/ship to house, the initial installation was Windows10. It wiped off easily enough and I have checked the partition/install of the platter and I believe Windows is 100% gone but - this might be another area I need to investigate further on.

Thanks everyone!

Source of information:[FONT=arial]


From your description I can only guess what your problem is. Your sequence of events is sketchy. It seems possible the problem is just as much a fault of the display as anything. UEFI BIOS sometimes complete their activity before they wake the display up in a compatible mode. I have multiple PC/display combinations here that do that. One of my workarounds is to make the default entry memtest. If it didn’t wake up quick enough, I just hit ESC, after which I’ll usually see Grub appear as it should. Another workaround can be turning off quick boot in the BIOS.

I bought an ASRock once. As long as Asus, Biostar, Gigabyte, Intel, MSI and other/older motherboard brands continue to exist, I don’t anticipate buying another. Mine didn’t last 30 days before needing replacement, and the replacement, an “Ultra” superceding model, didn’t last 5 years. My last three new motherboards have been MSI, Gigabyte and Asus.

Maybe PC producer configured it for a Win 10 in such a way.
Clear CMOS data, then try again.
Read mobo manual for details.
You will need to set up needed parameters in BIOS to get a proper working system.

Thanks for each of your responses to this issue I am experiencing. I am going to implement the suggestions soon and will follow up with the experience. Sorry, holiday weekend and having a 3 year old can make your life… busy. :slight_smile:

Thanks again, and I apologize for not having a great response to this situation yet.

Additionally, based on your experience in reading my post, do either of you (or others) have suggestions how this could be written more clearly for how to explain the experience for future post I will post?


Speaking with a friend of mine with much more Linux user experience than myself, he suggested that I review the boot options of the board and to see if it is boot priority to UEFI. It was, so I changed the boot priority to AHCI instead and this solved the issue.

Feeling a bit silly, but that is all a part of learning :slight_smile: lol

Thanks everyone!

Did you lose support for a NVME drives?