bios bootup from cd

i am trying to let my BIOS boot up from a CD afther installing openSUSE. so i went to my bios and configured it to boot to cd first then hdd, but it went to my hdd first. no cd…

i am trying to install another OS from cd…
how can i fix this? please help me!

A couple of possibilities: 1. The CD is not bootable. 2. The drive is broken.

Is the CD drive seen by the BIOS? Does the read light flash when booting, i.e. it attempts to read the bootloader?

the CD i have is bootable. i dont think the drive is broken.

how to check if the CD drive is seen by the bios?

what light flash?

i am using a laptop.

It should be listed as one of the available devices in the BIOS setup. Is there a LED that shows when CD is being accessed?

Try another CD, even another OS. You can never be too confident about CDs and CD drives.

it is listed as one of the available devices in the bios setup.

also. i just tried booting up with my windows 7 cd. it worked.

but my kubuntu cd wont boot?

Check the CD in another computer using the self-test on the CD. Also if your drive is old it may have problems with writable CDs but not factory CDs. Try another bootable CD-R in the drive.

i dont have another computer in the house…
the windows 7 cd is not a factory cd. its writable.
and my drive is not old

Burn the image to CD again then at slow speed. Make sure you burn it as an image, not as a file. There should be some Ubuntu instructions for this, but it’s the same for every distro. ISO images must be burnt as images, not as a file, nor even the so called “bootable CD” format of some programs like Nero.

If you have a new laptop, then it might also be possible to boot and install from a USB stick. In fact, it is very easy once you have a Linux running to issue the dd command to create such a memory stick.

Perhaps it is possible to do in Windows also, but I don’t know.

If you burned the Kubuntu CD on the same machine and you did that procedure correctly, then the problem is probably a flaw in the burning software and more likely with the media itself. This has nothing to do with the OS on the CD or any OS already installed on hard disk.