Big problem with nautilus (opensuse 11.2 - 64 bit)

In summary often don’t see the content of the folder.
Was sufficient move some file using gqview and even after many refresh the list of the file present on the folder aren’t visible.
While if use the command line (or even midnight commander) the file are exactly where they must stay.

This is the first time that i see an error so big on Nautilus. :sarcastic:

maybe you are trying to see “hidden” files (that begin with a “.”) and
have not enabled that feature in the nautilus setup? (seeing hidden
files is off, by default)


palladium

They are normal files.:\

alexopensuse wrote:
> They are normal files.:
>
>
then, use YaST to add a new user…then, log out and log back in as
that new user and give nautilus a try as the new user…

does it work right now?


palladium

Sorry right now i’m on another computer where i haven’t installed opensuse.
I will see tomorrow to take a look.

Initially I had thought to install xfe because use midnight commander isn’t really nice, but the only repository that i have find was:

home:dmitry_serpokryl:Enlightenment-cvs-core-metapackage/openSUSE_11.2

so i prefer avoid.

Maybe the user running nautilus doesn’t have read access to that directory.
Can you see the files if you start nautilus as root: sudo nautilus?

sudo nautilus won’t work…
gnomesu nautilus probably would…


palladium

The user was me, the directory was a subdirectory of my home.

However from a few minutes I turned on the computer and the problem seems gone without any intervention.

Before turning it on I thought that maybe these issues were due to installation of multimedia formats because there are a ton of software installed even for third party repository.

Well if the problem reappear again I tell you, the only thing certain is that it left me baffled. :sarcastic:

> Well if the problem reappear again I tell you

ok…good it is working again…


palladium

The probleam is reappeared. :
Some file is listed while other file aren’t listed.

http://img5.imagebanana.com/img/io6a8c5k/Schermatanautilus.png](http://img5.imagebanana.com/)

This time i have tried using gnomesu and when i’m root the file on the folder are list well.

Hi
What is the output from ls -la in the secondo directory, are they all
owned by your user, no hidden files?

Check your settings under the preview tab, I wonder if it’s the file
size?


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 2 days 23:52, 2 users, load average: 0.03, 0.06, 0.08
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

NOTE: before you do anything other than read, see the last line!

installation of multimedia formats should have no effect…but, your
first post you write “move some file using gqview”…really? can you
use a viewer to move files?? or, let me say it this way: Can you use
gqview to move files and THEN they are visible in nautilus, or not?

i can’t see any pattern to what is shown in nautilus and what is
not…but, tell me about the two different colors in the root
terminal…what is that telling you? are all the .per files
executable? what??

and, pay close attention to what Malcolm said about the setup of
nautilus…and do the same print screen again, but this time with
ls -ls instead of just ls

and, you said you didn’t like using mc, but does it show all the files
with you as a normal user?

and, do i understand you that ls in a terminal, as YOU, showed the
same four files as nautilus? (maybe you could do a screen shot with
both a root and normal user visible?)

what was it like if you add a new user (like i mentioned in my 23 Nov
posting)?

last question: you said it was all ok after a boot…i wonder if you
can think of what you might have done to change the system that might
have caused this strange behavior…(like, is this a laptop and it
worked until it woke up from a hibernate? sleep in RAM? you unplugged
the wall power…plugged in an external drive…switched from WIFI to
wired net…what?? if a desktop, maybe you attached a camera to
download some pix? or what?)

NEVER MIND, it is a known bug, see:
https://bugzilla.novell.com/show_bug.cgi?id=551701
i do NOT know if you should add another report with your specific
details…probably not, but adding a comment into that existing bug,
with your details (11.2 64, GNOME, maybe your graphic card type and
hmmmmmm?? laptop/or not…what else?)


palladium

palladium
Yes using gqview is possible even move file from one folder to another folder, you can even delete files, rename files, etc.

However this time i haven’t do this type of operation with gqview but the problem, after some times, is reappared again.

I just make some assumptions.

malcolmlewis
Yes i’m the owner of all these files.

This problem is appeared only after some use, so probably when i start the computer tommorrow will go well, and after a while will go bad, when go bad, i take screenshoot using:
ls -l
and after that i tried even to add another user.

This time i haven’t do anything on the system, i haven’t installed anything, i’m simply edited some photos using ufraw and gimp.

Format pef is only one of the ton of proprietary raw formats for photocamera. :wink:

Hi
Interesting, I have no problems with 11.2 GM 32bit (I see the bug is
for RC2)?

I wonder if it’s the thumbnail cache not being rebuilt properly.

@alexopensuse can you delete your thumbnail cache as well and see if
that helps.


rm -rf ~/.thumbnails
killall nautilus

You may also need to logout/login


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 3 days 1:43, 2 users, load average: 0.20, 0.10, 0.08
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

i guess you didn’t read all the way to the bottom of my posting–i’ll
remember that next time and be much more brief…


palladium

Seem a problem on the thumbnail cache.
First i have tried to use only:
rm -rf ~/.thumbnails
after that i refresh the folder.
The file appear.
I go on another folder and I return on the same folder and the file isn’t visible.
Then i have normally close nautilus and reopen.
Same problem.
In the end i have remove the thumbnails and kill nautilus and the problem is disappeared.

This problem is problematic because even is present don’t appear from the start but only after using a system from some time.

However this time i have noticed that the pointer of the mouse remains in the form of a sphere (like when charging) so at least I know when I experience this problem simply by looking at this particular every time I go on a folder, so i could avoid to delete a folder where there are file the aren’t visible for this big problem …:\

palladium
It’s a normal desktop.
I don’t attach my photocamera, i use a multicard reader (with it own hdd) using Usb 2.

> palladium
> It’s a normal desktop.
> I don’t attach my photocamera, i use a multicard reader (with it own
> hdd) using Usb 2.

your problem is a known bug, see:
https://bugzilla.novell.com/show_bug.cgi?id=551701


palladium

I have installed the final release while that bug is present from RC2
Severity: Major
and until now isn’t resolved.
Why? :sarcastic:

alexopensuse wrote:
> I have installed the final release while that bug is present from RC2
> Severity: Major
> and until now isn’t resolved.
> Why? :sarcastic:

maybe you have a lot of experience with Linux…or, maybe not, i do
not know…but, here are some things you might want to consider:

-Nautilus is part of (a small part of) the KDE project

-the openSUSE community does not control that project

-this community does not set work priorities for that project’s
programmers…

-both the openSUSE and KDE projects depend on a lot of volunteer
coders and helpers

-RC was released on October 29

-the final release was just 14 days later…

-today is 24 days later…

-there are many other bugs in 11.2 which are not yet resolved (and the
same can be said Vista, and XP, and OSX…though they all cost a LOT
more than you paid for 11.2)

-maybe you should ask for you money back, or how you can also help… :wink:


palladium

It’s part of Gnome.