Big Boot Problem - Fast help plox

Hello,

I’ve windows vista and I wanted to install openSUSE from my hard disk. So I started it with deamon tools and an install came up. It installed and I reboot should reboot and give a new option in the windows boot loader to start the installation. But it didn’t, I know that it works with windows xp. But with my vista it installed the bootloader before the one from vista I think. What causes the problem that the installation of openSUSE started immidiatly. But I want to enter my windows due to the fact that the installation of openSUSE didn’t worked cause I putted the iso wrong. But I can’t start my windows. Due to the fact that my it start the openSUSE local installation immidiatly.

So does someone have any idea how I can remove it so that I can load my windows vista again?

Any help is welcome!

NOTE: I’ve a live cd of ubuntu

Vista’s install cd should have a recovery option in it which will fix the boot record.
Failing this, search the forum for ‘grub vista’

WEll, the problem is that even with super grub I still get it…

Don’t panic if you’ve not been able to repair Vista right away.

If GRUB installed or used generic boot code into the MBR, then you will boot from the ‘active’ partition. So try with the Live CD, or Rescue option, and see how it’s installed.

fir:~ # fdisk -l /dev/sdb

Disk /dev/sdb: 250.0 GB, 250000000000 bytes
255 heads, 63 sectors/track, 30394 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe56c33ff

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1           7       56196   de  Dell Utility
/dev/sdb2               8        1313    10485760    7  HPFS/NTFS
/dev/sdb3   *        1313        8232    55575530    7  HPFS/NTFS
/dev/sdb4           17398       30394   104398402+   5  Extended
/dev/sdb5           17398       18162     6144831   82  Linux swap / Solaris
/dev/sdb6           18163       21986    30716248+   b  W95 FAT32
/dev/sdb7           21987       25025    24410736   83  Linux
/dev/sdb8           25026       25035       80293+  83  Linux
/dev/sdb9           25036       30394    43046136   8e  Linux LVM

There’s various repair system options, and if you just want to get back to running windows, then generic boot code, and setting the Vista partition active should suffice.

As the first responder mentioned, the Vista boot disk should be able to repair it’s boot sequence.

You may have to go through ‘activation’ depending on MS’s policy in that version of Vista (the relaxed it with SP1 I think, but it was a royal pain earlier).

That is also true, if you wish to set up GRUB, and use it to boot Linux or Windows.

Another option is to install the Easy boot manager for Vista, which is 3rd party free ware and can be found with Google, looking for ways to multi-boot Vista, XP, Linux etc.

WEll, I don’t understand the whole code you pasted here, and I don’t have vista install disk. I lost it. And I can’t install the boot manager due to the fact that it’s vista/windows software. And I can’t start my vista.

You can. Buy legitimate MS Vista media, and use that to fix.
Or restore from your Windows backup system, which you had prepared, for disaster recovery.
Or consult your PC supplier about repairing the Vista boot and getting a replacement copy of your installation media, though there’s a risk they’ll be restoring your PC to it’s original state.

Best to keep your original disks safe next time. It’s well known that Vista is fragile and that you need to have orginal media, if you’re going to make significant hardware or software changes. You have my sympathy, but you really did need to have that media and all license details, before you experimented with installing the Linux OS.

The Live CDs are there, to let you gain experience without touching your hard disk, and only using the Install when you have made the necessary preparation.

With Linux command line experience, you could definitely fix the boot sequence to launch Vista, but there’s no guarantee it won’t demand original media disk to be installed to do it’s anti-piracy checks.

Well, maybe I just install XP again. And I make a backup with the live cd of ubuntu. And I’m not a tatal linuc n00b. Because I’ve some experiënce with Ubuntu. Much easier to install.

Yes well, I tried both to evaluate.

Kubuntu 7.10 wouldn’t install on this box.

Ubuntu 7.10 did install OK on an old box, if I stripped it down, and did updates before adding back in.

The problem was, that firstly I just couldn’t stick GNOME, it is too dumbed down and restrictive, I actually prefer M$ Vista UI to GNOME.

Secondly, I just was finding too many bugs, and signs of low quality in all the Ubuntu start up scripts. This is probably due to them inheriting a humungeous heap of steaming crap from Debian, which had been thrown together with lots of “get it working changes”, but were poorly architected base on which to make large changes to boot concept like Upstart, and other product changes.

openSUSE 10.3, once it stabilised about a month after release, featured a more polished interface, had better integration with the M$ world, which is a requirement for my SO to use it. Actually one time, it was funny as she got angry with the computer, and called on me to “fix Linux”, and I discovered she’d accidentally booted into Windows and was having problems, with Internet Explorer.

The solution was to start Firefox, and have a little chuckle about her using Vista, rather than OS-10.3.

SuSE’s not perfect but if you look under the hood you find decent engineering. However I am considering using Ubuntu 8.04 LTS on a SOHO server, rather than Debian stable, simply because of the mess the Debian project appears to be in right now. I’d rather use SuSE in that spot, but the support and upgrade policies for openSUSE don’t quite suit me, and SLES/SLED I could only ‘evaluate’, and would have to subscribe. With a very stable box, doing a small set of standard highly used applications I’m just banking on other ppl having bungled through all the problems, so I won’t have to.

Centos would likely be a viable alternative, but I’ve no experience with it, having abandoned Red Hat due to their bungled 7.0 release, and changes to subscription model.

Maybe post #51 is a way out for you : Cannot boot into Vista after openSuse 11.0 Install - Page 2 - openSUSE Forums

Hope it helps,
wj