better to stay with 13.2 or upgrade to leap or tumbleweed??

on my laptop PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz, OS=opensuse 13.2 KDE= 4.14.9
I have a 3boot system, windows, opensuse13.2 for normal use, opensuse13.2 for emergency.
in these days I have time and I would like to try to upgrade one of the two 13.2 to leap42.
I red a bit around and found that there are still problems with leap42.

do you think is better to stay with 13.2 or upgrade to leap or tumbleweed??

my use of 13.2 is with KDE and mainly involve:
libreoffice,gimp, okular, the gnome pdf viewer, gwenview, inkscape,
dolphin with search and filter bar and all the KIM menues to convert files images songs and sftp and ssh and smb protocols and use of AFS filesystem
networkmanager with VPN cabled and wireless, owncloud, bluetooth, dropbox, kdewallet(but I can survive without it),
fast user switch with multiple users with different languages
firefox, chrome, chromium, rekonq, midori, epiphany, qupzilla,thunderbird, kde connect,telegram messenger,
six desktops with different wallpapers and two activities
greek italian english and russian keyboard layout,
skype, clementine, sound, smplayer, hplip,xsane, ktorrent, kwrite, luckybackup, k3b, avidemux, kmid, cheese cam viewer, krename, gparted, ksysguard, konsole, kcharselect, ark, kcalc, pdf mod, ksnapshot, efax,
kontact kaddress,ktimer, klipper,paste,kmix, knotes, krusader,
manage print jobs, beclock,
playonlinux, wine, virtualbox, q4wine

manythanks, :slight_smile: ciao :slight_smile: pier

The newest KDE (whatever it’s name) does not support different backgrounds for the different desktops you have. Making their use, well unusable imho.
There is a hefty discussion going on here: https://bugs.kde.org/show_bug.cgi?id=341143

I’ve been running LEAP a week before it officially was released (I did a live upgrade from the ftp) and I haven’t had a real issue, the 2 window bug in vlc is fixed (that was the only thing I noticed)
I did upgrade to plasma 5.5 from
http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/
TW is a different animal, it’s a rolling distribution always with the latest and greatest but has more bugs and no official video drivers for nvidia/ati if that seams appealing do try it.

I know there has been a lot of changes in plasma5 but if you use wolfi’s repo you can have both kde4 and plasma5 on your LEAP (just search the forums on how to do it)

I have Leap running on my laptop Lenovo Ideapad Z580, from the day Leap 42.1 was out. I am running it with KDE5. KDE 5.4 is little buggy and sometimes crashes (mainly KRunner). Also I have this bug: https://bugzilla.opensuse.org/show_bug.cgi?id=954146

I recommend you to stay with your current working system and upgrade to Leap when 42.2 will be out - January 2017 or so, around that time openSUSE 13.2 will end its lifetime support.
At home I am running openSUSE 13.2 with KDE4 and for now I wouldn’t gain anything upgrading to Leap 42.1.

…this is a bad news, without multiple desktop with different wallpaper, that I use strongly, I agree that it make KDE as usable as windows :slight_smile: …one point for 13.2

…good, another point for 13.2…

…without official video drivers for nvidia is difficult for me to use TW, maybe with NOUVEAU , one point against TW

…hmm, this is a good news, do you intend “have both kde4 and plasma5” on LEAP or only on TW??
so, one point for LEAP42 but with kde4,
two points for 13.2, -1 for TW :slight_smile:

manythanks to all, ciao, :slight_smile: pier

wolfy ported/tweaked plasma 5 a while ago and his repo has plasma 5 for 13.1 13.2 LEAP and TW,

if you go the standard rute you can’t have both kde4 and plasma5 on any version, for that you’d need to get kde4 from the regular oss repo and plasma5 from wolfi’s repo

under 13.2 you’d need to add the following 2 repo’s repo’s
for an updated Qt5.5
http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/
and wolfi’s with plasma5
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_13.2/
then you need to install the plasma5 patterns from wolfi’s repo and you might need to do a zypper dup with the above repo’s to get the proper packages

LEAP comes with plasma5.4 so to get both you’d need to install kde4 packages from the standard repo’s

zypper in kdebase4-session kdebase4-workspace kdebase4-runtime kdelibs4support kscreen kate4-parts konsole4-part kdm 

then add wolfi’s plasma5 for leap (no need for the extra qt5 repo as leap has it)
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.1/
and install plasma5 from wolfi’s repo, you might need to do a zypper dup with it.

For TW is basicly the same as LEAP install the kde4 packages add wolfi’s TW repo and install plasma5 from there
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Tumbleweed/

ps wolfi has the latest plasma 5.5 for LEAP 13.2

…manythanks, :slight_smile: very interesting, I’m thinking to upgrade to LEAP42 one of the 13.2 installation and then have both KDE4 and plasma5, but, I will choose kde4 or plama5 at the login like gnome or xfce?? or I’ll have kde4 and plasma5 running simultaneously??

you can chose from the logon screen, and you can use kdm or sddm on LEAP, when I last tried sddm on 13.2 it didn’t work but maybe it was fixed.

On Sun, 03 Jan 2016 18:26:01 GMT
pier andreit <pier_andreit@no-mx.forums.microfocus.com> wrote:

> I_A Wrote:
> > TW is a different animal, it’s a rolling distribution always with
> > the latest and greatest but has more bugs and no official video
> > drivers for nvidia/ati if that seams appealing do try it.
> …without official video drivers for nvidia is difficult for me to
> use TW, maybe with NOUVEAU , one point against TW

I managed to run the latest TW with just the standard nouveau driver
for nearly 24 hours without any glitches showing up. Mind you, I didn’t
have desktop effects switched on - though that hasn’t saved me from
fairly swift freezes in the past.

Had to quit a couple of times before I could run any longer because one
window of Dolphin froze in one session and then vanished in a
subsequent one. As I wanted to get some work done, I just switched back
to Old Faithful (13.2).

I also find that having to manually save a session before logging off
from TW and Leap is a real irritant.


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.3.3; Video: nVidia GeForce 210 (Driver: nouveau);
Sound: ATI SBx00 Azalia (Intel HDA)

there is a known bug with nouveau and plasma5 that still hasn’t been fixed
https://bugs.freedesktop.org/show_bug.cgi?id=92077
the workaround is to use nvidia’s propitiatory drivers the hard way, by downloading the run file from nvidia’s site and executing it in run level 3 when ever there is a kernel update which in tw’s case might be once a week, that’'s the same reason we don’t get precompiled nvidia drivers for TW, I do belive a user wrote a bash script that automates the update process but I still prefer LEAP to TW

Do you ever need to use an external monitor or projector for whatever you do?
If so, I would definitely avoid upgrading to Plasma 5 which handles this very badly: settings don’t stick, panels move around, and bugs.kde.org is full of complaints of this nature. It forced me over to GNOME 3:18 (which handles such situations really well, straight from the desktop). I find I get seg faults on a regular basis, but only on Plasma 5, not on GNOME. Some say it has to do with QT.
“if it’s not broken, don’t fix it!” an old saying in the western world. Wait.

you can have both kde4 and plasma 5.5 on both LEAP and 13.2
actually you can even get 2 flavors of good old kde3 (the vanillaor tinity)

upgraded to leap 42.1, after upgrade the old boot didnt works, it was under “my personal boot” and opensuse 13.2 (not leap)
it seems to works now, enough unusable, most of the old kde4 settings are gone, now I’m trying to install the wolfi repo following the I_A instructions :slight_smile:

LEAP comes with plasma5.4 so to get both you’d need to install kde4 packages from the standard repo’s

zypper in kdebase4-session kdebase4-workspace kdebase4-runtime kdelibs4support kscreen kate4-parts konsole4-part kdm

but I get this:

suseST-pla:/home/pla # zypper in kdebase4-session kdebase4-workspace kdebase4-runtime kdelibs4support kscreen kate4-parts konsole4-part kdm
Loading repository data...
Reading installed packages...
'kdebase4-runtime' is already installed.
No update candidate for 'kdebase4-runtime-15.08.3-3.2.x86_64'. The highest available version is already installed.
'kdelibs4support' is already installed.
No update candidate for 'kdelibs4support-5.16.0-3.6.x86_64'. The highest available version is already installed.
'kdm' is already installed.
No update candidate for 'kdm-4.11.22-1.7.x86_64'. The highest available version is already installed.
'konsole4-part' is already installed.
No update candidate for 'konsole4-part-4.14.3-1.2.x86_64'. The highest available version is already installed.
'kate4-parts' is already installed.
No update candidate for 'kate4-parts-4.14.3-2.3.x86_64'. The highest available version is already installed.
Resolving package dependencies...
3 Problems:
Problem: installed plasma5-session-5.4.3-3.1.noarch obsoletes kdebase4-session < 5.4.3 provided by kdebase4-session-4.12-7.2.noarch
Problem: powerdevil5-5.4.3-3.1.x86_64 conflicts with kdebase4-workspace < 5.3.0 provided by kdebase4-workspace-4.11.22-1.7.x86_64
Problem: installed kscreen5-5.4.3-4.2.x86_64 obsoletes kscreen < 5.4.3 provided by kscreen-1.0.71-3.6.x86_64

Problem: installed plasma5-session-5.4.3-3.1.noarch obsoletes kdebase4-session < 5.4.3 provided by kdebase4-session-4.12-7.2.noarch
 Solution 1: Following actions will be done:
  deinstallation of plasma5-session-5.4.3-3.1.noarch
  deinstallation of patterns-openSUSE-kde_plasma-20150918-12.1.x86_64
  deinstallation of patterns-openSUSE-kde_imaging-20150918-12.1.x86_64
  deinstallation of patterns-openSUSE-kde-20150918-12.1.x86_64
 Solution 2: do not install kdebase4-session-4.12-7.2.noarch

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 


…what I have to do???
manythanks :slight_smile: ciao :slight_smile: pier

try reading the comments of wolfi323 in this thread… he has his own repos for getting these both installed on the same machine running in 2 separate sessions https://forums.opensuse.org/showthread.php/502906-Plasma-5-What-to-expect

maaanythanks guys :slight_smile: :slight_smile:
added wolfi repo for leap 42.1 and switched packages on it also with 95 priority, kde4 works…:slight_smile:
but plasma5 doesn’t, if I try to install plasma5-session I have this:

#### YaST2 conflicts list - generated 2016-01-05 20:33:23 ####

nothing provides libkscreen2-plugin >= 5.5.2 needed by plasma5-session-5.5.2-140.1.noarch

     ] break plasma5-session-5.5.2-140.1.noarch by ignoring some of its dependencies

     ] do not install plasma5-session-5.5.2-140.1.noarch


is it safe to break plasma5-session???

no don’t break it I forgot another repo, as wolfi has the latest plasma you need the kde:Frameworks5 repo too, that one has that package
http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/
to add it do

zypper ar -f http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/KDE:Frameworks5.repo

I think I saw a few new posts from wolfi323 maybe he can say if I’m making an error

to get the latest plasma5.5 from wolfi and keep kde4 you need these 3 repo’s, check if you have them

http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/
http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_13.2/

Hi I_A, …I’m running LEAP 42.1, the above repositories you are writing about are for openSUSE_13.2, have I to add that one or the one for openSUSE_Leap_42.1??

ok, I added the 42.1 repos and plasma seems to start correctly :slight_smile:
added these other repos
http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/
http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.1/
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.1/
installed plasma-session from wolfi Leap_42.1 repo and accepted all vendor change for breeze from /KDE:/Frameworks5/openSUSE_Leap_42.1/

ok, plasma5 starts but now windows has no frames and titlebar and buttons and I cannot move them.
reading that there was a bug in nouveau I also installed nvidia driver but nothing change.
and if I click on system settings>desktop effects it crashes
any suggestion??

you probobly have a few packages from the oss repo (happened to me whan I was on 13.2) post your repo list

zypper lr -d

you need to do a distribution update zypper dup with the 3 repo’s posted above (and packman as wolfi has a crippled version of ffmpeg in his repo)