Beta vs. public release; updating

If one installs the beta version of Leap 15.2, will YaST provide updates after the public release of 15.2 (e.g., the so-called Gold Master; i.e., the final or stable version) such that the beta installation will effectively become one and the same as an updated public version?

Please direct me to any discussion or documentation of how this process works beyond the road map ( and the news releases (e.g.,

Usually you need reinstallation.

I agree it is better to assume that. Version 15.2. is now for testing and you are welcome to do so and report problems so the final reusult can be improved. But in the end the released version is the one that will be supported. And people here will assume that you have installed that (either fresh, or by one of the supported ways to upgrade from 15.1) from the released installation medium/repos. Doing otherwise may work without problems, but when problems arise, almost nobody else will have that situation and thus it might be more difficult to help.

I am not sure what you mean with “will YaST provide updates”. At the release moment the distribution version openSUSE 15.2 will be in it’s OSS and non-OSS repos and the Update repos of both will be empty at that moment.

Thank you both for your replies.

What I meant by “will YaST provide updates” is whether the online updater I’ve used all along with 15.1 and previous releases would update packages in the beta installation. E.g., the Linux kernel, KDE packages, etc. Perhaps not? Or, if so, not cleaning up packages and files that should be removed.

I’ve never installed a beta version, so I have no familiarity with these versions of the software.

You should use “zypper dup” to update (similar to Tumbleweed). That will give you new packages, remove old package, update existing packages and occasionally downgrade packages. It will keep your system aligned with the beta releases.

Once the final version is released:

  • Do one final “zypper dup”
  • Run the command “rpmconfigcheck” (as root) to look for an configuration files that you might need to update.

After that, you should resume using Yast or other methods (desktop updater, “zypper up”, etc) to maintain your system. No need to reinstall the released version (in my opinion), as long as you follow those steps.

nrickert, thanks for your reply.

I have had mixed results in the past with upgrading installations vs. clean installs, and therefore I’m considering 15.2 to avoid a re-installation down the road. Although I have four other machines running 15.1, it seems reasonable to try 15.2 given that it’s nearly ready for public release.

I used to always reinstall. But, starting with Leap 15.0, I have been using “zypper dup” as described above.

So Leap 15.2 was a clean install (it was at the Alpha testing stage when I installed). And I have been maintaining with “zypper dup” ever since. I do that about once per week, though I monitor the download site to see when there’s a new version.

The development process for Leap 15.x is very much based on what has been working with Tumbleweed. So, prior to the final release, I handle it much as I handle Tumbleweed. After release, I will revert to normal maintenance procedures – in my case, that’s Yast online update and “zypper up”. The “zypper up” is needed for packages from packman.

I do not quite understand that “reasonable”. As you may have understood from the advices above, the upgrading from 15.2 beta to 15.2 is in fact the same as upgrading from 15.1 to 15.2. And for that you will run an unfinished product (15.2 beta) for some time instead of mature 15.1.

It is of course your hobby and YMMV, But i would not only install 15.1 if I need that system now, I would (and will with my present 15.1 systems) wait a considarable time after 15.2 release date before I upgrade to let it settle down. And even then I will first do some testing.

But I am know as being preoccupied with stability and the less change the better. :stuck_out_tongue:

Just a note on what I am doing, for perspective.

Yes, I have 15.2 installed. But I also have 15.1 installed. My ordinary every day usage is of 15.1. But I do keep 15.2 reasonably up-to-date.

I’ll fully switch over to using 15.2 when it is released. Perhaps I’ll switch a bit sooner on my main desktop, because then I would be more thoroughly testing 15.2.

For most folk, it is best to wait. The main reason some might have for going to 15.2 right now, is that they have newer hardware that is better supported by the 15.2 kernel.

This is correct. During development, Leap snapshots are tested and released according to the same model TW uses. This ( couldn’t find the mailing list post, sorry ) was stated clearly by Ludwig Nussel ( former Leap release manager ), incl. the point that a reinstall after public release is not necessary.
FWIW: I’ve been repeating this procedure over and over again, and have not yet met any issues. What’s more:

  • I first test the ‘dup’ to the next Leap 15.2 snapshot
  • Then rollback to the btrfs snapshot that has the last 15.1 install
  • Fully update that incl. Packman ( it’s there for 15.2 now FYI )
  • I then run

sudo zypper --releasever 15.2 dup --allow-vendor-change

  • Check basic stuff after reboot, i.e. KDE Plasma desktop, kmail with an IMAP account added in 15.1, Libreoffice, Firefox.

So far, this has worked very well. No media needed, I end up with the 15.2 version of what I left behind in 15.1 and hey, that’s what we’re looking for, isn’t it?

Thank you all. I’m going to stick with 15.1 for the moment (yes, wimping out).

But I seem to have created another issue by installing 15.2 in a separate partition. Grub now shows both 15.1 and 15.2, but selecting 15.2 (any option) presents a blank screen (save for “-” in the upper left). I can access 15.1 and now wish to do the following:

  1. enable 15.2 if that doesn’t require a reinstall or a rescue (that seems to have failed also); and

  2. edit the bootloader, which appears to have been replaced by the 15.2 install, to make 15.1 the priority/default entry and remove 15.2 if that cannot be easily brought to life.

I tried booting the 15.1 rescue iso, but that too was not successful.

You should be able to boot 15.2 by entering the YaST - System - Bootloader module, simply hit OK. That will trigger a rebuild of the 15.1 GRUB entries.

Knurpht -

Well, that was easy enough - thanks. I had earlier visited the bootloader, but didn’t realize until I went into the partitioner that 15.1 could see both installations.

So I just hit “OK” in the bootloader panel and it solved the default issue.

I did view some other discussions about the blank/black screen issue (some of which include your posts), with references to earlier kernels, graphics, and the like, but nothing popped out. Selecting “e” on the 15.2 menu entry brings up a lengthy piece of code - but perhaps that’s not where I need to be.

Knurpht -

I re-read your reply. To be clear, I went into the YaST bootloader in 15.1 and selected OK there. But 15.2 still does not boot up after the “ramdisk” message following selection in grub.

There’s a possibility that this is Bug 1166664.

nrickert -

Thanks. I can only laugh (the installation doesn’t recognize crying as a valid command). And you would know, since you reported the bug. I’ll have to study the page carefully.

I believe the version I installed is 623.1, which I downloaded yesterday:

File information
Filename: openSUSE-Leap-15.2-DVD-x86_64-Build623.1-Media.iso
Path: /distribution/leap/15.2/iso/openSUSE-Leap-15.2-DVD-x86_64-Current.iso
Size: 3.9G (4195352576 bytes)
Last modified: Tue, 07 Apr 2020 12:31:46 GMT (Unix time: 1586262706)
Funny introduction to beta releases!

Yes, that would have the bug.

Probably the next release will have a fixed kernel.

If your computer has a processor with 2 cores, it is probably affected by the bug. A processor with 4 cores should be fine. At least, that’s my understanding. It affects only one of my computers, but I can still boot with an older kernel (and I can still boot Leap 15.1).

According to YaST hardware information (and confirmed by KInfocenter), the cpu is an AMD Phenom II X4 840T with 4 cores, in an HP Pavilion p7-1026b PC I inherited. In addition to some minor tasks, I use the machine for experiments like this and to try out things that might fail (or worse).

In that case, take a look at Bug 1169038 - radeon KMS driver isn’t loaded on recent Leap 15.2 kernels
That’s another kernel bug affecting 15.2, which will probably be fixed in the next release.

Thanks, that’s also interesting. The machine has an AMD RS880 (Radeon HD 4200) graphics card.

I may still play with 15.2, but I plan to install 15.1 on the target machine (a Dell laptop).