Beta 5. Network Manager problem

I’m having problems with Network Manager in Gnome. After updating to Beta 5.2, I realized that all my previous connections (wired an wireless) can’t be modified (all control boxes on dialog window are grayed). Also, I have a wired connection to a router with dhcp, but Network Manager can’t resolve hostnames. Using yast2 to configure network works however.

Is there anybody having this problem?

Please explain how you got yast to get your network working. I’m in a situation where I can’t connect to the internet and can’t update until I do.

In my case, I only configured a wired network trough yast2. Didn’t test it with a wireless network.
Just go to Network Devices -> Network Settings.
Then in Global Option check ‘Traditional Method with ifup’, this will disable Network Manager.
Then in ‘Overview’ select the nic card you want to configure and enter paramaters for your network.
In my case, I just checked Dynamic Adress because, like I said, I was connecting to a router with dhcp.
That’s all, I hope this help.

Well, it seems that Network Manager has problems with dhcp. In my case, I can see wireless networks, even connect and authenticate with them, but after that there is no name resolution.
A workaround that worked for me is to bind my wireless interface (wlan0) with a given network using Network Manager, and after that just executing this from the CLI

sudo /sbin/dhcpcd wlan0 

I’ll try this. I think I discovered how I lost internet connectivity. I did a clean install of 11.1 beta5 and it worked. When I used yast to change the hostname from what the install gave me to what it used to be, I lost the internet and it won’t come back :’(