Beta 5, KDE 4 requires root password to reboot


As the title says, why on earth does the KDE 4 reboot (in opensuse 11.1 beta 5 of course) ask me for a root password to proceed?

EDIT: Spelling mistakes

  • Karalabe wrote, On 11/14/2008 11:46 AM:
    > Hello,
    > As the title says, why on earth does the KDE 4 reboot (in opensuse
    > 11.1 beta 5 of course) ask me for a root password to proceed?

It doesn’t here. Are you using gdm instead of kdm by any chance?


What the heck is gdm and kdm? Have the default kde 4 on, and how to fix this?

Since it is a beta I didn’t want to customize too much, so I just installed it selecting the KDE 4 desktop environment and nothing else. So I’m using the one whichever comes with the default install.

The only additional thing I did, was install a video driver from nvidia, but that shouldn’t affect this (although it does have some bad side effects… but that’s for another forum topic).


In KDE4:
I didn’t have the issue with an upgrade from Beta 4.
I did have the issue with a Beta 5 clean install.

Go to “Configure Desktop” > “Advanced” tab > “Login Manager” > login as root > “Convience tab”
and then “enable autologin” and everywhere it had a User’sname, I selected my username & ticked the box, plus, I selected "enable Password-less login & my username.
Save/apply out of all that.

Worked for me;)

What caused this? Maybe desktop effects (which were turned on automatically for me)? Maybe because I also have KDE3 & other DEs too? Who knows?

Anyway, it’s now working.


Well I think it has to do with this KDE4 Beta, I am also prompted for the root password to be able to reboot. I am running 11.1 Beta 5 right now. I guess there is a lot to stuff to fix yet. None of my partitions are automounted but they do show up under my computer information so I had to manually edit the fstab file. No even my optical drives will show up. No multimedia as reported by other users and you cannot download the binary drivers from any repos at least not in the usual way. I dont care much because the 11.1 release will be in a little more than a month but just checking what works and what does not. Anyway, it is nice to see that KDE4 works really well and has solved many of the complains. I personally love KDE4 and think it will be amazing in the near future

Actually… the KDE 4 Login Manager settings arent in sync with the actual settings… [for example the selected theme is not the one used (suse)]. So basically if you open the login manager, and force an update (basically change something, change it back and apply), then it will write the actual configs to disk (and because of this enabling local reboot for everyone). After a reboot (the first will still require the password), no more passwords are needed.

All in all, the problem is, that by the default install suse does not allow local reboot/halt only for root and the KDE 4 login manager does NOT show the actual settings, but something default/else. If you apply the selected settings from the login manager (with no modifications), it will solve the reboot problem (and of course change the login theme as the wrong one is selected… … …).


mine’s an update. I’ll try and install the Beta 5 from scratch in a VMWare. In the meantime please check with to see if this is a known issue maybe.


I had the same problem when I did a fresh install of beta 5. I reinstalled beta 4 then upgraded to beta 5 and now the problem is gone.

This was on 2 different systems.

Same with beta 5 with kde 3.5.10 (clean install)

Thanks for the head up - I will try changing the settings on auto-logon.

Tried this fix using kde 3.5 but it didn’t stick but when I logged into kde 4.1 and did the change it works fine.