Best way to setup Cinnamon as the only desktop enviroment

Cinnamon seems to be the only major Desktop Environment that doesn’t have its own patter, selectable and automatically configured during the installation.

I’m trying to install Tumbleweed on a spare laptop, and I want to have Cinnamon as the only Desktop Environment there.

Since it is not present as an option, I installed the text only server environment (I did not want to install another full DE with all of his dependencies, just to remove it later), and subsequently installed the packages X11 and cinnamon.

The problem is that id doesn’t seem to work. At boot, I’m delivered to the CLI interface, and I don’t know what I should do to have cìCinnamon automatically start.

I forgot to add that i have also installed lightdm

I would leave IceWM.
However from the console you can start yast and> system> editor / etc / sysconfig> desktop> display manger> displaymanager> select> lightdm> ok
Yast is textual, so use Tab and Enter to move inside

Apart from the fact that I know nothing about Cinnamon, when you installed a text only system (if I remember correctly there is also the possibility to install a graphical system without any DE, did you not find that?), your system starts of course in non-graphical (multi-user) mode. Formerly called “runlevel 3”. Installing individual packages will not change that. Thus change your system to “runlevel 5”, now with systemd “graphical target”.

If I am correct:

systemctl set-default

or (using the newer name, but doing the same)

systemctl set-default

It doesn’t work.

Lightdm was not present as an option. I tried to insert the value manually, but I always get the CLI interface

You’ve tried installing IceWM.
From console

sudo zypper in icewm 

you really should have installed minimal X environment then pulled in cinnamon
I’m guessing you don’t have any display manager installed not even xdm
you should probobly have x installed if not install it and lightdm

zypper in xorg-x11 xorg-x11-server lightdm

then edit /etc/sysconfig/displaymanager

vim /etc/sysconfig/displaymanager

and set lightdm as the proffered displaymanager as I don’t think xdm allows for desktop environment selection
find and set DISPLAYMANAGER to


if everything goes well you should see lightdm when you reboot
you might want to add the cinnamon repo
keep in mind cinnamon is gtk3 with a lot of bells and whistles and needs a decent graphic card for smooth work

Ah yes, “Minimal X” that was what I was thinking of. A far better starting point IMHO.

You may find some value in my experiences in installing Cinnamon, related in this thread:

(with thanks to tsu2 and Miuku).

I also added the lightdm-slick-greeter with lightdm, am glad I did. Much more attractive.

Thank you, this solves the problem!

Additional comment.

The first @OP try was to install “text mode only” which is actually not so obvious mistake.

Unlike “Minimal X” or other installs with a Desktop, “Text Mode” installs a special non-graphical pattern in addition to the usual, and you cannot successfully add a Desktop without removing the packages in this special pattern. Of course this is tedious so it’s better to just avoid doing this in the first place.

Can’t remember the name of the pattern off the top of my head, but it’s a situation to know.