Belkin N750 USB Wireless ... Help please

I am a bit of a novice with Linux. I am using Opensuse 12.3, Kernel 3.7.10-1.1-default. I can not get my usb wireless device to work at all.
lsusb reveals: Bus 001 Device 003: ID 050d:1103 Belkin Components F9L1103 N750 DB 802.11abgn 2x3:3 [Ralink RT3573]

dmesg indicates the device is found:

3.068033] usb 1-3: new high-speed USB device number 3 using ehci_hcd
3.216158] usb 1-3: New USB device found, idVendor=050d, idProduct=1103
3.216163] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
3.216168] usb 1-3: Product: 802.11 n WLAN
3.216171] usb 1-3: Manufacturer: Ralink
3.216174] usb 1-3: SerialNumber: 1.0

However, no other statements regarding if firmware was loaded.

Any expert guidance would be great.

Thanks

On 04/03/2013 11:56 AM, dlmitco wrote:
>
> I am a bit of a novice with Linux. I am using Opensuse 12.3, Kernel
> 3.7.10-1.1-default. I can not get my usb wireless device to work at
> all.
> lsusb reveals: Bus 001 Device 003: ID 050d:1103 Belkin Components
> F9L1103 N750 DB 802.11abgn 2x3:3 [Ralink RT3573]
>
> dmesg indicates the device is found:
>
> 3.068033] usb 1-3: new high-speed USB device number 3 using
> ehci_hcd
> 3.216158] usb 1-3: New USB device found, idVendor=050d,
> idProduct=1103
> 3.216163] usb 1-3: New USB device strings: Mfr=1, Product=2,
> SerialNumber=3
> 3.216168] usb 1-3: Product: 802.11 n WLAN
> 3.216171] usb 1-3: Manufacturer: Ralink
> 3.216174] usb 1-3: SerialNumber: 1.0
>
> However, no other statements regarding if firmware was loaded.
>
> Any expert guidance would be great.

Two conditions must be met by any device: (1) it must be seen in a scan or the
appropriate bus, and (2) some driver must accept that device ID. Your device
fails the second condition. There is no driver built into Linux that opeerates
that device.

A quick Google search shows that an out-of-kernel Linux driver exists, but you
will need to build it on your system.

Sorry, no magic bullet.

Thank you for your assistance. I am not a programer however, I am willing to give it a shot. Is it very difficult to build the driver myself? Or would I be better off using Ndiswrapper?

On 04/04/2013 06:36 AM, dlmitco wrote:
>
> Thank you for your assistance. I am not a programer however, I am
> willing to give it a shot. Is it very difficult to build the driver
> myself? Or would I be better off using Ndiswrapper?

I never find ndiswrapper very satisfying, but it may work for you.

I have not tried to build that particular driver, thus I have no idea how much
problem it will be. As always, the first step is to install the necessary
software such as gcc, make, and the kernel headers.

I have a NetGear N900 WNDA4100 with the same RT3573 chipset. I got the latest driver from Ralink and verified that the usb id for this device is, indeed, present in the module rtusb_dev_id.c, ran “make”, “make install”, modprobe… nothing happened until I entered “ifconfig ra0 up” then the light came on. I had to manually set the “essid” to an unencrypted guest network as I use a WPA encryption and there is no way to enter the passphrase.

After reboot it was necessary to issue “ifconfig ra0 up” again to turn on the light.

I can not see the device in YAST->network devices->network settings.

Anybody have any idea what else needs doing?

iwconfig
ra0 Ralink STA ESSID:“blivit” Nickname:“RT2870STA”
Mode:Managed Frequency=2.412 GHz Access Point: 62:3F:0E:D9:44:31
Bit Rate=130 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=78/100 Signal level:-61 dBm Noise level:-61 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ifconfig
ra0 Link encap:Ethernet HWaddr 84:1B:5E:71:CF:A0
inet addr:198.105.251.68 Bcast:198.105.251.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2293 errors:0 dropped:0 overruns:0 frame:0
TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:551648 (538.7 Kb) TX bytes:4462 (4.3 Kb)

Please note that the IP ADDR is totally bogus. It looks like a pointer is pointing to a random chunk of memory.

Any help would be greatly appreciated and I will publish a complete step-by-step when this get working.

Thanks…

Rebooted and light came on… Did ifconfig ra0 up and now I see:

I included wlan0 for comparison. It is a PCI wireless card. At least now the ip address is on the right network which indicates that DHCP is working.

Why can’t YAST see it???

iwconfig
ra0 Ralink STA ESSID:“blivit” Nickname:“RT2870STA”
Mode:Managed Frequency=2.412 GHz Access Point: 62:3F:0E:09:44:31
Bit Rate=130 Mb/s
RTS thr: off Fragment thr: off
Encryption key off
Link Quality=78/100 Signal level:-63 dBm Noise level:-83 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“thor”
Mode:Managed Frequency:2.412 GHz Access Point: C0:3F:0E:09:44:30
Bit Rate=18 Mb/s Tx-Power=27 dBm
Retry long limit:7 RTS thr: off Fragment thr: off
Encryption key off
Power Management off
Link Quality=54/70 Signal level=-56 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:491 Invalid misc:1269 Missed beacon:0

ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:132 errors:0 dropped:0 overruns:0 frame:0
TX packets:132 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:15576 (15.2 Kb) TX bytes:15576 (15.2 Kb)

ra0 Link encap:Ethernet HWaddr 84:1B:5E:71:CF:A0
inet addr:192.168.0.118 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:35877 errors:0 dropped:0 overruns:0 frame:0
TX packets:2192 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8546525 (8.1 Mb) TX bytes:208390 (203.5 Kb)

wlan0 Link encap:Ethernet HWaddr 00:0D:88:8B:9B:B4
inet addr:192.168.0.103 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1491252 errors:0 dropped:0 overruns:0 frame:0
TX packets:1743426 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:626312150 (597.2 Mb) TX bytes:183535225 (175.0 Mb)

I assume you already have the firmware installed?

software.opensuse.org:

A udev rule edit should sort this. Read this thread:

http://forums.opensuse.org/english/get-technical-help-here/wireless/490288-problems-encountered-using-yast-configure-wireless-interface-using-rt2800pci-driver.html#post2584148

Firmware is in.

Does udev rule change require a reboot? I do have a “wlan0” Atheros pci wireless card. I tried setting the “ra*” to wlan0 and to wlan1 but it likes to be ra0. Also, nothing makes it visible to YAST.

On a positive note, it is working but I have to use an unencrypted router interface. YAST would be nice…

Any progress is good progress, I guess.

Thanks, Deano. Any more ideas, YAST-wise?

Can we see the rule(s) you have in /etc/udev/rules.d/70-persistent-net.rules?

cat /etc/udev/rules.d/70-persistent-net.rules

Obviously, you can’t assign the same name given to another device. It won’t get rid of the kernel device node either, but should provide an additional name (symbolic link) for the device which YaST can then work with.

Does udev rule change require a reboot?

For a PCI device you could either reboot, or do the following as root

udevadm control --reload

You might want to check the staus of your devices with the ‘rfkill’ utility

rfkill list

If blocked, issue something like

rfkill unblock wifi

or the numeric number of device as reported by rfkill.

The device is a usb wifi adapter. Does this change the udev entry?

SUBSYSTEM==“net”, ACTION==“add”, DRIVERS=="?", ATTR{address}==“00:0d:88:8b:9b:b4”, ATTR{dev_id}==“0x0”, ATTR{type}==“1”, KERNEL=="wlan", NAME=“wlan0”
SUBSYSTEM==“net”, ACTION==“add”, DRIVERS=="?", ATTR{address}==“84:1B:5E:71:CF:A0”, ATTR{dev_id}==“0x0”, ATTR{type}==“1”, KERNEL=="ra", NAME=“ra0”
SUBSYSTEM==“net”, ACTION==“add”, DRIVERS=="?", ATTR{address}==“b8:97:5a:3b:9c:5f”, ATTR{dev_id}==“0x0”, ATTR{type}==“1”, KERNEL=="eth", NAME=“eth0”

I was wondering about the “ATTR” entries.

The above rules apply to your 2 wireless devices and your ethernet device.

Did you try editing this rule?

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",  ATTR{address}=="84:1B:5E:71:CF:A0", ATTR{dev_id}=="0x0",  ATTR{type}=="1", KERNEL=="ra*", NAME="ra0"

to

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",  ATTR{address}=="84:1B:5E:71:CF:A0", ATTR{dev_id}=="0x0",  ATTR{type}=="1", KERNEL=="ra*", NAME="wlan1"

Disconnect and reconnect the USB wireless device. Then ‘wlan1’ should be present.

FYI

ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9696 (9.4 Kb) TX bytes:9696 (9.4 Kb)

ra0 Link encap:Ethernet HWaddr 84:1B:5E:71:CF:A0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:26 errors:0 dropped:0 overruns:0 frame:0
TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6292 (6.1 Kb) TX bytes:4160 (4.0 Kb)

wlan0 Link encap:Ethernet HWaddr 00:0D:88:8B:9B:B4
inet addr:192.168.0.103 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:11757 errors:0 dropped:0 overruns:0 frame:0
TX packets:10812 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10932708 (10.4 Mb) TX bytes:2432292 (2.3 Mb)

ZEUS:~ # iwconfig
ra0 Ralink STA ESSID:“blivit” Nickname:“RT2870STA”
Mode:Auto Frequency=2.412 GHz Access Point: Invalid
Bit Rate=1 Mb/s
RTS thr off Fragment thr off
Encryption key off
Link Quality=10/100 Signal level:0 dBm Noise level:0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“thor”
Mode:Managed Frequency:2.412 GHz Access Point: C0:3F:0E:09:44:30
Bit Rate=54 Mb/s Tx-Power=27 dBm
Retry long limit:7 RTS thr off Fragment thr off
Encryption key off
Power Management off
Link Quality=48/70 Signal level=-62 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:11 Missed beacon:0

Starting over - you mention that you have tried to configure via yast network settings. You mentioned the Ralink device wasn’t detected, but did you try adding the new wireless device manually there? (I use network manager instead, as I connect to various wireless and wired networks, so easier to manage.) Do you have the ‘wpa_supplicant’ package installed?

I edited the file “/etc/sysconfig/network/config” and added “|ra[0-9]” to LINKLOCAL_INTERFACES. Then I copies “ifcfg-wlan0” to “ifcfg-ra0” and edited the NAME to “NetGear… etc”.

Yast can now see it and it shows up in iwconfig and ifconfig. I have to play around but I will start fresh and figure it out. I seem to do “ifconfig ra0 up” to get it to connect to the router and get an ip address.

Problem is, it crashes the box with a PANIC. i have no idea where to begin debugging… but ignorance has never stopped me.

Right now, I do not have the dongle connected. I will do so after I send this in case of a PANIC. The pertinent info thus far is:

ZEUS:~ # cat /etc/udev/rules.d/70-per* (the “ra” entry does not seem to be persistent. Curious.)

PCI device 0x10ec:0x8168 (r8169)

PCI device 0x168c:0x0013 (ath5k)

PCI device 0x168c:0x0013 (ath5k)

SUBSYSTEM==“net”, ACTION==“add”, DRIVERS=="?", ATTR{address}==“00:0d:88:8b:9b:b4”, ATTR{dev_id}==“0x0”, ATTR{type}==“1”, KERNEL=="wlan", NAME=“wlan0”
SUBSYSTEM==“net”, ACTION==“add”, DRIVERS=="?", ATTR{address}==“b8:97:5a:3b:9c:5f”, ATTR{dev_id}==“0x0”, ATTR{type}==“1”, KERNEL=="eth", NAME=“eth0”
ZEUS:~ # iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“thor”
Mode:Managed Frequency:2.412 GHz Access Point: C0:3F:0E:09:44:30
Bit Rate=18 Mb/s Tx-Power=27 dBm
Retry long limit:7 RTS thr off Fragment thr off
Encryption key off
Power Management off
Link Quality=52/70 Signal level=-58 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:220 Invalid misc:7689 Missed beacon:0

ZEUS:~ # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:99 errors:0 dropped:0 overruns:0 frame:0
TX packets:99 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:10124 (9.8 Kb) TX bytes:10124 (9.8 Kb)

wlan0 Link encap:Ethernet HWaddr 00:0D:88:8B:9B:B4
inet addr:192.168.0.103 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:322122 errors:0 dropped:0 overruns:0 frame:0
TX packets:311145 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:249803535 (238.2 Mb) TX bytes:31947266 (30.4 Mb)

ZEUS:~ # cat /etc/sysconfig/network/ifcfg-ra0
BOOTPROTO=‘dhcp’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=’’
MTU=’’
NAME=‘NetGear WNDA4100 N900’
NETMASK=’’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
USERCONTROL=‘no’
WIRELESS_AP=’’
WIRELESS_AP_SCANMODE=‘1’
WIRELESS_AUTH_MODE=‘psk’
WIRELESS_BITRATE=‘auto’
WIRELESS_CA_CERT=’’
WIRELESS_CHANNEL=’’
WIRELESS_CLIENT_CERT=’’
WIRELESS_CLIENT_KEY=’’
WIRELESS_CLIENT_KEY_PASSWORD=’’
WIRELESS_DEFAULT_KEY=‘0’
WIRELESS_EAP_AUTH=’’
WIRELESS_EAP_MODE=’’
WIRELESS_ESSID=‘thor’
WIRELESS_FREQUENCY=’’
WIRELESS_KEY=’’
WIRELESS_KEY_0=’’
WIRELESS_KEY_1=’’
WIRELESS_KEY_2=’’
WIRELESS_KEY_3=’’
WIRELESS_KEY_LENGTH=‘128’
WIRELESS_MODE=‘Managed’
WIRELESS_NICK=’’
WIRELESS_NWID=’’
WIRELESS_PEAP_VERSION=’’
WIRELESS_POWER=‘no’
WIRELESS_WPA_ANONID=’’
WIRELESS_WPA_IDENTITY=’’
WIRELESS_WPA_PASSWORD=’’
WIRELESS_WPA_PSK=‘698 prescott rd’

On 09/27/2013 11:36 AM, divinsal wrote:
>
> deano_ferrari;2587948 Wrote:
>> Starting over - you mention that you have tried to configure via yast
>> network settings. You mentioned the Ralink device wasn’t detected, but
>> did you try adding the new wireless device manually there? (I use
>> network manager instead, as I connect to various wireless and wired
>> networks, so easier to manage.) Do you have the ‘wpa_supplicant’ package
>> installed?
>
> I edited the file “/etc/sysconfig/network/config” and added “|ra[0-9]”
> to LINKLOCAL_INTERFACES. Then I copies “ifcfg-wlan0” to “ifcfg-ra0” and
> edited the NAME to “NetGear… etc”.
>
> Yast can now see it and it shows up in iwconfig and ifconfig. I have to
> play around but I will start fresh and figure it out. I seem to do
> “ifconfig ra0 up” to get it to connect to the router and get an ip
> address.
>
> Problem is, it crashes the box with a PANIC. i have no idea where to
> begin debugging… but ignorance has never stopped me.
>
> Right now, I do not have the dongle connected. I will do so after I
> send this in case of a PANIC. The pertinent info thus far is:

The easiest way to debug kernel panics is to have the CTRL-ALT-F10 debugging
console on the screen when the panic occurs. Take as good a picture of the
screen as you can, post that picture at paste.opensuse.org, and report the link
here. If plugging in the dongle is all it takes, switch to the screen first. If
it takes some command to cause the panic, then use the sequence ‘sleep 10 &&
<command that does it>’. That will allow you 10 seconds to switch to the
debugging console. The only problem is that you cannot enter any other
information such as a password.

I am going to start fresh. I will remove the PCI card and go back to square one and record every keystroke and result. Thanks for all of your help and patience. I’ll let ya know…

Download - 20120911_RT3573_Linux_STA_v2.5.0.0_Rev1_DPO
Edit os/linux/config.mk → HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
Edit /etc/sysconfig/network/config -
LINKLOCAL_INTERFACES=“eth*[0-9]|tr*[0-9]|wlan[0-9]|ath[0-9]|ra[0-9]” (add “|ra[0-9])
install ralink-firmware
tweaked RT2870STA.dat to reflect correct access essid
make clean
make
make install
modprobe rt3573sta
create /etc/sysconfig/network/ifcfg-ra0 as follows:
BOOTPROTO=‘dhcp’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=’’
MTU=’’
NAME=‘NetGear WNDA4100 N900’
NETMASK=’’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
USERCONTROL=‘no’
WIRELESS_AP=’’
WIRELESS_AP_SCANMODE=‘1’
WIRELESS_AUTH_MODE=‘no-encryption’
WIRELESS_BITRATE=‘auto’
WIRELESS_CA_CERT=’’
WIRELESS_CHANNEL=’’
WIRELESS_CLIENT_CERT=’’
WIRELESS_CLIENT_KEY=’’
WIRELESS_CLIENT_KEY_PASSWORD=’’
WIRELESS_DEFAULT_KEY=‘0’
WIRELESS_EAP_AUTH=’’
WIRELESS_EAP_MODE=’’
WIRELESS_ESSID=‘blivit’ <— ESSID
WIRELESS_FREQUENCY=’’
WIRELESS_KEY=’’
WIRELESS_KEY_0=’’
WIRELESS_KEY_1=’’
WIRELESS_KEY_2=’’
WIRELESS_KEY_3=’’
WIRELESS_KEY_LENGTH=‘128’
WIRELESS_MODE=‘Managed’
WIRELESS_NICK=’’
WIRELESS_NWID=’’
WIRELESS_PEAP_VERSION=’’
WIRELESS_POWER=‘no’
WIRELESS_WPA_ANONID=’’
WIRELESS_WPA_IDENTITY=’’
WIRELESS_WPA_PASSWORD=’’
WIRELESS_WPA_PSK=’’

verify that the device interface is in YAST
plug in dongle (NetGear WNDA4100 N900) – lights on

ZEUS:/etc/sysconfig/network # iwconfig
ra0 Ralink STA ESSID:“blivit” Nickname:“RT2870STA”
Mode:Managed Frequency=2.412 GHz Access Point: 62:3F:0E:D9:44:31
Bit Rate=130 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=88/100 Signal level:-61 dBm Noise level:-61 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

lo no wireless extensions.

ZEUS:/etc/sysconfig/network # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:112 errors:0 dropped:0 overruns:0 frame:0
TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:13608 (13.2 Kb) TX bytes:13608 (13.2 Kb)

ra0 Link encap:Ethernet HWaddr 84:1B:5E:71:CF:A0
inet addr:192.168.0.113 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:302 errors:0 dropped:0 overruns:0 frame:0
TX packets:71 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:71391 (69.7 Kb) TX bytes:9284 (9.0 Kb)

Yast -Network Devices->Network Settings->select ra0->Hardware has no Module name.

ZEUS:/etc/sysconfig/network # ping 192.168.0.1 – PING router
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=7.88 ms
64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=3.82 ms
64 bytes from 192.168.0.1: icmp_seq=3 ttl=64 time=5.47 ms
^C
— 192.168.0.1 ping statistics —
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 3.822/5.727/7.886/1.670 ms
ZEUS:/etc/sysconfig/network # ping 192.168.0.101 – ping address on lan
PING 192.168.0.101 (192.168.0.101) 56(84) bytes of data.
64 bytes from 192.168.0.101: icmp_seq=1 ttl=64 time=26.2 ms
64 bytes from 192.168.0.101: icmp_seq=2 ttl=64 time=3.10 ms
64 bytes from 192.168.0.101: icmp_seq=3 ttl=64 time=4.60 ms
^C
— 192.168.0.101 ping statistics —
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 3.105/11.305/26.204/10.552 ms

PANIC

That’s enough for today. I can get it to ping the router and another box on the LAN.
There is/was no need to edit udev rules. I think we are getting close.
I need a beer.
Any suggestions?

On 09/27/2013 03:46 PM, divinsal wrote:
>
> Download - 20120911_RT3573_Linux_STA_v2.5.0.0_Rev1_DPO
> Edit os/linux/config.mk → HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
> Edit /etc/sysconfig/network/config -
>
> LINKLOCAL_INTERFACES=“eth*[0-9]|tr*[0-9]|wlan[0-9]|ath[0-9]|ra[0-9]”
> (add “|ra[0-9])
> install ralink-firmware
> tweaked RT2870STA.dat to reflect correct access essid
> make clean
> make
> make install
> modprobe rt3573sta
> create /etc/sysconfig/network/ifcfg-ra0 as follows:
> BOOTPROTO=‘dhcp’
> BROADCAST=’’
> ETHTOOL_OPTIONS=’’
> IPADDR=’’
> MTU=’’
> NAME=‘NetGear WNDA4100 N900’
> NETMASK=’’
> NETWORK=’’
> REMOTE_IPADDR=’’
> STARTMODE=‘auto’
> USERCONTROL=‘no’
> WIRELESS_AP=’’
> WIRELESS_AP_SCANMODE=‘1’
> WIRELESS_AUTH_MODE=‘no-encryption’
> WIRELESS_BITRATE=‘auto’
> WIRELESS_CA_CERT=’’
> WIRELESS_CHANNEL=’’
> WIRELESS_CLIENT_CERT=’’
> WIRELESS_CLIENT_KEY=’’
> WIRELESS_CLIENT_KEY_PASSWORD=’’
> WIRELESS_DEFAULT_KEY=‘0’
> WIRELESS_EAP_AUTH=’’
> WIRELESS_EAP_MODE=’’
> WIRELESS_ESSID=‘blivit’ <— ESSID
> WIRELESS_FREQUENCY=’’
> WIRELESS_KEY=’’
> WIRELESS_KEY_0=’’
> WIRELESS_KEY_1=’’
> WIRELESS_KEY_2=’’
> WIRELESS_KEY_3=’’
> WIRELESS_KEY_LENGTH=‘128’
> WIRELESS_MODE=‘Managed’
> WIRELESS_NICK=’’
> WIRELESS_NWID=’’
> WIRELESS_PEAP_VERSION=’’
> WIRELESS_POWER=‘no’
> WIRELESS_WPA_ANONID=’’
> WIRELESS_WPA_IDENTITY=’’
> WIRELESS_WPA_PASSWORD=’’
> WIRELESS_WPA_PSK=’’
> -----------------------------------------------------------------------------------------
> verify that the device interface is in YAST
> plug in dongle (NetGear WNDA4100 N900) – lights on
>
> ZEUS:/etc/sysconfig/network # iwconfig
> ra0 Ralink STA ESSID:“blivit” Nickname:“RT2870STA”
> Mode:Managed Frequency=2.412 GHz Access Point:
> 62:3F:0E:D9:44:31
> Bit Rate=130 Mb/s
> RTS thr:off Fragment thr:off
> Encryption key:off
> Link Quality=88/100 Signal level:-61 dBm Noise level:-61 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>
> eth0 no wireless extensions.
>
> lo no wireless extensions.
>
>
> ZEUS:/etc/sysconfig/network # ifconfig
> lo Link encap:Local Loopback
> inet addr:127.0.0.1 Mask:255.0.0.0
> UP LOOPBACK RUNNING MTU:65536 Metric:1
> RX packets:112 errors:0 dropped:0 overruns:0 frame:0
> TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:0
> RX bytes:13608 (13.2 Kb) TX bytes:13608 (13.2 Kb)
>
> ra0 Link encap:Ethernet HWaddr 84:1B:5E:71:CF:A0
> inet addr:192.168.0.113 Bcast:192.168.0.255
> Mask:255.255.255.0
> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> RX packets:302 errors:0 dropped:0 overruns:0 frame:0
> TX packets:71 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:1000
> RX bytes:71391 (69.7 Kb) TX bytes:9284 (9.0 Kb)
>
>
> Yast -Network Devices->Network Settings->select ra0->Hardware has no
> Module name.
>
> ZEUS:/etc/sysconfig/network # ping 192.168.0.1 – PING router
> PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
> 64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=7.88 ms
> 64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=3.82 ms
> 64 bytes from 192.168.0.1: icmp_seq=3 ttl=64 time=5.47 ms
> ^C
> — 192.168.0.1 ping statistics —
> 3 packets transmitted, 3 received, 0% packet loss, time 2003ms
> rtt min/avg/max/mdev = 3.822/5.727/7.886/1.670 ms
> ZEUS:/etc/sysconfig/network # ping 192.168.0.101 – ping address on lan
> PING 192.168.0.101 (192.168.0.101) 56(84) bytes of data.
> 64 bytes from 192.168.0.101: icmp_seq=1 ttl=64 time=26.2 ms
> 64 bytes from 192.168.0.101: icmp_seq=2 ttl=64 time=3.10 ms
> 64 bytes from 192.168.0.101: icmp_seq=3 ttl=64 time=4.60 ms
> ^C
> — 192.168.0.101 ping statistics —
> 3 packets transmitted, 3 received, 0% packet loss, time 2002ms
> rtt min/avg/max/mdev = 3.105/11.305/26.204/10.552 ms
>
> PANIC
>
> That’s enough for today. I can get it to ping the router and another
> box on the LAN.
> There is/was no need to edit udev rules. I think we are getting close.
> I need a beer.
> Any suggestions?

I did not realize you are using an out-of-kernel driver.

Save yourself a lot of grief and get the backports of compat-wireless package
for your kernel. That will get the latest version of the driver for your device,
AND it will not panic. Otherwise, enable the openSUSE kernel of the day repo,
and get a 3.11 or 3.12 kernel. It will have the latest drivers.

The Ralink RT3573 chipset is very new. I can find no anointed drivers hence, this exercise. wireless.kernel.org has pointers to the MediaTek site where I got the driver source. I may have to install another distro on one of my “spare” machines and see what happens. Oh, well.

Part of the problems seems to be the openSuSE method of installing (wireless) drivers. The package from Ralink assumes certain configuration/install standards that other (Ubuntu???) distros may comply. The changes I had to make to /sysconfig/network/Ifcfg-ra0 are not referenced in any post that I have seen either here or on other forums. I can not help but feel that the answer is in some arcane config file somewhere deep in the bowels of the system. Oh, well. Hey, it keeps me out of the bars, right?

The system panics in the kernel module ./net/core/skbuff.c:127. I do not believe that the back trace got me as far back as the driver.

Anyone intersted in getting this working in openSuSE 12.3, feel free to join me.