Belkin FD7050a usb not playing nice


I’m trying to get my Belkin FD7050a to work with my OS 11.1 desktop. I’ve installed what I believe is the right driver and firmware for the chipset, but still can’t see the access point.

So far I’ve installed the ralink rt73 driver and firmware (packages rt73-cvs-kmp-default and ralink-firmware from Akoellh’s OBS repository).

Following a partial solution for this adapter under Ubuntu that I found here, I’ve also added the following lines to /etc/modprobe.d/blacklist:

blacklist rt73usb
blacklist rt2570

Running iwconfig as root gives me the following:

lo        no wireless extensions.  

wlan0     RT73 WLAN  ESSID:""
          Mode:Managed  Frequency=2.412 GHz  Bit Rate:54 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=0/100  Signal level:-121 dBm  Noise level:-111 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

Relevant output of dmesg that I could find:

usb 2-1: New USB device found, idVendor=050d, idProduct=705a
usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-1: Product: Belkin 54g USB Network Adapter
usb 2-1: Manufacturer: Belkin


phy0 -> rt2500usb_init_eeprom: Error - Invalid RT chipset detected.
phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
usbcore: registered new interface driver rt2500usb
rt73: init
rt73: idVendor = 0x50d, idProduct = 0x705a 
firmware: requesting rt73.bin


rt73: using permanent MAC addr
rt73: Active MAC addr: 00:22:75:af:e8:42
rt73: Local MAC = 00:22:75:af:e8:42
usbcore: registered new interface driver rt73

Relevant output of lsusb:

mylogin@linux-myhost:/etc> /usr/bin/lsusb
Bus 001 Device 002: ID 050d:705a Belkin Components F5D7050A Wireless Adapter

So far I’d assumed that this means that the driver is working, but the adapter needs configuring (could well be wrong). Unfortunately I haven’t had any luck with either NetworkManager of Yast. The guide I found for Ubuntu suggested appending the following data to /etc/network/interfaces :

# rt73 wireless network device using DHCP
iface rausb0 inet dhcp
pre-up ifconfig rausb0 up
wireless-essid MY_ESSID
# wireless-key XXXXXXXXXXXXXXXXXXXXXXXXXX       # This line for hexidecimal keys
# wireless-key s:XXXXXXXXXXXXX                  # This line for ASCII (string) keys
auto rausb0

but I don’t know enough about OpenSuse’s configuration to adapt this to OpenSuse.

Do I have a driver issue, or is it just a matter of configuring the adapter properly? Could someone set me on the right path?

The legacy driver rt73-cvs should be the last resort.

I am pretty sure it will not be needed, so remove it!

Keep firmware and change blacklist entries to

blacklist rt2500usb

Then reboot and configure the device via NetworkManager or ifup/YaST no mixing of both methods.

Did that (configured using yast), and there is progress! Still no wireless though…

Output of iwconfig is encouraging:

lo        no wireless extensions.  

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"BTVOYAGER2110-C6"
          Mode:Managed  Frequency:2.427 GHz  Access Point: 00:11:F5:EA:D5:C6
          Bit Rate=54 Mb/s   Tx-Power=18 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:5555-5555-5555-5555-5555-5555-55   Security mode:open
          Power Management:off
          Link Quality=76/100  Signal level:-24 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

as is iwlist scan output:

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:11:F5:EA:D5:C6
                    Frequency:2.427 GHz (Channel 4)
                    Quality=56/100  Signal level:-20 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra: Last beacon: 24ms ago

This, however, is less encouraging:

mylogin@myhost:~> ping -c5
PING ( 56(84) bytes of data.
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable
From icmp_seq=4 Destination Host Unreachable
From icmp_seq=5 Destination Host Unreachable

--- ping statistics ---
5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 4003ms
, pipe 3

everything I could find from dmesg, in case it helps:

usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: New USB device found, idVendor=050d, idProduct=705a
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-1: Product: Belkin 54g USB Network Adapter
usb 1-1: Manufacturer: Belkin


phy0: Selected rate control algorithm 'pid'
Registered led device: rt73usb-phy0::radio
Registered led device: rt73usb-phy0::assoc
Registered led device: rt73usb-phy0::quality
usbcore: registered new interface driver rt73usb


eth0: no link during initialization.
ADDRCONF(NETDEV_UP): eth0: link is not ready
NET: Registered protocol family 17
firmware: requesting rt73.bin
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: authenticate with AP 00:11:f5:ea:d5:c6
wlan0: authenticated
wlan0: associate with AP 00:11:f5:ea:d5:c6
wlan0: RX AssocResp from 00:11:f5:ea:d5:c6 (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
bootsplash: status on console 0 changed to on

Where to go from here?

Edit: thought I’d better clarify that all these were after unplugging the ethernet cable and rebooting.

So your IP/DNS/routing setup is faulty.

The wireless part is working fine (as expected).

Read the sitckies in the wireless subforum, especially the post mentioning the diagnostic script and use that one.

You will get instructions on how to fix common errors.

Try to fix them and report back after trying them with the full output of the script run directly after you made the last changes.

Due to this thread here:

Network disconnects after minute Dell Dimension 8200 - openSUSE Forums

I have decided to play things a little different from now on, I just want to inform you.

I will only answer if

a) I get the impression, the person asking for help did her/his homework

b) The person asking for help gives useful information she/he was asked for

c) the person asking for help did a) and b) and unfortunately I have to tell them I don’t have an idea

d) the problem is extremely interesting because it is new


e) looks like a bug to me

Possibility d) can be excluded here.

If I don’t answer, then because I don’t think the person asking for help did a) and b).

Does not harm any person asking and saves me certainly a lot of time.

Thanks for your time on this.

Ran the script; apparently wlan0 can’t find the dhcp server.

I tried pinging the router as it suggested - no response. (Definitely got the right IP for the router - I double-checked with a tracert on another machine using the wireless). Running dhcpcd-test wlan0 similarly got no response. It also suggested I disable IPv6, which I’ve done.

Other machines are connected to the router via wireless, so the router’s definitely ok.

I ran the script again after disabling IPv6 and rebooting. I’ve pasted the full output here.

I’m rather out of my depth here.

But as a last hint:

mylogin@myhost:~> ping -c5
PING **** ( 56(84) bytes of data.
From ****: icmp_seq=2 Destination Host Unreachable

You should inform yourself about the meaning of subnets and network masks.

Sorry, but I’m not sure what you were asking for now. The only things the script suggested were pinging the router, running dhcpcp-test wlan0 and disabling IPv6. I pasted the full output of the script in the linked url. What was it that you wanted me to post?