Behaviour of different browsers

Hello!

I am a bit dedicated to Konqueror and preferably with KHTML as Webkit lacks some features I like to have available. Due to some limitations with Konqueror, with KHTML in particular, I also use Opera when Konqueror does not suffice, mainly with web-TV and sites which uses special plug-ins not available for it. However, on this site, the openSUSE.org, it seems like Opera resembles more KHTML than Webkit, meaning limitations or flaws with the browsing experience. Both with layout and with links it seems to struggle in some cases; the texts is sometimes labelled above the buttons making it difficult to navigate further, but most notably with the package search feature where I am unable to get past the ‘Show unstable packages’ (search revealing OBS packages). This behaviour is the same with KHTML, but when switching to Webkit one can navigate further viewing the packages available corresponding to your search.

This is not a big issue but would like to hear some views on it as I don’t understand what stops Opera and Konqueror with KHTML from following that link.

Cheers,
Olav

I don’t use opera enough to comment on that. I mainly use firefox and konqueror, though I do have opera and chromium installed.

I have experimented with konqueror using khtml, and some sites did not like it. With webkit, most sites work, though often firefox works better.

There are many sites that support only firefox, IE, safari and chrome. Anything else and it might work, or maybe not. Apparently konqueror with webkit resembles safari well enough that it usually gets by. With khtml, it doesn’t do so well.

It is my understanding that khtml is being phased out. Apparently there are a few features from khtml that need to be merged into webkit, and when that is done, khtml might disappear, or so I have heard.

My experience of Konqueror with WebKit is that it has made significant improvements and now, for example, supports all the HTML5 video codecs.

The only recent problem I have encountered is that clicking on an HTML, and sometimes a PDF, link within Konqueror does not reliably produce a result but in both cases right clicking and selecting New Tab or Okular works perfectly.

Also I have recently been doing some development with Konqueror and found that it is much more forgiving of HTML syntax errors than chromium; so if you are likely to use older or less well maintained sites, you may find Konqueror more useful.

What version of Opera are you using? From a bit of reading on the Opera Forum, I’ve gotten the impression that versions later than 11.62 or so are less than highly regarded. I’m using Opera 11.62 now, and things seem to work fairly well for me.

I am using Opera 12.11 from the official repo (update), I’ll take a note of that.

One thing I have noticed when switching between the two engines is that the HTML-settings (Tools > HTML settings >…) changes, and under Webkit only ‘Cookies’ and ‘Enable Cache’ is enabled; while by default (KHTML on my system) ‘Javascript’, ‘Plugins’ and ‘Auto-load Images’ is enabled in addition. Moreover it seems to reset itself from session to session, i.e. the alteration I do is not stored.

The one feature I miss the most with Webkit is the spell checking, not being a native speaker of English (in this case) I like to have it available.

Thanks:)

I’m guessing here but Javascript is now so much part of HTML5 that there may be an assumption it will always be available. There was a time when Konqueror WebKit repeatedly crashed when it encountered heavily Javascripted sites; it no longer does that - I was on one this morning and Konqueror WebKit behaved flawlessly. Not sure about the other options but my recent - as opposed to my earlier - experience has been that nothing seems to cause problems for Konqueror WebKit any longer.

Interesting.

I am using webkit. And Javascript, Plugins, Auto-load Images are all enabled. I don’t recall having manually enabled those, though I did tweak a few other settings.

I notice that spell checking can be turned on. So I have just done that. I don’t yet know whether that works.

Another thought on this.

I normally start konqueror by going to the application menu –> internet –> browsers –> konqueror

If I instead start it with the icon on the panel, then it seems to start in file-manager mode, and lots of browsing stuff doesn’t work right.

I notice that spell checking can be turned on. So I have just done that. I don’t yet know whether that works.

I don’t think it will work. At least, I did not manage to enable it. I could only find relevant config here (but I might be wrong): Settings > Configure Spell Checking > …

While we’re at it, one thing I’ve been curious about is what the difference between Java and/or Javascript enabled is?

Does it change the way it behaves (enters browser mode (+?)) if you navigate further on to the web? I think mine start in the same mode either way but I added the panel launcher by dragging the menu icon on to the panel so that should, I suppose, make sense:)
Btw, I start with the ‘Introduction page’.

When you mention this I came to think of how I had to set Konqueror as my default browser. In System Settings > Default applications > Web Browser I have to type in ‘konqueror’, if I instead choose the ‘kfmclient openProfile webbrowsing’ (the menu command) following links (KMail ,Konversation etc) will end up in cache, not online. This was a tip I got on the forum regarding an older version of OS, however I believe to remember having seen it on 12.2 as well before setting the ‘konqueror’ command.

Strange.

I mainly use firefox, and am typing this with firefox. But I use akregator, which integrates well with konqueror.

I tried setting the default browser to konqueror with:
Configure Desktop –> Default applications –> Web Browser.
There, I selected the box “in the following browser” and then clicked the button right at the end of the entry field. That allowed me to search the menu for konqueror. I think that entered “konqueror” in the entry field.

It worked very poorly. Whenever I tried to open an akregator message in the browser, it started a new instance of konqueror instead of opening in a tab of the already running konqueror.

So I switched that setting to the box “in an application based on the content of the URL”. And that worked much better.

I won’t be testing the spell checker till I try commenting on a blog that I am reading with akregator.

Thank you for testing!

I tried setting the default browser to konqueror with:
Configure Desktop –> Default applications –> Web Browser.
There, I selected the box “in the following browser” and then clicked the button right at the end of the entry field. That allowed me to search the menu for konqueror. I think that entered “konqueror” in the entry field.

I think you will end up with ‘konqbrowser’ not ‘konqueror’, didn’t it say so in the text field? At least that is what I get.

It worked very poorly. Whenever I tried to open an akregator message in the browser, it started a new instance of konqueror instead of opening in a tab of the already running konqueror.

Perhaps you can change this here: Settings > Configure Konqueror > General > New instances: ‘tab or window’. But using Firefox I suppose this isn’t of too much concern.

So I switched that setting to the box “in an application based on the content of the URL”. And that worked much better.

Shouldn’t this open the link with Firefox (default browser)?

But in regard what you mentioned earlier (post 8) I would guess that ‘konqbrowser’ open Konqueror in the web-browser mode. Why it then caches the page and displays it from cache when following links, as mention earlier, is beyond me. But entering ‘konqueror’ in the field under System Settings > Default applications > Web Browser > ‘in the following browser’ works very well.

Cheers:)

You might be right. But I think that is just konqueror with its browser mode profile.

I already had that set. And I already had akregator set to browse in a new tab. But it still opened a new konqueror window.

I start firefox from the command line (actually, using my own script that does some cookie cleanup first). So setting the default browser to konqueror doesn’t interfere with my normal use of firefox.

It would if firefox were configured as the default browser.

I experimented with that this morning. That setting is fine for starting konqueror. But then akregator starts a new instance of konqueror for opening a message in the browser, instead of using a tab in the existing browser.

Perhaps that’s related to the akregator setting to share cache with the browser, but that is listed as a recommended setting.

I’m back to “in an application based on the contents of the URL” as the best Default Application setting for starting konqueror and having it integrate well with akregator.

Oh, and spellcheck does not seem to work with webkit, even though the settings say that it should.

They’re completely different!

Javascript is a Web scripting language used by very many websites. Javascript interpretation is built into your browser - if you disable it, you’ll break lots of websites.

Java is a full-fledged programming language. This is not built into your browser; the IcedTea (or Oracle) browser plugin allows your browser to load Java applets. These were popular about ten years ago; nowadays Java applets are quite rare and the plugin is mostly just a security risk. You can safely disable it wherever your browser lets you manage plugins (I use neither Opera nor Konqueror).

Oh, and spellcheck does not seem to work with webkit, even though the settings say that it should.

Yes, this was my experience as well.

I’m back to “in an application based on the contents of the URL” as the best Default Application setting for starting konqueror and having it integrate well with akregator.

There was a reason why I discarded this (default) set-up. I’m not sure but would guess that it had to do with apps not recognising any browser, maybe in particular non-kde software; possibly, it is related to the attempt to integrate Firefox into KDE as the default browser?

I experimented with that this morning. That setting is fine for starting konqueror. But then akregator starts a new instance of konqueror for opening a message in the browser, instead of using a tab in the existing browser.

I do not use Akregator much but opened Kontact, went to Akregator and opened some feed links from there. No separate Konqueror session was started it was just embedded in the Kontact suite with tabs opening whenever I opened a new link (URL). I guess you use it differently? I really haven’t got a clue what is a normal way (if there is one) to use Akregator, however it seemed to work all right reading the already present feeds from OpenSuSE and KDE this way.

Cheers

Alright, thank you!

So the IcedTea plug-in isn’t usually needed either, and in any case will not load Java applets if Java is not enabled in the browser?

A duplicate, ignore this post!

So the IcedTea plug-in isn’t usually needed either, and in any case will not load Java applets if Java is not enabled in the browser?

Just to elaborate a bit further. In Konqueror, if I understand this properly, I can enable/disable Java as well as having the IcedTea plug-in available or not; these settings are separate and managed in different places. But in order to have IcedTea loading a Java applet I have to have Java enabled in the browser, is this correct?

On 2012-12-17 03:36, Golbats Everywhere wrote:

> browser to load Java -applets-. These were popular about ten years ago;
> nowadays Java applets are quite rare and the plugin is mostly just a
> security risk. You can safely disable it wherever your browser lets you
> manage plugins (I use neither Opera nor Konqueror).

They are used by banks, for example. My country tax site uses it, and
some other government sites IIRC. Some others use PDF forms (which also
uses javscript).


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))