(Beginner) Help configuring to network

Hello, I just need some help. I had a dead computer (no OS) that i booted from USB with newest OpenSUSE.
During the installation i skipped every part including network, to deal with that post install.
I am trying to connect to internet, and ive been trying in YaST.
All i want is to access the internet.

I’ll try and provide some information to what I’ve tried.

YaST - > Netowork settings i clicked wireless adapter and edit, put in all my stuff it found my home network and i filled in everything and DHCP etc. I used the Wicked Service because whenever i tried using Network Manager it said it required a program to run, which is a program i couldnt find.

So using the wicked service i put in all my stuff and clicked ok and i got an error where it cannot access installation media for some packet. This is I assume because during installation i didnt configure anything with network which i know i shouldve done but opensuse network configuration had me very confused so i didnt deal with it then. When i click OK on the network settings in YaST i get the error and it just doesnt seem to go anywhere. Im assuming the error for why it cant access installation media is because im not already connected to anything.

So if anyone can help me that is great. Most of the guides ive read seem to take into account that you configured everything during installation.
Please try and explain in simple terms as you would to a child as it is my first time using this OS. Let me know any information you need from me in order to answer me how to get past the error (in other words, access installation media), how to set up the network card and go on the internet etc.

Apologies for being a bit computer illiterate.

Remove the install media from the repo list Look at the URLs it is pretty obvious which it is

Show lsusb to see what wireless chip set you have. Some will know the package you need.

I’d guess that your easiest course moving forward is to re-install, but configure your networking during your installation.

It would also be helpful to know exactly what is on your USB stick (where did you get whatever is installed on the USB stick?), it might be only a boot disk, it could be a network install image or a full DVD image, or it could be a LiveCD image. Each type of image has varying amounts of data that might or might not provide what you’re missing.

But, all things equal… Re-installing avoids all sorts of troubleshooting if it really can install openSUSE on your system.


I installed opensuse from here https://software.opensuse.org/421/en and i picked the first option that says 4.7 GB also suitable for usb stick and i used imageusb to write it to the usb.

Incase it is useful information, I’ll add that I did not click “check installation media” on the first screen I simply clicked installation.

If installing everything over again is my best option how do I erase the OpenSUSE that is currently on the computer?

Sounds like if you did install to your hard drive, your USB key is your install source.
This likely means that you removed your USB key when you tried to install and configure networking.

You should know that if you use Wicked, you can only configure one wireless network connection and if you connect to another network your currents settings will be lost. If you want to configure network connections which can be saved, you need to switch from Wicked to Network Manager.


I didnt really *want *to use wicked it was just that it seemed like my only option, because when i was in yast -> network settings it said wicked and network service manager and when i clicked network service manager and “OK” it said it requires a panel program to run. But i have not been able to find Network Service Manager. Could you tell me where i should be able to find it?

I did remove my USB key after installation because i thought there was no use leaving it stuck in the computer after suse was installed. Are you saying I need to keep the USB key in the computer when i do e.g set up network because it is my install source?

Update, I turned on my comp i put in the USB key in incase it helped. Somehow it said network manager was enabled when i went into YaST, and magically the internet signal icon appeared bottom right corner. So now i am connected to my home network at least. But still i have not done anything regarding network card or any of that sort of configuration, unless that is already taken care of with network manager and DHCP?
Let me know what else i should configure if there are any other things.

If you are connected you are connected. Nothing to do unless there is a problem