BCM4312 detected but not connecting to networks.

Ok yesterday I tried to update to the Broadcom hybrid_wl driver instead of ndiswrapper. However that didn’t work as when I got it installed although I could detect wireless access points I couldn’t connect. I tried to go back to ndiswrapper however I’m having the same problem I could detect the networks It wouldn’t connect.

/usr/bin/lsusb
Bus 001 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]


/sbin/lspci
30:00.0 Network controller: Broadcom Corporation BCM4312 802.11a/b/g (rev 02)

ndiswrapper is loaded at boot.
b43, ssb and wl are blacklisted.

I could use any help I can get as I have spent the last 2 days trying to fix this and have failed.

Thanks in advanced.

I do not believe that the Broadcom hybrid driver works on a device as old as
BCM4312, but b43/ssb will work for that one.

Just run the script

/usr/sbin/install_bcm43xx_firmware

(requires network access), remove ssb and b43 from your blacklist, and keep
ndiswrapper from loading.

Larry

Boy this is getting old fast. Nope same problem I can detect networks but cant connect.

I have the installation dvd around here somewhere I might try to go back to a clean start and see if I have any better luck.

I really don’t understand why this isn’t working though.

Also Broadcom claims support for the BCM4312 Chipset in its Linux driver. Broadcom Corporation - Broadcom 802.11 Linux STA driver

Ok sorry for the double post but It appears I cant edit the above.

I went with my clean install idea. It may have been a bit premature but that’s what I decided to do and what you suggested worked within seconds of the install finishing.

I dont exactly know why it didnt work earlier I may have been doing something wrong but everything is up and running now. Now I just have to update everything to the stage I had it at previously.