Battery dying too fast?

Hey i seem to have a problem with my battery going from 1 hour to a few minutes any ideas? on windoze it seems to be stable(2.4hrs) but on opensuse kde it sucks (especially gnome that’s a battery sucker) here’s info from

upower -i /org/freedesktop/UPower/devices/battery_BAT0
  • command i ran

native-path:          BAT0
  vendor:               ASUSTek
  model:                G74--52
  power supply:         yes
  updated:              Fri 27 Jun 2014 06:01:50 PM EDT (7 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    energy:              41.46 Wh
    energy-empty:        0 Wh
    energy-full:         72.915 Wh
    energy-full-design:  78 Wh
    energy-rate:         31.425 W
    voltage:             14.543 V
    time to empty:       1.3 hours
    percentage:          56%
    capacity:            93.4808%
    technology:          lithium-ion
  History (charge):
    1403906510  56.000  discharging
    1403906450  57.000  discharging
  History (rate):
    1403906510  31.425  discharging
    1403906480  46.995  discharging
    1403906450  45.570  discharging
    1403906420  50.265  discharging

OS Version -   Linux 3.11.10-17-desktop
 openSUSE 13.1 (Bottle) (x86_64)

KDE platform Version - 4.11.5

Also i am gonna metion my laptop has turbo mode in windows upto 2.9Ghz (max) my processor is an i7-2630QM and my gfx is an GTX 560M let me know if you need anything else …i wish my laptop was more portable but the battery limits it :open_mouth:

Most likely it’s an Optimus system, to confirm post the output of the following command.

/sbin/lspci | egrep 'VGA|3D'

Ran the command you said to run and here you go

01:00.0 VGA compatible controller: NVIDIA Corporation GF116M [GeForce GT 560M] (rev a1)

QE - yes that is the only thing that came out

Well surprise it wasn’t an Optimus. Have you installed any drivers for it, Nvidias drivers I believe have better power management than the standard nouveau? If you haven’t, add the Nvidia repo in Yast and install with Yast, you’ll also get an Nvidia applet for settings.

Yea i have installed the drivers and checked the settings it’s on adaptive which is set to auto and i put the Image settings to performance(there’s HQ/high quality and performance and sadly there’s no in between) and everything else is stock

My guess on how i can put this to last longer is lowering cpu speed from Ghz to Mhz - x.xxGhz to at least to 1.0Ghz or if possible 800Mhz and since i have a quad-core (4 threads in each system) i could put 2 threads to sleep and be running on dual --does this sound possible or do i risk messing my cpu up? :sarcastic: