Batch Convert CGM Images

Is there an easy way to batch convert CGM images into anything modern (preferably SVG, because they’re vector graphics)? The furthest I’ve gotten is ImageMagick, which tries to open them, but dies saying it can’t find “ralcgm”, mhich I can’t find in any repos.

Install and try uniconvertor.
Do a search:

uniconvertor fails with “Cannot load plugin module cgmloader”.

I haven’t used it myself. It uses sk1 libraries and you may report the problem to sK1 Project.
Actually, there is a slightly later version available from their site (you may try those to see if the same problem exists):
32 Bit:
64 Bit:

Though it is not in the repositories, there is still an rpm for it at
RPM Search PLD ralcgm-3.50-3.i386.rpm
which may be worth trying.

YaST should tell you if it has any dependencies which cannot be supported from the openSUSE repos.

SK1 errors out with “Cannot load filter cgmloader.CGMLoader”.

ImageMagick dies with "Delegate failed `“ralcgm -d ps -oC < “%i” > “%o” 2> “%Z”’ @ delegate.c/InvokeDelegate/1032:”

Running “ralcgm image.cgm” always quits with “***FATAL ERROR: CGMibin [146] Wrong Version number”.

I always you just convert. It should be installed by default


man convert for the options.

convert also gives me “convert: Delegate failed `“ralcgm” -d ps -oC < “%i” > “%o” 2> “%Z”’ @ delegate.c/InvokeDelegate/1032.”

You must have mucked up the Imagemagic install. Try uninstalling and then reinstall.

Not sure this is the problem from a quick google I would suspect you need ralcgm looking at the other delegates

convert -list delegate

I would expect you to be able to run the ralcgm from cli now not checked but i have found it here Index of /download/delegates you seem to have an rpm but I suspect it may not work so what I did…

Go to here get the src.rpm RPM Search PLD ralcgm-3.50-1.i386.rpm install it. This won’t build so you need this spec file it actually only mods 2 lines the patch needs a 0 and optflags instead of the PLD version.

rpmbuild -bb /usr/src/packages/SPECS/ralcgm.spec

then install with zypper in /usr/src/packages/i586/ralcgm.rpm

I’ve tested with this file CGM Image Test Page it works fine and I get the error without this installed and convert works fine with it.

It works on the test file, but none of the CGMs I have. (Still the same error.) These files display fine with the Micrografx ActiveCGM plugin for IE5 under Win95; so, I know they aren’t corrupt. I think there’s a problem with ralcgm (the program itself, not my installation).

Got a sample, you can share, intrigued where you got ralcgm from? I never found it, and trying without it installed didn’t work for me on the sample.

I got the ralcgm SRPM and built it per this post. Here’s a sample file I’m trying to open:

OK well some investigating I would say it is not possible. If you run it through ralcgm you’ll get a new error message.
cgminbin 146 error something like that(man ralcgm) if you google the error you get one hit on a debian bug report it looks like it is the format.

Being proprietary I imagine it is in a grey area I also like you had a quick go with uniconvertor tracking that error got me here sK1 Project - Support Forum: Cannot load plugin module cgmloader under Windows XP SP3

So short answer you can’t at the moment.

It would seem and if I was to expect any one it would look like uniconvertor but it is a feature request really.

Wine to the rescue I just tried got this from total cad converter Wine demoware I think, but google plenty about

Svg from the file Why won’t the forum show svg (hehe finding a host was hard enough)