Basic Mounting problem.

When i click on my HDD to access it it says :“Failed to execute child process “gnome-mount” (No such file or directory)”. What can i do?

Attempt to mount the drive with the mount command with a terminal: mount -t ext3 /dev/sda1 /mnt (for example)

I didn’t know the command because the other distros i have used are different.

command doesnt work?

What HD
Post su terminal output of :

fdisk -l

Identify the relevant section

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x05dccb24

Device Boot Start End Blocks Id System
/dev/sda1 1 8624 69272248+ 7 HPFS/NTFS
/dev/sda2 * 10409 19457 72686092+ f W95 Ext’d (LBA)
/dev/sda3 8625 10408 14329980 82 Linux swap / Solaris
/dev/sda5 10409 19457 72686061 83 Linux

Partition table entries are not in disk order

i would assume that the HDD i want to mount is sda1 because it is NTFS but im new to opensuse so its slightly different to the other distros i’ve been using.

jf812 wrote:
> command doesnt work?

That is not very enlightening! What fails? Does it give an error message? Did
you run the command as root?

heres what it says:
root’s password:
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount -t fstype] something somewhere’.
Details found in /etc/fstab may be omitted.
mount -a -t|-O] … : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
One can change the type of mount containing the directory dir:
mount --make-shared dir
mount --make-slave dir
mount --make-private dir
mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
mount --make-rshared dir
mount --make-rslave dir
mount --make-rprivate dir
mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: -nfFrsvw] -o options] -p passwdfd].
For many more details, say man 8 mount .

Please now post the contents of

command not found

kdesu kwrite /etc/fstab


gnomesu gedit /etc/fstab

/dev/disk/by-id/ata-WDC_WD1600JS-55NCB1_WD-WMANM1690021-part3 swap swap defaults 0 0
/dev/disk/by-id/ata-WDC_WD1600JS-55NCB1_WD-WMANM1690021-part5 / ext3 acl,user_xattr 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

When you see the ntfs entry in fstab it will likely have info somethoing like this: ntfs-3g uid=1000,gid=100,umask=0022 0 0

change it to just

ntfs-3g defaults 0 0

save and reboot.

now try

If you don’t follow, wait till you get a edited response to doing this

OK it’s not there
create a folder in your home/username*/windows_C
*username = your username
the folder you are creating is windows_C

add this

/dev/sda1 /home/username*/windows_C ntfs-3g defaults 0 0

Check this
FSTAB - Editing Manually - openSUSE Forums

well now it just says only root can mount it.

If you trying to mount the Windows partition use the following command:

mount -t ntfs-3g /dev/sda1 /mnt
This command will mount it to your /mnt directory.

If you trying to mount the Linux partition use the following command:

mount -t ext3 /dev/sda5 /mnt

When your ready to unmount the drive you can use the umount command.