Banshee stopped working after yesterday's updates

Apper prompted me for updates yesterday. I was playing music in Banshee as the updates took place. After the updates, when I re-launched Banshee and tried to play music, even the same songs I played a few minutes before, I got this:

/usr/lib/gst-install-plugins-helper requires an additional plugin to decode this file

ID3 tag demuxerq

As always, with a message like that, it gives an option to search for the missing plugin, and it fails to find anything. I’m in the middle of some work on re-tagging a few tracks, and now suddenly I can’t do anything. Anyone know how I can fix this?

Here’s a list of yesterday’s updates:

gmplayer-1.1+35127-2.30.x86_64 Tue May 28 10:07:44 2013
smplayer-0.8.5-1.5.x86_64 Tue May 28 10:07:39 2013
vlc-aout-pulse-2.0.6-127.3.x86_64 Tue May 28 10:07:36 2013
amarok-lang-2.7.1-13.3.noarch Tue May 28 10:07:35 2013
MPlayer-1.1+35127-2.30.x86_64 Tue May 28 10:07:24 2013
vlc-2.0.6-127.3.x86_64 Tue May 28 10:07:14 2013
amarok-2.7.1-13.3.x86_64 Tue May 28 10:07:02 2013
flash-player-kde4- Tue May 28 10:06:48 2013
acroread-browser-plugin-9.5.5-4.1.i586 Tue May 28 10:06:47 2013
flash-player- Tue May 28 10:06:42 2013
acroread-9.5.5-4.1.i586 Tue May 28 10:06:23 2013
gtk2-branding-openSUSE-12.2-4.4.1.noarch Tue May 28 10:06:10 2013
MozillaFirefox-21.0-1.18.1.x86_64 Tue May 28 10:05:51 2013
gtk2-metatheme-adwaita-3.6.5-3.8.1.noarch Tue May 28 10:05:43 2013
MozillaThunderbird-17.0.6-61.13.1.x86_64 Tue May 28 10:05:26 2013
gtk2-theming-engine-adwaita-3.6.5-3.8.1.x86_64 Tue May 28 10:05:17 2013
MozillaFirefox-branding-openSUSE-21-2.5.1.x86_64 Tue May 28 10:05:17 2013
gtk2-immodule-vietnamese-2.24.18-2.4.2.x86_64 Tue May 28 10:05:16 2013
gtk2-immodule-thai-2.24.18-2.4.2.x86_64 Tue May 28 10:05:16 2013
gtk2-immodule-inuktitut-2.24.18-2.4.2.x86_64 Tue May 28 10:05:16 2013
gtk2-immodule-amharic-2.24.18-2.4.2.x86_64 Tue May 28 10:05:15 2013
yast2-installation-2.23.15-1.12.2.noarch Tue May 28 10:05:13 2013
yast2-country-2.23.2-1.4.1.x86_64 Tue May 28 10:05:10 2013
gtk3-metatheme-adwaita-3.6.5-3.8.1.noarch Tue May 28 10:05:06 2013
libgtk-2_0-0-2.24.18-2.4.2.x86_64 Tue May 28 10:05:04 2013
yast2-country-data-2.23.2-1.4.1.x86_64 Tue May 28 10:05:03 2013
libphonon4-4.6.0-7.4.1.x86_64 Tue May 28 10:05:02 2013
mozilla-nspr-4.9.6-1.7.1.x86_64 Tue May 28 10:05:01 2013
icedtea-web-1.4-4.14.1.x86_64 Tue May 28 10:05:00 2013
gtk3-theming-engine-adwaita-3.6.5-3.8.1.x86_64 Tue May 28 10:04:59 2013
gtk2-tools-2.24.18-2.4.2.x86_64 Tue May 28 10:04:58 2013
enigmail-1.5.1+17.0.6-61.13.1.x86_64 Tue May 28 10:04:57 2013
cryptsetup-mkinitrd-0_201206151440-3.4.1.x86_64 Tue May 28 10:04:53 2013
metatheme-adwaita-common-3.6.5-3.8.1.noarch Tue May 28 10:04:52 2013
gtk2-data-2.24.18-2.4.2.noarch Tue May 28 10:04:47 2013
wine-gecko-2.21-38.1.noarch Tue May 28 10:04:46 2013
gstreamer-0_10-plugins-bad-orig-addon-0.10.23-19.30.x86_64 Tue May 28 10:04:37 2013
gstreamer-0_10-plugins-bad-lang-0.10.23-19.30.noarch Tue May 28 10:04:36 2013
gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.24.x86_64 Tue May 28 10:04:34 2013
gstreamer-0_10-plugins-bad-0.10.23-19.30.x86_64 Tue May 28 10:04:32 2013
gstreamer-0_10-plugins-good-extra-0.10.31-11.28.x86_64 Tue May 28 10:04:19 2013
vlc-qt-2.0.6-127.3.x86_64 Tue May 28 10:04:17 2013
gstreamer-0_10-plugins-ugly-0.10.19-10.24.x86_64 Tue May 28 10:04:13 2013
libgstbasecamerabinsrc-0_10-23-0.10.23-19.30.x86_64 Tue May 28 10:04:08 2013
gstreamer-0_10-plugin-gnomevfs-0.10.36-9.28.x86_64 Tue May 28 10:04:07 2013
gstreamer-0_10-plugins-good-0.10.31-11.28.x86_64 Tue May 28 10:04:05 2013
vlc-noX-2.0.6-127.3.x86_64 Tue May 28 10:03:42 2013
libgstbasevideo-0_10-23-0.10.23-19.30.x86_64 Tue May 28 10:03:24 2013
libgstvdp-0_10-23-0.10.23-19.30.x86_64 Tue May 28 10:03:23 2013
libgstapp-0_10-0-0.10.36-9.28.x86_64 Tue May 28 10:03:23 2013
libvlc5-2.0.6-127.3.x86_64 Tue May 28 10:03:22 2013
k3b-codecs-2.0.2-15.44.x86_64 Tue May 28 10:03:22 2013
libgstinterfaces-0_10-0-0.10.36-9.28.x86_64 Tue May 28 10:03:21 2013
libxine2-codecs-1.2.2-83.3.x86_64 Tue May 28 10:03:19 2013
libxine2-pulse-1.2.2-83.3.x86_64 Tue May 28 10:03:18 2013
wine-mp3-1.1.39-12.27.i586 Tue May 28 10:03:17 2013
libvlccore5-2.0.6-127.3.x86_64 Tue May 28 10:03:16 2013
libgstapp-0_10-0-32bit-0.10.36-9.28.x86_64 Tue May 28 10:03:15 2013
k3b-2.0.2-15.44.x86_64 Tue May 28 10:03:09 2013
gstreamer-0_10-plugins-base-0.10.36-9.28.x86_64 Tue May 28 10:03:04 2013
chromium-pepper-flash-11.7.700.203-1.1.x86_64 Tue May 28 10:03:02 2013
libgstphotography-0_10-23-0.10.23-19.30.x86_64 Tue May 28 10:03:00 2013
libxine2-1.2.2-83.3.x86_64 Tue May 28 10:02:58 2013
libmpg123-0-32bit-1.15.4-1.1.x86_64 Tue May 28 10:02:44 2013
libmpg123-0-1.15.4-1.1.x86_64 Tue May 28 10:02:43 2013
libgstcodecparsers-0_10-23-0.10.23-19.30.x86_64 Tue May 28 10:02:42 2013
libgstsignalprocessor-0_10-23-0.10.23-19.30.x86_64 Tue May 28 10:02:40 2013
chromium-ffmpeg-29.0.1517.0-101.1.x86_64 Tue May 28 10:02:39 2013
gecko-mediaplayer-1.0.8-1.4.x86_64 Tue May 28 10:02:36 2013

Thank you,


Some of your gstreamer-0_10 packages come from the standard openSUSE repo instead of Packman, f.e. gstreamer-0_10-plugins-ugly. (I don’t want to check the whole list though)
Please check all of those and switch them to the Packman versions if necessary.

A quick way to do that would be to open YaST->Software Management, click on View->Repositories, select your Packman repo on the left, and click on “Switch all system packages to the versions in this repository” right above the package list.

Oops, sorry. I was wrong, maybe I slipped to the wrong line when checking the versions.

Nevertheless, you should check if all your gstreamer packages are from Packman.

I had already switched all system packages to Packman shortly after installing OpenSUSE 12.3, but I ran it again just in case, and I still have the same issue. I also ran mmcheck and checked the gstreamer packages with it, and it shows them all from Packman.

Any other ideas?

Thank you!


Do you get some output if you run:

gst-inspect-0.10 id3demux


If it cannot find it, try to delete the directory $HOME/.gstreamer-0.10/ and run that command again.

I did as suggested. The first result was:

$gst-inspect-0.10 id3demux
No such element or plugin $gst-inspect-0.10 id3demux
No such element or plugin 'id3demux''id3demux'

I removed the directory .gstreamer-0.10 in my home directory and ran the command again. The result was:

$gst-inspect-0.10 id3demux

(gst-plugin-scanner:31695): GStreamer-WARNING **: Failed to load plugin '/usr/lib64/gstreamer-0.10/': /usr/lib64/gstreamer-0.10/ undefined symbol: dc1394_iso_release_all
Factory Details:
  Long name:    ID3 tag demuxer
  Class:        Codec/Demuxer/Metadata
  Description:  Read and output ID3v1 and ID3v2 tags while demuxing the contents
  Author(s):    Jan Schmidt <>
  Rank:         primary (256)

Plugin Details:
  Name:                 id3demux
  Description:          Demux ID3v1 and ID3v2 tags from a file
  Filename:             /usr/lib64/gstreamer-0.10/
  Version:              0.10.31
  License:              LGPL
  Source module:        gst-plugins-good
  Source release date:  2012-02-20
  Binary package:       GStreamer Good Plug-ins source release
  Origin URL:           Unknown package origin


Pad Templates:
  SINK template: 'sink'
    Availability: Always

  SRC template: 'src'
    Availability: Sometimes

Element Flags:
  no flags set

Element Implementation:
  Has change_state() function: gst_tag_demux_change_state
  Has custom save_thyself() function: gst_element_save_thyself
  Has custom restore_thyself() function: gst_element_restore_thyself

Element has no clocking capabilities.
Element has no indexing capabilities.
Element has no URI handling capabilities.

  SINK: 'sink'
      Has chainfunc(): gst_tag_demux_chain
      Has custom eventfunc(): gst_tag_demux_sink_event
      Has custom queryfunc(): gst_pad_query_default
      Has custom iterintlinkfunc(): gst_pad_iterate_internal_links_default
      Has acceptcapsfunc(): gst_pad_acceptcaps_default
    Pad Template: 'sink'

Element Properties:
  name                : The name of the object
                        flags: readable, writable
                        String. Default: "id3demux0"
  prefer-v1           : Prefer tags from ID3v1 tag at end of file when both ID3v1 and ID3v2 tags are present
                        flags: readable, writable
                        Boolean. Default: false

Element Signals:
  "pad-added" :  void user_function (GstElement* object,
                                     GstPad* arg0,
                                     gpointer user_data);
  "pad-removed" :  void user_function (GstElement* object,
                                       GstPad* arg0,
                                       gpointer user_data);
  "no-more-pads" :  void user_function (GstElement* object,
                                        gpointer user_data);

Interestingly, I can now play the files in Banshee, so apparently whatever was in the .gstreamer-0.10 directory must have been corrupt. Everything is working again. Thank you wolfi323.

RESOLUTION: Remove $HOME/.gstreamer-0.10/

This directory contains the plugins repository, i.e. a cache for the list of plugins that are available and their properties.

You do have one gstreamer problem left:

$gst-inspect-0.10 id3demux

(gst-plugin-scanner:31695): **GStreamer-WARNING : Failed to load plugin ‘/usr/lib64/gstreamer-0.10/’: /usr/lib64/gstreamer-0.10/ undefined symbol: dc1394_iso_release_all

So the dc1394 (FireWire) plugin wouldn’t work.
If you want to solve this as well (I guess you don’t need this plugin, but anyway), please check that you have libdc1394-22 from the standard openSUSE repo installed. You seem to have only an older version…