Banshee Refuses to Start

Hey all,

I just installed Bansee and when I run it, I get this:

[Info  17:07:02.591] Running Banshee 1.5.1: [source-tarball (linux-gnu, i686) @ 2009-11-09 16:30:50 NZDT]
Stacktrace:

  at (wrapper managed-to-native) Banshee.GStreamer.Service.gstreamer_initialize (bool,Banshee.GStreamer.Service/BansheeLogHandler) <0x00004>
  at (wrapper managed-to-native) Banshee.GStreamer.Service.gstreamer_initialize (bool,Banshee.GStreamer.Service/BansheeLogHandler) <0xffffffff>
  at Banshee.GStreamer.Service.Banshee.ServiceStack.IExtensionService.Initialize () <0x0014b>
  at Banshee.ServiceStack.ServiceManager.StartExtension (Mono.Addins.TypeExtensionNode) <0x0011f>
  at Banshee.ServiceStack.ServiceManager.Run () <0x00126>
  at Banshee.ServiceStack.Application.Run () <0x0004b>
  at Banshee.Gui.GtkBaseClient.Initialize (bool) <0x001b7>
  at Banshee.Gui.GtkBaseClient..ctor (bool,string) <0x00023>
  at Banshee.Gui.GtkBaseClient..ctor () <0x00017>
  at Nereid.Client..ctor () <0x00010>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>
  at (wrapper managed-to-native) System.Reflection.MonoCMethod.InternalInvoke (object,object],System.Exception&) <0x00004>
  at (wrapper managed-to-native) System.Reflection.MonoCMethod.InternalInvoke (object,object],System.Exception&) <0xffffffff>
  at System.Reflection.MonoCMethod.Invoke (object,System.Reflection.BindingFlags,System.Reflection.Binder,object],System.Globalization.CultureInfo) <0x000f1>
  at System.Reflection.MonoCMethod.Invoke (System.Reflection.BindingFlags,System.Reflection.Binder,object],System.Globalization.CultureInfo) <0x00027>
  at System.Reflection.ConstructorInfo.Invoke (object]) <0x00042>
  at System.Activator.CreateInstance (System.Type,bool) <0x0010d>
  at System.Activator.CreateInstance (System.Type) <0x00012>
  at Banshee.Gui.GtkBaseClient.Startup () <0x0001a>
  at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.CleanRoomStartup/StartupInvocationHandler) <0x00089>
  at Banshee.Gui.GtkBaseClient.Startup<Nereid.Client> () <0x0004d>
  at Banshee.Gui.GtkBaseClient.Startup<Nereid.Client> (string]) <0x000c0>
  at Nereid.Client.Main (string]) <0x00015>
  at (wrapper runtime-invoke) Nereid.Client.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>
  at (wrapper managed-to-native) System.AppDomain.ExecuteAssembly (System.Reflection.Assembly,string]) <0x00004>
  at (wrapper managed-to-native) System.AppDomain.ExecuteAssembly (System.Reflection.Assembly,string]) <0xffffffff>
  at System.AppDomain.ExecuteAssemblyInternal (System.Reflection.Assembly,string]) <0x0002b>
  at System.AppDomain.ExecuteAssembly (string,System.Security.Policy.Evidence,string]) <0x00025>
  at (wrapper remoting-invoke-with-check) System.AppDomain.ExecuteAssembly (string,System.Security.Policy.Evidence,string]) <0xffffffff>
  at System.AppDomain.ExecuteAssembly (string) <0x00019>
  at (wrapper remoting-invoke-with-check) System.AppDomain.ExecuteAssembly (string) <0xffffffff>
  at Booter.Booter.BootClient (string) <0x00069>
  at Booter.Booter.Main () <0x00178>
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

Inconsistency detected by ld.so: dl-open.c: 256: dl_open_worker: Assertion `_dl_debug_initialize (0, args-&gt;nsid)-&gt;r_state == RT_CONSISTENT' failed!
Could not initialize GStreamer: Error re-scanning registry , child terminated by signal

Running OpenSuse 11.2 Final RC, GNOME.

Any ideas?
Thanks.

Hi
Did you install from source? Why not run the later version that came
with 11.2 RC2 which is 1.6 beta?

openSUSE repository as that

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 2:41, 2 users, load average: 1.40, 0.53, 0.24
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Yes I did, it seemed to be the later version? I installed 1.51, Suse is 1.6beta which is 1.50 I think.

Hi
So you don’t get the error from the default on that comes with 11.2?
AFAIK banshee-1-1.5.1 is the version installed with 11.2? Are there
some features that are missing on the default one? Just trying to
understand your requirement to upgrade :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 3:20, 2 users, load average: 0.09, 0.10, 0.09
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

I had been having problems with Banshee crashing while playing FLAC, or attempting to play vidoes. (Yes I did get all the codecs, but ntohignt seemed to work, so I came to the conclusion that there is a problem with Banshee)
So I thought I’d be smart and get it from them directly and try that. (I thought it was a different version, now I am not so sure.)
Didn’t quite work out how I had planned.