Banshee 2.0 "export playlist" and "import playlist" results differ

I’m new to banshee but playing with it to see if I like it or not.
I have a playlist of 634 tracks that I export to a file. I then try
to import that same file and only 627 tracks get imported into
the created playlist. The 7 tracks that are missing are:

#EXTINF:125,Elvis Presley - Don’t Be Cruel
…/…/…/…/media/LinuxHD/Music/Elvis Presley/Elv1s 30 #1 Hits/02. Don’t Be Cruel.mp3
#EXTINF:189,Elvis Presley - Are You Lonesome Tonight?
…/…/…/…/media/LinuxHD/Music/Elvis Presley/Elv1s 30 #1 Hits/16. Are You Lonesome Tonight_.mp3
#EXTINF:181,Elvis Presley - Can’t Help Falling In Love
…/…/…/…/media/LinuxHD/Music/Elvis Presley/Elv1s 30 #1 Hits/20. Can’t Help Falling In Love.mp3
#EXTINF:146,Elvis Presley - Crying In The Chapel
…/…/…/…/media/LinuxHD/Music/Elvis Presley/Elv1s 30 #1 Hits/25. Crying In The Chapel.mp3
#EXTINF:185,Elvis Presley - In The Ghetto
…/…/…/…/media/LinuxHD/Music/Elvis Presley/Elv1s 30 #1 Hits/26. In The Ghetto.mp3
#EXTINF:275,Elvis Presley - Suspicious Minds
…/…/…/…/media/LinuxHD/Music/Elvis Presley/Elv1s 30 #1 Hits/27. Suspicious Minds.mp3
#EXTINF:149,Elvis Presley - The Wonder Of You
…/…/…/…/media/LinuxHD/Music/Elvis Presley/Elv1s 30 #1 Hits/28. The Wonder Of You.mp3

The only thing unique to these 7 tracks is the # symbol in the album name.

I’m running openSUSE 11.4 32-bit with the Gnome desktop.

Thats a bug I guess.

Please file one at banshees bugzilla.

https://bugzilla.gnome.org/enter_bug.cgi?product=banshee&version=git
+master&bug_severity=enhancement

//Zaitor

On winamp playlists, the pound sign (#) normally indicates a new title follows. Banshee is reading the # in the path as that. As Zaitor says, report this as a bug.