baloosearch stopped working in dolphin

Today’s update updated libqt4 to verison 4.8.6-7.1 along with several other qt4* files.

Now Dolphin version 15.12.2 no longer works correctly when I try to find a file.

I note that Dolphin is using qt 5.5.1 and the above update was qt4, I don’t understand the inner workings of all this stuff and wonder if this is the problem.

What would be the best way for me to get baloosearch working again?

No ideas on this?

Guess I’ll start removing files from the last update one by one until I get search back again.

The Qt4 update should not have any influence on Baloo.

Unless you still have the KDE4 version of baloo installed, but then search in dolphin wouldn’t have works at all before that…

What repos are you using and what baloo packages do you have installed?

zypper lr -d
rpm -qa | grep baloo

Also, I would suggest to delete ~/.local/share/baloo/ to force everything to being reindexed again.
You might have to logout afterwards though or at least run “balooctl restart” afterwards, but I’m not sure.

And check in systemsettings5 whether baloo is actually enabled and the folders you want to search are not excluded. Although this shouldn’t change just by itself…

A possible test would also be to try running “baloosearch xxx” at the command line (as user).
“balooctl status” might give some clue as well.

The baloo pkgs are

 rpm -qa | grep baloo
libbaloowidgets4-4.14.3-2.3.x86_64
baloo5-5.19.0-6.2.x86_64
baloo5-widgets-15.12.2-12.1.x86_64
libbalooqueryparser4-4.14.3-2.4.x86_64
libbaloopim4-4.14.3-2.4.x86_64
baloo5-imports-5.19.0-6.2.x86_64
baloo-kioslaves-4.14.3-2.4.x86_64
baloo5-kioslaves-5.19.0-6.2.x86_64
baloo5-file-5.19.0-6.2.x86_64
libbaloofiles4-4.14.3-2.4.x86_64
baloo-core-4.14.3-2.4.x86_64
baloo5-lang-5.19.0-6.2.noarch
baloo5-tools-5.19.0-6.2.x86_64
baloo-pim-4.14.3-2.4.x86_64

Note that in the below list, only repo # 11, 12, 14, & 15 were Enabled when I last run an update. Repo #1 & #4 were added yesterday when I installed recoll because baloo was not working.

The repos are:

 zypper lr
#  | Alias                      | Name                                    | Enabled | GPG Check | Refresh
---+----------------------------+-----------------------------------------+---------+-----------+--------
 1 | KDE:Extra                  | KDE:Extra                               | No      | ----      | No     
 2 | MyUpdates                  | MyUpdates                               | No      | ----      | No     
 3 | Oracle_VirtualBox          | Oracle VirtualBox                       | No      | ----      | No     
 4 | download.opensuse.org-oss  | Main Repository (Sources)               | Yes     | (r ) Yes  | Yes    
 5 | ftp.gwdg.de-suse           | Packman Repository                      | Yes     | (r ) Yes  | Yes    
 6 | geeko.ioda.net-amd-fglrx_1 | AMD/ATI Graphics Drivers                | No      | ----      | No     
 7 | repo-debug                 | openSUSE-Leap-42.1-Debug                | No      | ----      | Yes    
 8 | repo-debug-non-oss         | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | Yes    
 9 | repo-debug-update          | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes    
10 | repo-debug-update-non-oss  | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes    
11 | repo-non-oss               | openSUSE-Leap-42.1-Non-Oss              | Yes     | (r ) Yes  | Yes    
12 | repo-oss                   | openSUSE-Leap-42.1-Oss                  | Yes     | (r ) Yes  | Yes    
13 | repo-source                | openSUSE-Leap-42.1-Source               | No      | ----      | Yes    
14 | repo-update                | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes  | Yes    
15 | repo-update-non-oss        | openSUSE-Leap-42.1-Update-Non-Oss       | Yes     | (r ) Yes  | Yes    


The commandline balooctr status shows running and the commandline search works perfectly.

Baloo is enabled in System Settings 5 and there are no restrictions configured.

I have not yet deleted ~/.local/share/baloo/ but will do that later on today.

Thank you for the reply and for the tip on baloosearch. I will be using that cmd quite often in everyday use.

[QUOTE=6520302;2772940The commandline balooctr status shows running and the commandline search works perfectly.

Baloo is enabled in System Settings 5 and there are no restrictions configured.

I have not yet deleted ~/.local/share/baloo/ but will do that later on today.
[/QUOTE]
Well, if baloosearch works, deleting this won’t help either I suppose.
You do have the KF5 baloosearch installed, after all.

Although deleting it wouldn’t harm either, it would just cause reindexing of everything.

Your package list looks ok.

Not sure at the moment what else to try.
It’s a bit late for me now though, I hope I’ll have another idea tomorrow… :wink:

Thank you so much for the suggestions.

I tried Dolphin as SU from the launcher menu and it worked fine.

So I did delete the suggested directory and rebooted. It works now!! Guess the index got corrupted up somehow.

And thanks again for the cmdline tip, it is very fast.

Probably, something like that.
Strange that baloosearch still worked then though, but well, at least the problem is solved… :wink:

And thanks again for the cmdline tip, it is very fast.

You’re welcome.
Just typing something into the KRunner dialog (Alt+F2, Alt+Space) or the application menu’s search field should use Baloo’s search as well (unless disabled).

I deleted ~/.local/share/baloo/

but filesystem search ist still not workin in dolphin.

so many annoyances with 42.1

Then post which baloo packages you have installed:

rpm -qa | grep baloo

And check that indexing is enabled in the settings (should be by default).
Note that indexing is only enabled for the home folder by default.

Also check in kinfocenter what the current state of the indexer is, or run “balooctl status”.

so many annoyances with 42.1

Then use something else.

This is not a problem of Leap 42.1 though.

baloo wasn’t running. balooctl enable does the trick