Baloo Using Excessive Disk I/O

After upgrading to KDE 4.13 through the Factory repo, I had issues with Baloo going crazy when BOINC was running, as BOINC writes to the disk constantly and Baloo went completely nuts trying to index everything in that folder. I excluded the BOINC directory in the Desktop Search GUI and the problem went away, and disk I/O returned to normal.

After removing the KDE factory repos and adding the KDE current ones, there were some more updates for KDE, xorg, etc. I’m assuming there were some more changes between the time the packages moved from one repo to another. Running iotop shows that baloo_file_cleaner is taking around 50% IO when absolutely nothing is running on the computer besides Linux kernel modules, KDE desktop, etc, and this has been going on for hours. I figured it may be indexing my files, but I don’t get why it would be re-indexing everything when Baloo had already indexed stuff after applying the first KDE 4.13 update. The Desktop Search GUI should offer a way for a user to disable the program, and I’m not the only one having this issue. My presumption is that Baloo is indexing nothing, and is stuck in some kind of endless loop. Just when Nepomuk was working good, they had to change it and release this complete garbage. Not only is Baloo broken, but they didn’t offer novice users a simple way to shut it off. Real smart thinking KDE devs.

More comments from frustrated users:

Here’s a tip for everyone: Don’t upgrade to KDE 4.13 like I did.

On 04/26/2014 12:06 AM, pirithous wrote:
> More comments from frustrated users:
> Here’s a tip for everyone: Don’t upgrade to KDE 4.13 like I did.

  1. Nepomuk was not just working (at least on my system), it used quite
    a bit of memory, especially if you tried to use it to do heavy indexing.

  2. I am using 4.13 and its working like a charm on my system. Baloo and
    Milou are really impressing me with their low memory usage and useful

With that said, you can check what Baloo is doing with this command

qdbus org.kde.baloo.file /indexer org.kde.baloo.file.statusMessage

Also check in ~/.local/share/baloo to see if it is writing to the
location because that is where it keeps its database.

Bring the Penguins Back!
openSUSE 13.1
KDE 4.11.4

  1. I am using 4.13 and its working like a charm on my system. Baloo and
    Milou are really impressing me with their low memory usage and useful

I can only report the same :slight_smile:

On this thread some additional information and observations.

On my desktop 13.1/KDE 4.12.4–>4.13.0, it took baloo_file_extractor almost 7 hours to do it’s first thing after upgrade, now all is quiet with baloo running.

Yep same here, the initial indexing took a really long time but now its not doing it anymore. But even when it was indexing stuff, I only saw it use up one core on the CPU while the RAM usage stayed pretty stable at 1.6GB. The only time I saw RAM go crazy is when you tell it to blacklist a folder it has already indexed, then the RAM usage goes from 1.6GB to 3.6GB rotfl!

When downloading files such as a torrent, Baloo causes non-stop accessing of the disk, and sucks 25% of one core as long as the download is going. Nepomuk never used to do that, and whoever was praising Baloo for its great performance obviously doesn’t download things such as torrents.

I have a 955BE as a CPU and just today I created ~50GB of files for a backup and didnt notice anything change. How is your system setup and what are your specs?

Also i do agree that it is strange you cannot disable Baloo.

Core i5 2500k, 8 GB memory, 1 TB hard drive. Not only did baloo_file_cleaner get stuck in an infinite loop yesterday and I had to kill the process, but as I wrote, Baloo doesn’t play nice with torrents, BOINC, or anything that is writing to the disk a lot. It tries to index immediately, and sucks CPU resources. Look around the internet…i’m not the only one experiencing issues.

Actually, baloo can be disabled, but not by a simple disable button. Instead, just exclude the users $HOME directory in System Settings > Desktop Search, then you’ll find there is nothing left to index, and baloo will switch off

Before excluding

ps -A|grep baloo
 1238 ?        00:00:01 baloo_file

After, it will be gone.

Simple. :slight_smile:

If you don’t like it, disable it as I’ve just described. (I have no issue with it though.)

Alternatively, edit ~/.kde4/share/config/baloofilerc and change




and it will leave you alone next login.

I see none of this negative behaviour

You and me both :slight_smile: …but I accept that there may be issues like that which pirithous has mentioned. However, this should be reported so that bugs can be squashed.

Can you try running BOINC and/or downloading about 5-10 large torrents at once and see what Baboon does? I’ll report the bug, but it already looks like there is enough backlash on the dev’s blog about this piece of software. It doesn’t always act up, but there is definitely something buggy about it that I would label as abnormal behavior.

I won’t be trying that, but you should definitely reporting any issues you’re experiencing with it, and I’m sure that you could exclude any directories associated with your torrents that might be impacting on baloo’s performance.


in Configure Desktop Search GUI
baloo can be switch-off by adding to
Do not search in these locations
/* (as root)

the same can be achieved if the same is done
as a user for the /home directory,
or any other directory for that user if selected

If only I can do things in an already frozen system.

Forgive me if I am wrong but doesn’t BOINC itself use up quite a bit of CPU power?

Either way, as you described before its probably because the torrents are constantly changing the file on the system so perhaps Baloo attempts to index it right away instead of once the torrent is finished. Reporting it is a good idea because I am sure they did not intend to have it behave this way. In the meantime, as deano suggested, why dont you blacklist the folders where your torrents download stuff to (or just disable it entirely)?

I installed ballo during my migration to kde4.13.0 on opensuse 12.3, after the first try it was ok, then using the laptop i7 8GB ram 1TB disk I disabled baloo in this way
disable indexing baloo edit ~/.kde4/share/config/baloofilerc and change
Indexing-Enabled=true to Indexing-Enabled=false
becouse the laptop was sticky and slow everything
and also knotes stop to working in a usable way

disabling baloo the laptop became responsive as in the past… but not knotes…

thanks :slight_smile: ciao :slight_smile: pier