baloo (KDE indexer) eats CPU time

On my Tumbleweed KDE, the KDE file indexer baloo_file - in particular the baloo-file-extractor process - is constantly eating up 25% of the CPU time, i.e. one out of the four cores. This is happening since one or two weeks, although I wouldn’t swear to that, could be longer. Its status message is:

balooctl status
Die Baloo-Dateiindizierung läuft
Indizierungsstatus: Inaktiv
41722/41723 Dateien indiziert
Der aktuelle Index hat eine Größe von 65,93 MiB

i.e. it seems to be missing one last file. This message is being posted all the same for the last one or two weeks.

Funny things are: baloo is not obviously reacting to commands such as

balooctl suspend
balooctl stop

It takes the system monitor to stop the baloo_file_extractor and baloo-file processes. At reboot, baloo is back to eating 25% of the CPU time. I haven’t tried to disable and re-enable baloo yet.

There are many forum posts on how to tame or discipline baloo. The “baloo flu” seems to be a common issue, occurring in a number of ways. However, I don’t like many of the recipes give in this and other (ArchLinux) fora, e.g. (a) exclude one’s home directory from the baloo indexing, or (b) just don’t run baloo at all.

I would really like to FIX and tame my baloo! Thus, my questions are:

  • Is there a way to find out which one file lets baloo get stuck - if that is what’s really happening? (I somehow can’t believe this 41722/41723 file status…)
  • How would I stop baloo, delete all index data, then restart baloo and let it run in peace until it might finish up?
  • I would hate to exclude my home dir from indexing. I know one of my hard disk partitions (mounted to a mount point in my home dir via fstab) is a tough one, 1 TB of audio files, the majority of them hi-res formats (i.e. large files of up to 1 GB each). I understand baloo is indexing the audio file metadata - any idea whether something peculiar might cause baloo to get stuck?

Excluding your homedir is not a solution, baloo is KDE’s indexer, meant to index your homedir, not the entire system. But …
From what I see the baloo database is corrupted. This cannot really be solved, but a solution for the CPU consumption could be to let baloo start over again. To do so, stop baloo, remove the baloo* files from ~/.config, remove ~/.local/share/baloo, and restart baloo. This may initially show some CPU consumption to, but that’s only because nothing has been indexed yet. After that, it should run quitely, albeit ( as a found ), that it will fire up for a couple of minutes if you dump a 40.000 files webenvironment on your laptop :stuck_out_tongue:

Thank you, Knurpht, your diagnosis and solution are spot-on. All settled.