bad functionality in Clementine in OpenSUSE 13.2

Well, to my dismay, Clementine 1.2.2 in my fresh Opensuse 13.2 has some annoying bad (or lack ?) of functionality:

  1. when removing (with DEL key) a music file from the playlist, there’s NO cursor onto next file in list ! (very annoying, but still something you can become accustomed and come to not lack any more after a while … but next one is absolutely unbearable:
  2. I find with horror that the module responsible for editing ID3 tags in mp3/flac/etc file DOES NOT work !!!
    I double checked in order that the files are not read-only (and they were not: permissions were 664), and the same with folder that hold those files. Unfortunately, I was not able to edit tags anymore :frowning:
    Has anyone else had same problems ? (especially with editing tags ?)

For the moment, I just removed Clementine 1.2.2, and installed the previous version, 1.1.1, from Opensuse 13.1 – along with dependencies needed from OS 13.1 (libGLEW1_9, libplist1); now I’m back to the previous state of experience with Clementine, something working OK.

The only (major) inconvenient is now that the automatic update applet now tries to update Clementine to the newly version, which I just don’t want to accept.
Any clue about how I can instruct the applet to disregard Clementine when checking updates available ?
Manually, in yast2 I can set clementine to protect it from be checked for updates available (option “protect - don’t modify”); is there something similar for the update applet ?

In Yast find the app mark it to not install

Okay,
for the part of keeping update applet (apper ?) to constantly find update to the new clementine, I solved it: just had to mark clementine as “protect - do not update” AND just click on the button “Accept” as if it should run the install process; now yast2 will remember to protect the package against further update checks, and apper too will not consider it when seeking new updates.

I would be happier, though, if the issue with clementine 1.2.2 will be solved in order to use it, instead as this older version.

Just a thought I have opensuse 13.2 but am using the latest version of clementine which is 1.2.3 from the factory repo:

http://download.opensuse.org/factory/repo/oss/suse/

Just tried to do the two things that are causing you difficulties and both worked fine.

Thanks.
Tried this myself.
But, unfortunatelly, things did not worked OK at my side :frowning:

  • after deleting some file from the playlist, “cursor” does not stays on the next file in list, but it just goes at the end of the list — this one I have already confirmed on several installations of version 1.2.3 on windows systems, and this seems a general behaviour;
  • trying to save something into some tag (for instance Author) does not do anything at all – I checked this with other ID3 editing tag software (kid3) and it really does not save anything !

So, I returned back to clementine 1.1.1, and stick with it.

Hello.

Another thought.
Instead of using the factory package of 1.2.3 you could try the one from multimedia:apps, that one is at least built for OS 13.2.
For OS 13.1 I use that repo.