bad experience zypper dup from 11.0 to 11.1

To share with you what happened when I attempted to upgrade my 11.0 64-bit mobo to 11.1 with zypper dup.
I read on this forum that you can upgrade from 11.0. to 11.1 by

  1. changing your repos to those of opensuse 11.1 (which you have to do manually for each, it’s a pity there’s nothing to automate this)
  2. zypper ref
  3. zypper dup
    That’s what I did. Took me ages to update my repos (you have to find the new URL for each one yourself). Then I exited my graphic session and logged in as root in a shell.
    Then zypper ref gave me an error on the main update repo. I ran it again and it went smoothly that second time (!).
    Then ran zypper dup. Had several dependencies conflicts, which I solved by choosing solution 1 (change vendor) or solution 2 (do not install okular for instance).
    After resolving the dependencies problems, it told me it was going to download 300.6M.
    During the download and install, the screen went completely black. After about an hour, I used the down arrow to see the result: “CommitingCommitResult 259 (errors 0, remaining 0, srcremaning 0)”
    issued “reboot” and the login window (which looked a bit different – newer KDE). Then, horror, impossible to log in: with KDE, IceWM, or in a console. in a console, I get “unknown module”, even with root. So I simply cannot log into my computer whatever I do.
    I had to pull out my opensuse 11.0 DVD to try to repair the system, to no avail.
    I then ran an “update” from that same DVD, and now I can log into my new 4.1.3 (KDE 4.1.3) "release 68.1 with my RT kernel (with the default kernel, I have a kernel panic).

So now I’m downloading the 11.1 DVD.

Any feedback/comments on my experience would be appreciated.